summaryrefslogtreecommitdiff
path: root/app-admin/filewatcher
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/filewatcher
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/filewatcher')
-rw-r--r--app-admin/filewatcher/Manifest4
-rw-r--r--app-admin/filewatcher/files/filewatcher.conf24
-rw-r--r--app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild38
-rw-r--r--app-admin/filewatcher/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/app-admin/filewatcher/Manifest b/app-admin/filewatcher/Manifest
new file mode 100644
index 000000000000..d2993e2ec3cf
--- /dev/null
+++ b/app-admin/filewatcher/Manifest
@@ -0,0 +1,4 @@
+AUX filewatcher.conf 567 BLAKE2B af300ec8d7c4017bfdff12423e409ed853ab39a7cf4cb3496a9d128de80d6d45137b3dfdead346d9777fd45a86baacd69f76e1d4157c05bd745c8e4b1872f579 SHA512 74108243a29e3993cf2c1b6bc4821907918e978a0bd7e6ca76c62172485ac94587a685c504fbb0a32a326e5537ebe00d0418f56229dc2031e3142773571ced14
+DIST filewatcher-2.4.6.tar.gz 37459 BLAKE2B 41fc1a6a289247d428cc3101eb9b437ae99d4b11c6df51c712a825cadba8ff8bc00cffa3cc4c4554565cebe596a821cac20a273453a186f2092ef93cb1752f7b SHA512 a6e1d2fb11f54352f963c21a1cbb42ceadcf3aff0ebf2b0e629d7827fada12c03531ecc9b9400afc65937830f92a0f16c54abd1cc034392351b72326943d6442
+EBUILD filewatcher-2.4.6-r1.ebuild 890 BLAKE2B e6671bd369acdf1c1c28094abd33989fe65decdd0320cff2ca1aab3fb660e5967b39ce81d8ef6a99e8aba90f5c9087a146b55ec17462c04d69b57c1c4297c88a SHA512 b0c53b07b6291277346de663325a8a88a1782ef752efe7a36a34d5d6584a0c154095ccb2ff56c3afab0711bbe866977ae40ba9c4213048f59c3e65b3361d28d4
+MISC metadata.xml 248 BLAKE2B f0d0956727aed0e1f5f6fd3be70e28c9080db1cd1657fb1a2e5dee93bc015c81561bcc8f51704fbd2b348c356aa353c6e4fb70a0f2afc7bc75d9ae5462488b1f SHA512 b9359e11a093d5e57800889f12683be0fc228d18dc9a63bd258d428185d825475089911629a9e34c53ae27cea7591caeb8ab8dee92d9bfe05d7037f48c3ee75e
diff --git a/app-admin/filewatcher/files/filewatcher.conf b/app-admin/filewatcher/files/filewatcher.conf
new file mode 100644
index 000000000000..e3358242759a
--- /dev/null
+++ b/app-admin/filewatcher/files/filewatcher.conf
@@ -0,0 +1,24 @@
+option archive-root /var/lib/filewatcher/archive
+option state-file /var/lib/filewatcher/state
+option warn-if-missing true
+option include-autopush true
+option skip-binary true
+
+# default notify via email to sysadm address
+option notify mailto:root
+# scan for archived files deleted from the filesystem
+option scan-frequency 4h
+watch ARCHIVE
+
+# system security files
+option scan-frequency 5m
+watch /etc/passwd
+watch /etc/group
+watch /sudoers
+
+
+# filewatcher and its configuration files
+option scan-frequency 30m
+watch /etc/filewatcher.conf
+watch /usr/sbin/filewatcher
+
diff --git a/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild b/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild
new file mode 100644
index 000000000000..db9d3becf660
--- /dev/null
+++ b/app-admin/filewatcher/filewatcher-2.4.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="File control configuration system and IDS"
+HOMEPAGE="https://sourceforge.net/projects/filewatcher/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-perl/MailTools
+ dev-vcs/rcs
+ virtual/mta"
+
+DOCS=( Changes README )
+
+src_install() {
+ keepdir /var/lib/filewatcher /var/lib/filewatcher/archive
+ dosbin filewatcher
+ doman filewatcher.1
+ insinto /etc
+ doins "${FILESDIR}"/filewatcher.conf
+ einstalldocs
+}
+
+pkg_postinst() {
+ elog " A basic configuration has been provided in"
+ elog " /etc/filewatcher.conf. It is strongly"
+ elog " recommended that you invoke filewatcher via"
+ elog " crontab."
+ elog
+ elog " 55,25,40 * * * * root /usr/sbin/filewatcher"
+ elog " --config=/etc/filewatcher.conf"
+}
diff --git a/app-admin/filewatcher/metadata.xml b/app-admin/filewatcher/metadata.xml
new file mode 100644
index 000000000000..78a26da23d19
--- /dev/null
+++ b/app-admin/filewatcher/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">filewatcher</remote-id>
+ </upstream>
+</pkgmetadata>