summaryrefslogtreecommitdiff
path: root/app-admin/exo/exo-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-21 10:20:03 +0100
commit6f8038813c460b4f0572d5ef595cdfa94af3a94d (patch)
tree3509e94070265053394b7f2e30a779d7e60c2064 /app-admin/exo/exo-1.3.0.ebuild
parenteccb70a7f91b2d22582587f26d1a28bb31408b45 (diff)
gentoo resync : 21.05.2019
Diffstat (limited to 'app-admin/exo/exo-1.3.0.ebuild')
-rw-r--r--app-admin/exo/exo-1.3.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-admin/exo/exo-1.3.0.ebuild b/app-admin/exo/exo-1.3.0.ebuild
new file mode 100644
index 000000000000..ebb329b957ff
--- /dev/null
+++ b/app-admin/exo/exo-1.3.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Command-line tool for everything at Exoscale: compute, storage, dns."
+HOMEPAGE="https://exoscale.github.io/cli"
+SRC_URI="https://github.com/exoscale/cli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+DEPEND="dev-lang/go:="
+RESTRICT="strip"
+
+S="${WORKDIR}/cli-${PV}"
+
+src_compile() {
+ go build -mod vendor -o ${PN} || die "build failed"
+}
+
+src_install() {
+ dobin ${PN}
+}