summaryrefslogtreecommitdiff
path: root/app-admin/entr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-admin/entr
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-admin/entr')
-rw-r--r--app-admin/entr/Manifest5
-rw-r--r--app-admin/entr/entr-5.3.ebuild40
-rw-r--r--app-admin/entr/files/entr-5.3-no-which.patch16
-rw-r--r--app-admin/entr/metadata.xml8
4 files changed, 68 insertions, 1 deletions
diff --git a/app-admin/entr/Manifest b/app-admin/entr/Manifest
index d07da56d25b8..1de57815da29 100644
--- a/app-admin/entr/Manifest
+++ b/app-admin/entr/Manifest
@@ -1,3 +1,6 @@
+AUX entr-5.3-no-which.patch 495 BLAKE2B ca5ba048e53c4cdee12b88d792e5e7b6e5fae2185f5bd87bc306d36689fe7fb2697729cb4e77e6099226f77d682408d4416bf8f42479bcbd5c597acd5acfcfb4 SHA512 2a8a642b0bcc7c274634fe67e4c8b97ed038d1cd577175596ca35a92e9fddf78e7ea5ee6ef70f19bb43868c9e138ad7690f1a6368ac3e4b5d307a5e8bfe02aab
DIST entr-5.2.tar.gz 25834 BLAKE2B c14eddaaf26994679991c43b38dcea0f1cbf53ce517af462cfed9dea2c914d9c1719053cb3b9f28f04d0cbf8719fe5612963c1428832e02bd55545ba33c72556 SHA512 b12310b6695f0b3d3d830b651dd182ddf2321aad38f569066cc2e5b17570070e48eb4900725c88c1d31a8ff71099aba78fb7508ad60706265cbdf8f29257eaaa
+DIST entr-5.3.tar.gz 20905 BLAKE2B 79b4c39ee3f9530db1d8a6cd62a6aa925e201d6b5b370b25c3884b160a83658688204005db612b1d18743ba39f0de6ccad8492910142ebfff7b550a5ec48516d SHA512 b160cb60de99a743226b472256d937ef6ace54f5350a83420f59ac2706cd0fb042d6f85fcac6c73e76c161c6225b956df8b00156dea9ce55d8b8225e8ca13e7f
EBUILD entr-5.2.ebuild 611 BLAKE2B ae084f4e1104a3e8652ae939bc338cb36777ef2f380c328d449217a42caa9f0734369c1f872301732742b0845ac9fbf7989049119eb4196baf9711014cfd2f8d SHA512 9e07fe4c426f03c751e52c7f94ec0f0ee5799755e9cae56c47067e15fbc14898e6104fc1f2028b4efdc5f89dc703a8cc95dd5dd4ef786c9707bb97b6923431e9
-MISC metadata.xml 455 BLAKE2B 294fe2a1c6597cc0988c97a080f00c8dc1f48d96f87eecd329425d66f8bbb7e39b1152bcb7645f51b7cc0aa97186f05528c4766ae90e636ac5ab482dceac423c SHA512 d08a5678831d0d97c31588ffc0844acf137a0527d88c529a51d4c3a72f04ee71ea49450a79bd5a9a442c443c792b4d771bdff4551c9c64c2cacfd55048f40c94
+EBUILD entr-5.3.ebuild 707 BLAKE2B 9f6bba6002d70f17b8f2261e4308fefc46b29b1a9c7fca1b57b1c0449b6e8046f4e62db5e0f3eef1d13c98e0906e85beb88dabe442207e914985093922de24a6 SHA512 38f6b9a73bcb0503d14254463107a09b66ce0ee1875239f322d92531a6c5d50ce1be27f5b9dc4717e80902872e3a9c9a8ecc7c6afedd13b79ee614c819f1a8cb
+MISC metadata.xml 706 BLAKE2B d01cfcb5fccc39dfa4c298f3f741c9360ac6c77926bda0d3ade3db29e8c08a4a7a42a5d62c9c05eef73172c60aa7dba01da67747b8048dbb2b99a7af798a374b SHA512 d1ecfec008b55545b5a1317968a2d1067b72ef3f8a18d2473635994d6e47cb57b01dfb27c55e3dd3b38298a5657d12fb63c12ec47b127087d7900069d46fd593
diff --git a/app-admin/entr/entr-5.3.ebuild b/app-admin/entr/entr-5.3.ebuild
new file mode 100644
index 000000000000..cd6c30b6b897
--- /dev/null
+++ b/app-admin/entr/entr-5.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="
+ https://eradman.com/entrproject/
+ https://github.com/eradman/entr
+"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-editors/vim
+ app-misc/tmux
+ dev-vcs/git
+ sys-apps/file
+ )
+"
+
+PATCH=(
+ "${FILESDIR}/${P}-no-which.patch"
+)
+
+src_configure() {
+ tc-export CC
+ export PREFIX="${EPREFIX}/usr"
+ export SHELL="${BROOT}/bin/bash"
+
+ edo ./configure
+}
diff --git a/app-admin/entr/files/entr-5.3-no-which.patch b/app-admin/entr/files/entr-5.3-no-which.patch
new file mode 100644
index 000000000000..fbc96fe697f4
--- /dev/null
+++ b/app-admin/entr/files/entr-5.3-no-which.patch
@@ -0,0 +1,16 @@
+Upstream-PR: https://github.com/eradman/entr/pull/108
+
+diff --git a/system_test.sh b/system_test.sh
+index 2687bb3..dbec661 100755
+--- a/system_test.sh
++++ b/system_test.sh
+@@ -40,7 +40,7 @@ trap "$clear_tty; $clear_tmux; $clear_tmp" EXIT
+
+ utils="file pgrep git vim tmux"
+ for util in $utils; do
+- p=$(which $util 2> /dev/null) || {
++ p=$(command -pv $util) || {
+ echo "ERROR: could not locate the '$util' utility" >&2
+ echo "System tests depend on the following: $utils" >&2
+ exit 1
+--
diff --git a/app-admin/entr/metadata.xml b/app-admin/entr/metadata.xml
index e0bb95651e8f..c54583354751 100644
--- a/app-admin/entr/metadata.xml
+++ b/app-admin/entr/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
<maintainer type="person">
<email>monsieurp@gentoo.org</email>
<name>Patrice Clement</name>
@@ -9,6 +13,10 @@
<email>shell-tools@gentoo.org</email>
<name>Gentoo Shell Tools Project</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">eradman/entr</remote-id>
</upstream>