summaryrefslogtreecommitdiff
path: root/app-admin/entr/entr-5.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-15 14:01:09 +0000
commitdfa2037f41649c9775d690a3d01cfd5cabf4db71 (patch)
tree261884874fd25b6a9bff06b2e5f6106d091e3848 /app-admin/entr/entr-5.3-r1.ebuild
parent8ba94db1fe69019bb2d3b4f50fe9d1ccf3d94b3a (diff)
gentoo auto-resync : 15:02:2023 - 14:01:08
Diffstat (limited to 'app-admin/entr/entr-5.3-r1.ebuild')
-rw-r--r--app-admin/entr/entr-5.3-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/entr/entr-5.3-r1.ebuild b/app-admin/entr/entr-5.3-r1.ebuild
new file mode 100644
index 000000000000..142efed43b1f
--- /dev/null
+++ b/app-admin/entr/entr-5.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Run arbitrary commands when files change"
+HOMEPAGE="
+ https://eradman.com/entrproject/
+ https://github.com/eradman/entr
+"
+SRC_URI="https://eradman.com/entrproject/code/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ app-editors/vim
+ app-misc/tmux
+ dev-vcs/git
+ sys-apps/file
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-no-which.patch"
+)
+
+src_configure() {
+ tc-export CC
+ export PREFIX="${EPREFIX}/usr"
+ export SHELL="${BROOT}/bin/bash"
+ export TMUX_TMPDIR="${T}"
+
+ edo ./configure
+}