summaryrefslogtreecommitdiff
path: root/app-admin/drush
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/drush
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/drush')
-rw-r--r--app-admin/drush/Manifest5
-rw-r--r--app-admin/drush/drush-6.7.0-r1.ebuild65
-rw-r--r--app-admin/drush/drush-6.7.0.ebuild63
-rw-r--r--app-admin/drush/files/update-bash-completion-script-for-2.1.patch39
-rw-r--r--app-admin/drush/metadata.xml14
5 files changed, 186 insertions, 0 deletions
diff --git a/app-admin/drush/Manifest b/app-admin/drush/Manifest
new file mode 100644
index 000000000000..65e2a6cec52f
--- /dev/null
+++ b/app-admin/drush/Manifest
@@ -0,0 +1,5 @@
+AUX update-bash-completion-script-for-2.1.patch 1332 BLAKE2B a54fa2cab268542a37f1020012cf7744106966419d2ba8415a2e2ead882feb3f3dc9bd9b1ab17f8592e5d021855f5361b05304efcc810362224935069ef1b897 SHA512 2e19a6be652684c1b1a2a9d6605c1404272391950408cd6ae964b2bdd9f95b1e59deec5111c1eaa563a92837ea394fcb2315a3032b2ab02996509b98eb7d1cf0
+DIST drush-6.7.0.tar.gz 511581 BLAKE2B d3a589e3de35afe120d790f96ffa7e88b530da1e1d04815b1dea2f05cd081ad7dc6f4b39fa6f19b5620b9913b952ab289ec538f1b7c0c0f298d3cd0129eb7026 SHA512 203870190dd8987ad3da71f7625476c1f94bc75513447a740fd8c16268fb9705bcbc3b2bffc49a44045998e3fa49fd5ee9d4c0634a1fb39605ba8e10b7373fa5
+EBUILD drush-6.7.0-r1.ebuild 1716 BLAKE2B 6323bd830e199edbcf39a74b6ddaf0b38816678c43a6245565db2999236f496209859f88074920a86a8647ff653e3d603c032cd4cd79ca37efe893546d0baf83 SHA512 b766666dfce86612ae691db158f0ca340025cfca28e5d8ca55020bdc762cf0ccb73cb41d37318c962974df40695b3d8fab5fef6c9f1bd4a453806d0c79d7aab8
+EBUILD drush-6.7.0.ebuild 1705 BLAKE2B b53cf220834579345e124bc469aced5fafb5d609090db5c545436859d8107543807699440f39577ea95921a47c14e64d512ce90867945b07f0bae65e78f5de19 SHA512 1c6bd5d2c9af395751d9deefb08fcd35dbe38be0c7d9df2e5db68d6aa9a732dbb326da1b6d2f9b548a16c14120b2f7c6d59ed810c53f4f75c24ff02827da97f0
+MISC metadata.xml 531 BLAKE2B f28505f228108046c5a667d98863fe5b77e3ff8a994d3613a34bcc6666d041451c419a0f43b6792c376e2a0749dcf5dfd42e83781ad2db6b1ba6f084bee00b1a SHA512 27cfde1e0c618050f645abf589511ccf87675ac00da8eb147b6a38d1e48d0d688fef2310ec015d394a202b56b3f09aca32b6d6c9bedaab98e469139349472aa4
diff --git a/app-admin/drush/drush-6.7.0-r1.ebuild b/app-admin/drush/drush-6.7.0-r1.ebuild
new file mode 100644
index 000000000000..41d92ea52559
--- /dev/null
+++ b/app-admin/drush/drush-6.7.0-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/drush"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
+ dev-php/PEAR-Console_Table"
+
+# Fixes the bash completion script, check the patch for Gentoo/upstream
+# bug numbers.
+PATCHES=( "${FILESDIR}/update-bash-completion-script-for-2.1.patch" )
+
+src_prepare() {
+ default
+
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+ #
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.inc'!.inc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ # Always install the examples; they're referenced within the source
+ # code and too difficult to exorcise.
+ dodoc -r README.md docs examples
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym ../share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}
diff --git a/app-admin/drush/drush-6.7.0.ebuild b/app-admin/drush/drush-6.7.0.ebuild
new file mode 100644
index 000000000000..9052c38c745c
--- /dev/null
+++ b/app-admin/drush/drush-6.7.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/drush"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[cli,ctype,json,simplexml]
+ dev-php/PEAR-Console_Table"
+
+src_prepare() {
+ # Fix the bash completion script, check the patch for Gentoo/upstream
+ # bug numbers.
+ epatch "${FILESDIR}/update-bash-completion-script-for-2.1.patch"
+
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.inc'!.inc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ # Always install the examples; they're referenced within the source
+ # code and too difficult to exorcise.
+ dodoc -r README.md docs examples
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym ../share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}
diff --git a/app-admin/drush/files/update-bash-completion-script-for-2.1.patch b/app-admin/drush/files/update-bash-completion-script-for-2.1.patch
new file mode 100644
index 000000000000..a6a9b6a0ff43
--- /dev/null
+++ b/app-admin/drush/files/update-bash-completion-script-for-2.1.patch
@@ -0,0 +1,39 @@
+From e0f53949d35f32d251ab003d6e9e70a7f8c0e69a Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <mjo@gentoo.org>
+Date: Tue, 21 Oct 2014 19:48:37 -0400
+Subject: [PATCH 1/1] Update bash completion script for new
+ bash-completion-2.1 (Gentoo bug #526222).
+
+* Don't use `which drush ...` to detect the presence of drush in the
+ bash-completion script (https://github.com/drush-ops/drush/issues/521).
+
+* Don't install completions for commands that we don't "own"
+ (https://github.com/drush-ops/drush/issues/915).
+
+---
+ drush.complete.sh | 5 +----
+ 1 file changed, 1 insertion(+), 4 deletions(-)
+
+diff --git a/drush.complete.sh b/drush.complete.sh
+index 067a67c..2f97317 100644
+--- a/drush.complete.sh
++++ b/drush.complete.sh
+@@ -5,9 +5,6 @@
+ # examples/example.bashrc instead, as it will automatically find and source
+ # this file.
+
+-# Ensure drush is available.
+-which drush > /dev/null || alias drush &> /dev/null || return
+-
+ __drush_ps1() {
+ f="${TMPDIR:-/tmp/}/drush-env/drush-drupal-site-$$"
+ if [ -f $f ]
+@@ -31,4 +28,4 @@ _drush_completion() {
+ }
+
+ # Register our completion function. We include common short aliases for Drush.
+-complete -o bashdefault -o default -o nospace -F _drush_completion d dr drush drush5 drush6 drush7 drush.php
++complete -o bashdefault -o default -o nospace -F _drush_completion drush
+--
+2.0.4
+
diff --git a/app-admin/drush/metadata.xml b/app-admin/drush/metadata.xml
new file mode 100644
index 000000000000..dade88fc1985
--- /dev/null
+++ b/app-admin/drush/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription lang="en">
+ Drush is a command line shell and scripting interface for Drupal,
+ a veritable Swiss Army knife designed to make life easier for
+ those of us who spend some of our working hours hacking away at
+ the command prompt.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">drush-ops/drush</remote-id>
+ </upstream>
+</pkgmetadata>