summaryrefslogtreecommitdiff
path: root/app-admin/drush
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /app-admin/drush
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'app-admin/drush')
-rw-r--r--app-admin/drush/Manifest2
-rw-r--r--app-admin/drush/drush-6.7.0-r3.ebuild66
-rw-r--r--app-admin/drush/files/array-syntax.patch58
3 files changed, 126 insertions, 0 deletions
diff --git a/app-admin/drush/Manifest b/app-admin/drush/Manifest
index 4c10df59df1e..3c157132ae6c 100644
--- a/app-admin/drush/Manifest
+++ b/app-admin/drush/Manifest
@@ -1,4 +1,6 @@
+AUX array-syntax.patch 2166 BLAKE2B 40c40456ea5f2deacb4f83f74abdb58300a1fd03f93544e05d0e4e58ec266422d5b2cffa0652b49022a6096801d8506779e2da5f11cabfbc2e15fb36f1a78fe1 SHA512 8fb8e243b885a40490b0e55a12e65639879e6adae60f2784e6c960338c9e842bb480d9d18d83c1dd834b8114c37c59a4709881936895faf0c3262878de62414a
AUX update-bash-completion-script-for-2.1.patch 1332 BLAKE2B a54fa2cab268542a37f1020012cf7744106966419d2ba8415a2e2ead882feb3f3dc9bd9b1ab17f8592e5d021855f5361b05304efcc810362224935069ef1b897 SHA512 2e19a6be652684c1b1a2a9d6605c1404272391950408cd6ae964b2bdd9f95b1e59deec5111c1eaa563a92837ea394fcb2315a3032b2ab02996509b98eb7d1cf0
DIST drush-6.7.0.tar.gz 511581 BLAKE2B d3a589e3de35afe120d790f96ffa7e88b530da1e1d04815b1dea2f05cd081ad7dc6f4b39fa6f19b5620b9913b952ab289ec538f1b7c0c0f298d3cd0129eb7026 SHA512 203870190dd8987ad3da71f7625476c1f94bc75513447a740fd8c16268fb9705bcbc3b2bffc49a44045998e3fa49fd5ee9d4c0634a1fb39605ba8e10b7373fa5
EBUILD drush-6.7.0-r2.ebuild 1714 BLAKE2B a21340f3c6092b81d2b779bf629b7f337d62a689cd81d5c46044ab332078ba35b9c8f7e848d0acd2aeec584800b10c9855d6f3bd2f6eaa44d4a1e9648a5c587f SHA512 b3a493fa5b1e8b6f235626fdcdd84ff1fcd113ca4ee22a874b7138229317ac272b91a5e05ed74959e37f8e5c6375b903e316bc101f34e82ad779012b66e4ea4f
+EBUILD drush-6.7.0-r3.ebuild 1664 BLAKE2B 5ca852654883947225c1a1ff609b071ed7d2812e305258ab6f7c52d87533aeba3df4b5e3a0f7b552b4aea94c7df00de1b9f265bda6a7171207605cdfa7e30f5d SHA512 ee1fd17e55e4ca9563ef138a2054c64a0b92f5dac166aae1751194625c3332fe27ca1b93330479e9dba34dc032d7beb698f8010d6ab50dd8b626c111d3d07652
MISC metadata.xml 532 BLAKE2B c6ca539149d500608519aa982f4a3ef7f8e15b472d5140b8569371df6585c9f80ea57d7802fee00267bfe76290f2b9836be20250472bd261500fd5de84b974f7 SHA512 ec95e30855e93d1d04eac73b3dcf538c2ab38fbeb44acb7f3f7f3c3c04af9a5adba7dc96181cc02f136ffd901e22aab362dadef70aa9f84b0dde78a70bd36716
diff --git a/app-admin/drush/drush-6.7.0-r3.ebuild b/app-admin/drush/drush-6.7.0-r3.ebuild
new file mode 100644
index 000000000000..38e4125922de
--- /dev/null
+++ b/app-admin/drush/drush-6.7.0-r3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Command line shell and scripting interface for Drupal"
+HOMEPAGE="https://github.com/drush-ops/drush"
+SRC_URI="https://github.com/drush-ops/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php[cli,ctype,json(+),simplexml]
+ dev-php/PEAR-Console_Table"
+
+PATCHES=(
+ "${FILESDIR}/update-bash-completion-script-for-2.1.patch"
+ "${FILESDIR}/array-syntax.patch"
+)
+
+src_prepare() {
+ default
+
+ # dodoc compresses all of the documentation, so we fix the filenames
+ # in a few places.
+ #
+ # First, the README location in bootstrap.inc.
+ sed -i -e \
+ "s!/share/doc/drush!/share/doc/${PF}!" \
+ -e "s!README\.md!\0.bz2!g" \
+ includes/bootstrap.inc || die
+
+ # Next, the list of documentation in docs.drush.inc. Note that
+ # html files don't get compressed.
+ sed -i \
+ -e "s!\.bashrc'!.bashrc.bz2'!" \
+ -e "s!\.inc'!.inc.bz2'!" \
+ -e "s!\.ini'!.ini.bz2'!" \
+ -e "s!\.md'!.md.bz2'!" \
+ -e "s!\.php'!.php.bz2'!" \
+ -e "s!\.script'!.script.bz2'!" \
+ -e "s!\.txt'!.txt.bz2'!" \
+ commands/core/docs.drush.inc || die
+}
+
+src_install() {
+ # Always install the examples; they're referenced within the source
+ # code and too difficult to exorcise.
+ dodoc -r README.md docs examples
+
+ insinto /usr/share/drush
+ doins -r classes commands includes lib misc
+ doins drush_logo-black.png drush.info drush.php
+
+ exeinto /usr/share/drush
+ doexe drush
+ dosym ../share/drush/drush /usr/bin/drush
+
+ keepdir /etc/drush
+ newbashcomp drush.complete.sh drush
+}
diff --git a/app-admin/drush/files/array-syntax.patch b/app-admin/drush/files/array-syntax.patch
new file mode 100644
index 000000000000..60abeea984e5
--- /dev/null
+++ b/app-admin/drush/files/array-syntax.patch
@@ -0,0 +1,58 @@
+From 354d3d4f7a0c56926bd5124d2ec5bb363a9f9bc8 Mon Sep 17 00:00:00 2001
+From: Michael Orlitzky <michael@orlitzky.com>
+Date: Tue, 23 Nov 2021 17:34:24 -0500
+Subject: [PATCH 1/1] includes: don't access array elements with curly braces.
+
+The array{idx} syntax was deprecated in php-7.4 and has been removed
+in php-8.0. It's trivial to use square brackets, like array[idx],
+instead; so we do it.
+---
+ includes/command.inc | 6 +++---
+ includes/sitealias.inc | 6 +++---
+ 2 files changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/includes/command.inc b/includes/command.inc
+index af039ad..ed0e817 100644
+--- a/includes/command.inc
++++ b/includes/command.inc
+@@ -749,16 +749,16 @@ function drush_parse_args() {
+ $command_args[] = $opt;
+ }
+ // Is the arg an option (starting with '-')?
+- if (!empty($opt) && $opt{0} == "-" && strlen($opt) != 1) {
++ if (!empty($opt) && $opt[0] == "-" && strlen($opt) != 1) {
+ // Do we have multiple options behind one '-'?
+- if (strlen($opt) > 2 && $opt{1} != "-") {
++ if (strlen($opt) > 2 && $opt[1] != "-") {
+ // Each char becomes a key of its own.
+ for ($j = 1; $j < strlen($opt); $j++) {
+ $options[substr($opt, $j, 1)] = true;
+ }
+ }
+ // Do we have a longopt (starting with '--')?
+- elseif ($opt{1} == "-") {
++ elseif ($opt[1] == "-") {
+ if ($pos = strpos($opt, '=')) {
+ $options[substr($opt, 2, $pos - 2)] = substr($opt, $pos + 1);
+ }
+diff --git a/includes/sitealias.inc b/includes/sitealias.inc
+index b9f0bb9..13a38c1 100644
+--- a/includes/sitealias.inc
++++ b/includes/sitealias.inc
+@@ -133,10 +133,10 @@ function drush_sitealias_resolve_sitespecs($site_specifications, $alias_path_con
+ function drush_sitealias_valid_alias_format($alias) {
+ return ( (strpos($alias, ',') !== false) ||
+ ((strpos($alias, '@') === FALSE ? 0 : 1) + (strpos($alias, '/') === FALSE ? 0 : 1) + (strpos($alias, '#') === FALSE ? 0 : 1) >= 2) ||
+- ($alias{0} == '#') ||
+- ($alias{0} == '@')
++ ($alias[0] == '#') ||
++ ($alias[0] == '@')
+ );
+- return $alias{0} == '@';
++ return $alias[0] == '@';
+ }
+
+ /**
+--
+2.32.0
+