summaryrefslogtreecommitdiff
path: root/app-admin/doctl/doctl-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-admin/doctl/doctl-9999.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-admin/doctl/doctl-9999.ebuild')
-rw-r--r--app-admin/doctl/doctl-9999.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/doctl/doctl-9999.ebuild b/app-admin/doctl/doctl-9999.ebuild
new file mode 100644
index 000000000000..59e3c4d9aa3c
--- /dev/null
+++ b/app-admin/doctl/doctl-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/digitalocean/${PN}.git"
+
+inherit bash-completion-r1 git-r3 go-module
+
+DESCRIPTION="A command line tool for DigitalOcean services"
+HOMEPAGE="https://github.com/digitalocean/doctl"
+SRC_URI=""
+
+LICENSE="Apache-2.0 MIT BSD BSD-2 ISC MPL-2.0"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+src_unpack() {
+ git-r3_src_unpack
+}
+
+src_compile() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go build ./cmd/... || die "build failed"
+
+ ./doctl completion bash > doctl.bash || die "completion for bash failed"
+ ./doctl completion zsh > doctl.zsh || die "completion for sh failed"
+ ./doctl completion fish > doctl.fish || die "completion for fish failed"
+}
+
+src_test() {
+ GOFLAGS="-v -x -mod=vendor" \
+ go test -work ./do/... ./pkg/... . || die "test failed"
+}
+
+src_install() {
+ einstalldocs
+ dobin doctl
+
+ newbashcomp doctl.bash doctl
+ insinto /usr/share/zsh/site-functions
+ newins doctl.zsh _doctl
+ insinto /usr/share/fish/completion
+ newins doctl.fish doctl
+}