summaryrefslogtreecommitdiff
path: root/app-admin/djbdns-logparse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
commitef596bcaa32d9c69d88a3451193cb242da803db1 (patch)
treed6084e886d9fb2f2bd064f937c0257aa1dfea7a6 /app-admin/djbdns-logparse
parent83ebb477861172671f6796999e016400b659d65f (diff)
gentoo auto-resync : 25:02:2023 - 21:55:01
Diffstat (limited to 'app-admin/djbdns-logparse')
-rw-r--r--app-admin/djbdns-logparse/Manifest1
-rw-r--r--app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/app-admin/djbdns-logparse/Manifest b/app-admin/djbdns-logparse/Manifest
index dbc6d408e1fc..b0d16ecda649 100644
--- a/app-admin/djbdns-logparse/Manifest
+++ b/app-admin/djbdns-logparse/Manifest
@@ -1,3 +1,4 @@
DIST djbdns-logparse-0.0.2.tar.gz 23425 BLAKE2B dfcad00ddc27d85497d671fde9d51cad033d63b132b7d73e35b65825af4c222239a4815a8081eecdeeab18ec3a00237a16a4a12b647ad6520c0a8e302d0830cc SHA512 8b4b8a59567b929e20571f50bbd302280bcf2755d6e016475db20b98884d380bdeb6800a1ce815265b0655c4f5c725c28575c89f907c89d85a163f88b7a97f6c
+EBUILD djbdns-logparse-0.0.2-r1.ebuild 798 BLAKE2B 99eeb49ba9c920464b012cc17745d8a32bb1890020ad72d234ea600521b0d75d60a2cd941f12ef32dffce5a11fe790f2eefe777325ff6a68d83fb826f9653e4e SHA512 85a9038ce1fa4e553dcf2a6a1da73c647fdc527409cbb46c57f3037c924d32989c316a85e942e44f1d3b33911cf9dc68932728ed94cf471fc555f173d21fd6ee
EBUILD djbdns-logparse-0.0.2.ebuild 765 BLAKE2B 58311221a1545a6b9b192b8e0714e3828a07e437bf5676d1070e05c97d77f015663bd3fec17f08ccab4bf3bb9fc0f243b979edc93bf33daae4b5248847704829 SHA512 b7f33271cbd311bbd5cd2c6d671d1f7f1ed694968895d6b4bc9427136fa0a18696aa2c65969e70e2fdd47b3f176182b1f775de0dad94080a409fe6764e517a82
MISC metadata.xml 219 BLAKE2B 27094593eb47f098fe9df926d3a827b65c2ca39ac6b03d392efe2c19d646274e5b462f65a7177ba2556a9167c994544688e53a3df810dc7f86ae43c4a75fd59e SHA512 e990bf6d766d6c0380344187a03b66380e4ed7a1554dd7a900ccf1f6f2dd3a51b06b382cedd5c73e0ad75301436b351fea0e7f1fb720c3d1345a8958554d341c
diff --git a/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild
new file mode 100644
index 000000000000..155ae489821a
--- /dev/null
+++ b/app-admin/djbdns-logparse/djbdns-logparse-0.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="Make tinydns and dnscache logs human-readable"
+HOMEPAGE="http://michael.orlitzky.com/code/djbdns-logparse.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.gz"
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# djbdns-logparse pipes the logs through the "tai64nlocal" program
+# that comes with sys-process/daemontools.
+RDEPEND="sys-process/daemontools"
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_install_all() {
+ doman "doc/man1/${PN}.1"
+ local DOCS=( doc/README )
+ distutils-r1_python_install_all
+}
+
+python_test() {
+ esetup.py test
+}