summaryrefslogtreecommitdiff
path: root/app-admin/diradm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-13 10:44:02 +0100
commit57dbe782fa3930bfa59520388f90ca4c2f037785 (patch)
treecab5bb5fd36f7758c6ba15635a713eadc3ee5754 /app-admin/diradm
parent7bb2a634b4e693c8545db3823c080e6edec25e77 (diff)
gentoo auto-resync : 13:09:2023 - 10:44:02
Diffstat (limited to 'app-admin/diradm')
-rw-r--r--app-admin/diradm/Manifest1
-rw-r--r--app-admin/diradm/diradm-2.9.7.1-r1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/app-admin/diradm/Manifest b/app-admin/diradm/Manifest
index 2f85437ce4d0..1cf20dcb374d 100644
--- a/app-admin/diradm/Manifest
+++ b/app-admin/diradm/Manifest
@@ -1,3 +1,4 @@
DIST diradm-2.9.7.1.tar.bz2 126172 BLAKE2B 23f18a7946187caf1e12ec9d1f67a2c5c06895d837add3c79dd0b043d4745f0fd9b405e5667ebe5480946e4741c7bbff2be8c4281afcb7636353f72904f7e39b SHA512 5052f7b7072cd61eb9c70d23057f6c0d2fa68a151792d7260ca52716c9588c06234d335af84b967df23da4b4a8650502cab3b18900dc15e71f71b0888224993f
+EBUILD diradm-2.9.7.1-r1.ebuild 1786 BLAKE2B d1a011849116a2019ba561a9c098df8e5e7cb67acd2815d2a4e7b8a3afd843d5700ebea519ff9d42785e466e296ef7a4a92d0ac0e72ad4efccc5e6b187ae742a SHA512 10d2423a9e4d959be9dbed5974947ce3a53bb4e78206783a9122207d47618752565ad88f06861d1b5b58e1a46e83a9bdeacfc719570c779df856d2ca4ae0941f
EBUILD diradm-2.9.7.1.ebuild 1770 BLAKE2B 1ae13033af0aa9c6130690309ae0a04e760c9478873323094c906dc79ae53741c6c5da92d9c26c28ec6053100fc185147a09d3f49fe11356b5c63c1f2cd937f4 SHA512 20ca60e206dc56711e757056d87e20b7e7ccbaab0b31acbad06f73d835fcd4f71fb18ddcbacde2bd87e8157dacbc3cae2832a949275442edef0f1fe3e22b8afc
MISC metadata.xml 410 BLAKE2B 0a7f652623aa08561e3fbe452a40030955edf0f20506713162938ed0b3049436d7df02243932013e90d8171a232448a04b473217d6e185d8fbb107847cfe3bfb SHA512 e717ddf67bb381f6a343670112ff14340693e68eea81edc4c8674b0568b2288bb1998750ebe456612264fa82e447c22dac3468af1fd68f0958c56a819bbbf6a4
diff --git a/app-admin/diradm/diradm-2.9.7.1-r1.ebuild b/app-admin/diradm/diradm-2.9.7.1-r1.ebuild
new file mode 100644
index 000000000000..e5be64b31f5d
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.7.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP"
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="http://research.iat.sfu.ca/custom-software/diradm/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="automount irixpasswd samba test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( automount irixpasswd samba )"
+
+RDEPEND="
+ app-shells/bash:*
+ dev-lang/perl
+ >=net-nds/openldap-2.3
+ sys-apps/coreutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ dev-perl/Crypt-SmbHash
+ dev-util/dejagnu
+ >=net-fs/samba-3.0.6
+ net-nds/openldap[-minimal]
+ )
+"
+
+src_configure() {
+ econf \
+ $(use_enable automount) \
+ $(use_enable irixpasswd) \
+ $(use_enable samba)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ dodoc CHANGES.prefork KNOWN-BUGS
+
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+ elog "This package is primarily intended for use with nss_ldap & pam_ldap"
+ elog "and populates many default settings from the /etc/ldap.conf used by"
+ elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
+ elog "for server connection settings only."
+}