summaryrefslogtreecommitdiff
path: root/app-admin/dio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/dio
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/dio')
-rw-r--r--app-admin/dio/Manifest3
-rw-r--r--app-admin/dio/dio-1.5.2.ebuild28
-rw-r--r--app-admin/dio/metadata.xml15
3 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/dio/Manifest b/app-admin/dio/Manifest
new file mode 100644
index 000000000000..dc907a1ea49c
--- /dev/null
+++ b/app-admin/dio/Manifest
@@ -0,0 +1,3 @@
+DIST dio-1.5.2.tar.gz 44344 BLAKE2B 8e573cbf2ad1b717ffec09f20f8c7474841bc3e1635af35116d02b37af56ef3b4742e12725134d485f788e7abb595605640e19bd6f84bfd8f14289abf1695089 SHA512 366d2f2d25b8d16439c4a9aaa7cd775ddffb1022980675cdda8e2e4d4de3d3e5dcfa8d0c581b73fcfe4eff66ee8ef682f082c8788f514b7abdf1a2cb2159b9ba
+EBUILD dio-1.5.2.ebuild 549 BLAKE2B 3553d95a1b4f3b4c3b1ee239f063874149b1ddc46ad831908a32304f9a3c300d7eae3b0a793fbca25a9fc4c292e85435b95ae31f1930b3cc44b37b318c6e260d SHA512 4554efe518dc9a795a07751a85950bcc0b6edfa6cc35ce71cd0401ad84d63db832d9864a5f7144f9d28c320008ab06246b2dcaa7afbb37a29d213547e0399709
+MISC metadata.xml 474 BLAKE2B 927b087f58c120fe79c16595932d546ad071fe77968395877bb23f647fb0f996d790d795912f8a93d81c7063d5427af66987a59ca54c73ee5871ab0d7ddeb616 SHA512 259b13ae48c1e20d7d9a8d4c76cfcf375c69c2a55ffe78c231291bc745249cc9b51e3d6981ac52d7607b179d2f3b933434577eeaa1b06e602fdb1a65d7187d97
diff --git a/app-admin/dio/dio-1.5.2.ebuild b/app-admin/dio/dio-1.5.2.ebuild
new file mode 100644
index 000000000000..6087eb8c5354
--- /dev/null
+++ b/app-admin/dio/dio-1.5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit toolchain-funcs
+
+DESCRIPTION="dio - Device I/O monitoring tool"
+HOMEPAGE="https://github.com/donaldmcintosh/dio"
+SRC_URI="https://github.com/donaldmcintosh/dio/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dio
+ doman dio.1
+}
diff --git a/app-admin/dio/metadata.xml b/app-admin/dio/metadata.xml
new file mode 100644
index 000000000000..19a392ab5492
--- /dev/null
+++ b/app-admin/dio/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>donaldbmcintosh@yahoo.co.uk</email>
+ <name>Donald McIntosh</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">donaldmcintosh/dio</remote-id>
+ </upstream>
+</pkgmetadata>