summaryrefslogtreecommitdiff
path: root/app-admin/consul
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /app-admin/consul
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'app-admin/consul')
-rw-r--r--app-admin/consul/Manifest2
-rw-r--r--app-admin/consul/consul-1.2.3.ebuild69
2 files changed, 71 insertions, 0 deletions
diff --git a/app-admin/consul/Manifest b/app-admin/consul/Manifest
index 742ddf8687b6..a3a4fc77cf60 100644
--- a/app-admin/consul/Manifest
+++ b/app-admin/consul/Manifest
@@ -6,5 +6,7 @@ AUX consul.service 354 BLAKE2B 9996b9d6a1aab360a3b46518e2091e8f30794f3bd3d113a3e
AUX data-dir.json.example 36 BLAKE2B dadf9d7350346db73e4db0d98aaa569fe7caa5d695e25606fb97b252be16f2d3f50630092be39be378821f7e17e4914557a55c620156e7d07ced151d1f977689 SHA512 cca94745ddfdcfedcc612da4a14965d4f51f0eaf519d8395e95b8b6cbe7bcb9987b8fdbffd66fb13edda7164a7b0f26e93e5aeab9e631cbf5e0a3a5c05b84b0b
AUX ui.json.example 17 BLAKE2B ecb48d228ee02df0a96b46cd87001742924ee907d7fe05b54c900b6e37e14b8bd7278e5adeaadd164b09129275a804f1014b7fdf64068ba9d9ad957325f9d5fd SHA512 9aebf80a0dd2bc5345285b63c894af8c0d5864f352d97fc3ba7cd6bf22b905ace3bd221cf23092080e9f7d60832384632c2f069d580eef789eb3f81011e9869d
DIST consul-1.2.2.tar.gz 15789375 BLAKE2B 8a0af370568f6fcb90334b147bd84e479efb682ed6c58d63dd56f3554f9e6538d37963ac825bb8598eef8948492feec688b8266733223d1557dbce9704daef35 SHA512 715f69e7b36d0070ea4e602dc50f51aa2547dbbbbb07cce985da79d1e201c6e84dade8a7c810e3602f88cfbd30e063669076954d2541810a18a0c9e7c9ff8458
+DIST consul-1.2.3.tar.gz 18428593 BLAKE2B 14582bf9668e4f2a1c8c443cb01d7b9780c9bc414ff226907335f3873c135b77566898649d16b352ef21ee9300c290338f59672c5fb2b187694aea97b8735dec SHA512 71a7dbfc031df4a96faf2ddd829f289e96adefd0e0087208bbdd26e742a24e3da05fceea4181eb915703ad3323ed5b02bf74eb3fdfbed1e9a1afa2f74acb2a34
EBUILD consul-1.2.2.ebuild 1550 BLAKE2B 83bbc84358ac1cd5854fd6325b62a517e6da51a0cb8d4cce6b5b94278ca4ffafaa74f3232d4d6556ebc6611b4d71608e028f931a72a10536698cec17a7322203 SHA512 bb60a8d056fe2dfbaff0eb0de014af536f9bdf8e5e8a76b17174acb19ca005530eb8811b8357097fb4a469acb0c6751337c8e81eb99fbbd156111aa1040fe4ee
+EBUILD consul-1.2.3.ebuild 1550 BLAKE2B 21eaf66415397eb834e6208082c58bca34e5e02d180503fcdb02d7727ca1d46e2fdbad86fd5c3b7d24961c2f16479c602b2e4ad42b5b6f98c4b48632d98558de SHA512 4ebefcbbd2d253d39c413b083feb0918e430ed27dbc38a728077ca16097729593f70576af0bd434109b3f2ec8ca17bc70cd74d09348c9e7dcc79a8dc1d0ed56e
MISC metadata.xml 391 BLAKE2B c60fccfb61459803d5e9cff21d68525df118fc15b2390e805e3358b4e50e19a6eba6e06c057c5310797a9ba533f0d24746c95d8160a67e285732e7adab9b7fb2 SHA512 74541a7ccabd8ed4cebaec46f8d848d1930e8b50bc1fe5d84a5d37022d307e261d8e5537f942608c019992a2deccf0831a7624447d92dd68fe85128cfabf4ceb
diff --git a/app-admin/consul/consul-1.2.3.ebuild b/app-admin/consul/consul-1.2.3.ebuild
new file mode 100644
index 000000000000..5c900d4ab45d
--- /dev/null
+++ b/app-admin/consul/consul-1.2.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot systemd user
+GIT_COMMIT="48d287e"
+KEYWORDS="~amd64"
+EGO_PN="github.com/hashicorp/consul"
+DESCRIPTION="A tool for service discovery, monitoring and configuration"
+HOMEPAGE="https://www.consul.io"
+SRC_URI="https://github.com/hashicorp/consul/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MPL-2.0"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="dev-go/gox
+ >=dev-lang/go-1.9:=
+ >=dev-go/go-tools-0_pre20160121"
+RDEPEND=""
+
+pkg_setup() {
+ enewgroup consul
+ enewuser consul -1 -1 /var/lib/${PN} consul
+}
+
+src_prepare() {
+ default
+
+ sed -e 's:go get -u -v $(GOTOOLS)::' \
+ -e 's:vendorfmt dev-build:dev-build:' \
+ -i "src/${EGO_PN}/GNUmakefile" || die
+}
+
+src_compile() {
+ # The dev target sets causes build.sh to set appropriate XC_OS
+ # and XC_ARCH, and skips generation of an unused zip file,
+ # avoiding a dependency on app-arch/zip.
+ GOPATH="${S}" \
+ GOBIN="${S}/bin" \
+ GIT_DESCRIBE="v${PV}" \
+ GIT_DIRTY="" \
+ GIT_COMMIT="${GIT_COMMIT}" \
+ emake -C "src/${EGO_PN}" dev-build
+}
+
+src_install() {
+ local x
+
+ dobin bin/consul
+
+ keepdir /etc/consul.d
+ insinto /etc/consul.d
+ doins "${FILESDIR}/"*.json.example
+
+ for x in /var/{lib,log}/${PN}; do
+ keepdir "${x}"
+ fowners consul:consul "${x}"
+ done
+
+ newinitd "${FILESDIR}/consul.initd" "${PN}"
+ newconfd "${FILESDIR}/consul.confd" "${PN}"
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/consul.service"
+}