summaryrefslogtreecommitdiff
path: root/app-admin/conserver/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/conserver/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/conserver/files')
-rw-r--r--app-admin/conserver/files/conserver-8.1.18-dmalloc.patch100
-rw-r--r--app-admin/conserver/files/conserver-prestrip.patch24
-rw-r--r--app-admin/conserver/files/conserver.confd6
-rw-r--r--app-admin/conserver/files/conserver.initd37
-rw-r--r--app-admin/conserver/files/conserver.initd-r137
-rw-r--r--app-admin/conserver/files/conserver.pam-pambase6
6 files changed, 210 insertions, 0 deletions
diff --git a/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
new file mode 100644
index 000000000000..ff82f74b261c
--- /dev/null
+++ b/app-admin/conserver/files/conserver-8.1.18-dmalloc.patch
@@ -0,0 +1,100 @@
+--- configure.in 2011-08-19 01:11:06.000000000 -0400
++++ configure.in 2011-08-19 02:06:50.000000000 -0400
+@@ -320,6 +320,8 @@
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
+
++AM_WITH_DMALLOC([cons_with_dmalloc="YES"],[cons_with_dmalloc="NO"])
++
+ dnl ### Compiler characteristics. ##################################
+ AC_AIX
+ AC_C_CONST
+@@ -578,51 +580,6 @@
+ fi]
+ )
+
+-cons_with_dmalloc="NO"
+-AC_ARG_WITH(dmalloc,
+- AS_HELP_STRING([--with-dmalloc@<:@=PATH@:>@],
+- [Compile in dmalloc support]),
+- [if test "$withval" != "no"; then
+- if test "$withval" != "yes"; then
+- DMALLOCCPPFLAGS="-I$withval/include"
+- if test "$use_dash_r" != "yes"; then
+- DMALLOCLDFLAGS="-L$withval/lib"
+- else
+- DMALLOCLDFLAGS="-L$withval/lib -R$withval/lib"
+- fi
+- else
+- DMALLOCCPPFLAGS=""
+- DMALLOCLDFLAGS=""
+- fi
+-
+- oCPPFLAGS="$CPPFLAGS"
+- oLDFLAGS="$LDFLAGS"
+- oLIBS="$LIBS"
+- have_dmalloc=no
+-
+- CPPFLAGS="$CPPFLAGS $DMALLOCCPPFLAGS"
+- LDFLAGS="$LDFLAGS $DMALLOCLDFLAGS"
+-
+- AC_CHECK_HEADER([dmalloc.h],
+- [LIBS="$LIBS -ldmalloc"
+- AC_MSG_CHECKING(for dmalloc libraries -ldmalloc)
+- AC_TRY_LINK([#include <dmalloc.h>
+- ],[dmalloc_debug(0)],
+- [AC_MSG_RESULT(yes)
+- cons_with_dmalloc="YES"
+- AC_DEFINE(HAVE_DMALLOC)
+- have_dmalloc=yes],
+- [AC_MSG_RESULT(no)])],)
+-
+- if test $have_dmalloc = no; then
+- LIBS="$oLIBS"
+- CPPFLAGS="$oCPPFLAGS"
+- LDFLAGS="$oLDFLAGS"
+- fi
+- fi]
+-)
+-
+-
+ dnl ### Check for needed functions. ################################
+
+ dnl dnl The following basically stollen from the less-358 distribution, but
+--- /dev/null 2011-08-07 13:18:05.535976733 -0400
++++ m4/dmalloc.m4 2011-08-19 03:49:03.755073497 -0400
+@@ -0,0 +1,34 @@
++## ----------------------------------- ## -*- Autoconf -*-
++## Check if --with-dmalloc was given. ##
++## From Franc,ois Pinard ##
++## ----------------------------------- ##
++
++# Copyright (C) 1996, 1998, 1999, 2000, 2001, 2002, 2003, 2005, 2010,
++# 2011 Free Software Foundation, Inc.
++#
++# This file is free software; the Free Software Foundation
++# gives unlimited permission to copy and/or distribute it,
++# with or without modifications, as long as this notice is preserved.
++
++# serial 7
++
++dnl AM_WITH_DMALLOC([ACTION-IF-FOUND],[ACTION-IF-NOT])
++AC_DEFUN([AM_WITH_DMALLOC],
++[AC_MSG_CHECKING([if malloc debugging is wanted])
++AC_ARG_WITH([dmalloc],
++[AS_HELP_STRING([--with-dmalloc],
++ [use dmalloc, as in http://www.dmalloc.com])],
++[if test "$withval" = yes; then
++ AC_MSG_RESULT([yes])
++ AC_DEFINE([WITH_DMALLOC], [1],
++ [Define if using the dmalloc debugging malloc package])
++ LIBS="$LIBS -ldmalloc"
++ LDFLAGS="$LDFLAGS -g"
++ [$1]
++else
++ AC_MSG_RESULT([no])
++ [$2]
++fi], [AC_MSG_RESULT([no])])
++])
++
++AU_DEFUN([fp_WITH_DMALLOC], [AM_WITH_DMALLOC])
diff --git a/app-admin/conserver/files/conserver-prestrip.patch b/app-admin/conserver/files/conserver-prestrip.patch
new file mode 100644
index 000000000000..e67c49da1a66
--- /dev/null
+++ b/app-admin/conserver/files/conserver-prestrip.patch
@@ -0,0 +1,24 @@
+diff -Nuar conserver-8.1.14.orig/conserver/Makefile.in conserver-8.1.14/conserver/Makefile.in
+--- conserver-8.1.14.orig/conserver/Makefile.in 2006-10-25 17:41:00.398082243 -0600
++++ conserver-8.1.14/conserver/Makefile.in 2006-10-25 17:41:27.876759095 -0600
+@@ -13,7 +13,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
+diff -Nuar conserver-8.1.14.orig/console/Makefile.in conserver-8.1.14/console/Makefile.in
+--- conserver-8.1.14.orig/console/Makefile.in 2006-10-25 17:41:00.401081662 -0600
++++ conserver-8.1.14/console/Makefile.in 2006-10-25 17:41:18.188635834 -0600
+@@ -9,7 +9,7 @@
+
+ ### Installation programs and flags
+ INSTALL = @INSTALL@
+-INSTALL_PROGRAM = @INSTALL_PROGRAM@ -s
++INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ LN_S = @LN_S@
+ MKDIR = @MKDIR@
+
diff --git a/app-admin/conserver/files/conserver.confd b/app-admin/conserver/files/conserver.confd
new file mode 100644
index 000000000000..4544fed4ab36
--- /dev/null
+++ b/app-admin/conserver/files/conserver.confd
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+## Config file for /etc/init.d/conserver
+
+CONSERVER_OPTS="-d"
diff --git a/app-admin/conserver/files/conserver.initd b/app-admin/conserver/files/conserver.initd
new file mode 100644
index 000000000000..0c0771c72c6b
--- /dev/null
+++ b/app-admin/conserver/files/conserver.initd
@@ -0,0 +1,37 @@
+#!/sbin/openrc-run
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need clock
+}
+
+checkconfig() {
+ if [ ! -e /etc/conserver/conserver.cf ] ; then
+ eerror "You need to create /etc/conserver/conserver.cf first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+
+ if [ ! -e /etc/conserver/conserver.passwd ] ; then
+ eerror "You need to create /etc/conserver/conserver.passwd first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting conserver"
+ start-stop-daemon --start --quiet --exec \
+ /usr/sbin/conserver -- ${CONSERVER_OPTS} 1>/dev/null
+ eend $? "Failed to start conserver"
+}
+
+stop() {
+ ebegin "Stopping conserver"
+ start-stop-daemon --stop --quiet --pidfile /var/run/conserver.pid
+ eend $? "Failed to stop conserver"
+}
diff --git a/app-admin/conserver/files/conserver.initd-r1 b/app-admin/conserver/files/conserver.initd-r1
new file mode 100644
index 000000000000..907b1b711705
--- /dev/null
+++ b/app-admin/conserver/files/conserver.initd-r1
@@ -0,0 +1,37 @@
+#!/sbin/openrc-run
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need clock
+}
+
+checkconfig() {
+ if [ ! -e /etc/conserver/conserver.cf ] ; then
+ eerror "You need to create /etc/conserver/conserver.cf first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+
+ if [ ! -e /etc/conserver/conserver.passwd ] ; then
+ eerror "You need to create /etc/conserver/conserver.passwd first."
+ eerror "A sample is placed there to be renamed and ajusted."
+ eerror "Read the man page or see /usr/share/doc/conserver-<version>/."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting conserver"
+ start-stop-daemon --start --quiet --pidfile /var/run/conserver.pid --exec \
+ /usr/sbin/conserver -- ${CONSERVER_OPTS} 1>/dev/null
+ eend $? "Failed to start conserver"
+}
+
+stop() {
+ ebegin "Stopping conserver"
+ start-stop-daemon --stop --quiet --pidfile /var/run/conserver.pid
+ eend $? "Failed to stop conserver"
+}
diff --git a/app-admin/conserver/files/conserver.pam-pambase b/app-admin/conserver/files/conserver.pam-pambase
new file mode 100644
index 000000000000..30025fe1403e
--- /dev/null
+++ b/app-admin/conserver/files/conserver.pam-pambase
@@ -0,0 +1,6 @@
+auth required pam_securetty.so
+auth include system-remote-login
+
+account include system-remote-login
+password include system-remote-login
+session include system-remote-login