summaryrefslogtreecommitdiff
path: root/app-admin/conkyforecast
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/conkyforecast
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/conkyforecast')
-rw-r--r--app-admin/conkyforecast/Manifest5
-rw-r--r--app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild44
-rw-r--r--app-admin/conkyforecast/metadata.xml11
3 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/conkyforecast/Manifest b/app-admin/conkyforecast/Manifest
new file mode 100644
index 000000000000..53bcfda07241
--- /dev/null
+++ b/app-admin/conkyforecast/Manifest
@@ -0,0 +1,5 @@
+DIST conkyforecast_2.24.tar.gz 11347231 SHA256 251dba60bc209a2f4181de856abb1fe553e8b983d1af40998235061e8679a54d SHA512 dcff08915c00915f6be4cd25824e3d8de978ed15ffb6776f002d585d95856f5e0827632371dd4d37016e07d58542e2bc95a7a859ebdc8ab9d1200ac04d4364e0 WHIRLPOOL d7a6967e09a52eeac98ab13f64f3ab86a29f1964b7b79951c78b08f7e42c67d6d41e5c339bd1d7dedad687c523bd7fd059d529d076894d19af2a1c2a8180e718
+EBUILD conkyforecast-2.24-r1.ebuild 1143 SHA256 2ce47e5359453144dd0a29f3e37825c579d3430f4a96c5ff5273a25865a0a820 SHA512 b269faef892efa7ded0d49830e0232fb2eefc95c55e24a6e50935aa40b9e2c0ad198c061237d7200a252a6169cc2480df6b1d865423963374375dc264f4c5695 WHIRLPOOL 806c90b2f7dc4792c6b83c998a8aa3eb75d9e6a5694d95ee4811be2ee81c4b76c85648821b2871bf5fde4d62f17e7d6dd1435c7abbd1093b9a9e1f0b1e0dc777
+MISC ChangeLog 2199 SHA256 69543bd70972d420d1cd5a61b5fb46fd4b63bc322d33feb433ceceacf0f100bf SHA512 ef6cd37b9f3dc5cce0444c590fe26d2e843ca16b341eae90852c2f41a08e5b0aaf85cb71f5dfded8d5277e4183ab252f2cc49aeb52a28115002257ec6febb5f3 WHIRLPOOL a9f333c1f9bba4d9b1c1380f084dc0a885f18f72c4b56594f67d012f61ef85e19f5fc7b633aad285c494504f5d177ec80c06cd634e1b817dba6fd4162f664272
+MISC ChangeLog-2015 1379 SHA256 4223c2785e36e2e2b5b73a6ca745bf355ec36b974d4c305c0d750a8d12961ad2 SHA512 9e1f5abfcdd0b15897e5e480e816fff90f5e0dbdc5f1771e794de4b7c887c07d709ec94b6cbace2648c05a8420f7ff470f034fa6775f451400ca956e16d7c197 WHIRLPOOL 4a4d96f40336e25ac4b5308498e144237201901e0466eaf06d1bb13b18fc3bb1f57d232ebd0a7610b520e4bb072f5409c4045ef16ea4e3c36b2ae62be7cc4a63
+MISC metadata.xml 328 SHA256 42562b05183360f33bee3279a728db09771f8c94428be860ffbc1b8afc129632 SHA512 b82738da77f143327af6973f163191826c7883fb1d3991f2c369ebcc84e50c71b1ea714d124562236501788fde015c3c3b33c4300561cc549a275931dc9fe426 WHIRLPOOL 7f3161bd822780af5dc41098c19c947a54a416a8a0f6f7d4f84ab538067892d063ba7c066a5b915a0575e8f0b3f96c59bd14c75f341855e07fcc222bebbcb1ce
diff --git a/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
new file mode 100644
index 000000000000..2a1f73e2ee42
--- /dev/null
+++ b/app-admin/conkyforecast/conkyforecast-2.24-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# upstream broke setup.py to install into /usr/share...
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Conky weather forecast script with support for language files"
+HOMEPAGE="https://launchpad.net/~conky-companions"
+SRC_URI="https://launchpad.net/~conky-companions/+archive/ppa/+files/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/conky"
+
+S=${WORKDIR}/src
+
+python_prepare_all() {
+ sed -i -e "s:pythoncmd=.*$:pythoncmd=${EPYTHON}:" conkyForecast* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize "${ED%/}"/usr/share/${PN}
+}
+
+pkg_postinst() {
+ elog "You have to define a partner id and registration code for "
+ elog "the weather.com xoap. You need to copy the template from"
+ elog "/usr/share/conkyforecast/conkyForecast.config into you account"
+ elog "as ~/.conkyForecast.config and edit the respective fields."
+ elog
+ elog "More details can be found in the README file."
+}
diff --git a/app-admin/conkyforecast/metadata.xml b/app-admin/conkyforecast/metadata.xml
new file mode 100644
index 000000000000..d9f08c9f2411
--- /dev/null
+++ b/app-admin/conkyforecast/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">~conky-companions</remote-id>
+ </upstream>
+</pkgmetadata>