summaryrefslogtreecommitdiff
path: root/app-admin/chrpath
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/chrpath
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/chrpath')
-rw-r--r--app-admin/chrpath/Manifest6
-rw-r--r--app-admin/chrpath/chrpath-0.13-r2.ebuild42
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-multilib.patch160
-rw-r--r--app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch19
-rw-r--r--app-admin/chrpath/files/chrpath-keepgoing.patch20
-rw-r--r--app-admin/chrpath/metadata.xml11
6 files changed, 258 insertions, 0 deletions
diff --git a/app-admin/chrpath/Manifest b/app-admin/chrpath/Manifest
new file mode 100644
index 000000000000..25d6bed03315
--- /dev/null
+++ b/app-admin/chrpath/Manifest
@@ -0,0 +1,6 @@
+AUX chrpath-0.13-multilib.patch 4129 BLAKE2B d6a2405751bba1774bd62ad3244928e0243c24825e986ed9e1531d28bd7521fb67fd5523365e574bfed1f8b404002afb76b89ec3e855fb6f5eababe042b5e360 SHA512 45f1a25a7abee84e955ffb13485480efb1f768cb225d35a57fae5fa6a75dac7d633aa7221aad81aa6fef2cf8f27f221dcaee972ad82e70677049f2f2fc6e9ff3
+AUX chrpath-0.13-testsuite-1.patch 575 BLAKE2B 0fa870a459c564a48ec82a86af46ca25afd52b98e9342b4690b876fcac18357fabe996fdb638378128596271f2855219de48b651903ec655316a166b746921e7 SHA512 0969af4defcf4b3650e4416c8d17d747f6a785b6a2f0cdd2105e6ff111c04ecbfc236c073e6f48096494b08c41d6077a332b02104ff3e07e60c542d706f7ef6c
+AUX chrpath-keepgoing.patch 1041 BLAKE2B d5ec2b6d482fbd42b2d3cd04626984c1d6ea0c5ca35d5aa25160bb6781a0bd534c637d90e19f8c873e12ad477b2f0d17d57f066401afd95fc0d82c4e3319ff12 SHA512 7bd459313f3cd83c86c63adf8a39df41c0454f6a689aab803d3211b5ffa295a72ce45a8ed7c3f61af0f705fc614c4ce48d86c6a5706b20c4d45265bbeafceb9c
+DIST chrpath-0.13.tar.gz 125129 BLAKE2B 004db7e3567ceeb700d018e7e32036843413605466c218bf40252927b169775c5a86f81f8ea355f0d141821313d114ec24654ed62d75443e31739118e31bc497 SHA512 9ec2ab2731fb553497996939b421130ae221d478dab8887c184ae91f7d3ae697688e7a30e3bea30cc0cf765f1dc8c7f47d2a1f4369b36079b4033e8d0303d75e
+EBUILD chrpath-0.13-r2.ebuild 1138 BLAKE2B 759093b1b0ac32ea57866d3266e7be4f14e24d16125e11531cacb627107a8ed48a4fdc4681fef51a6c6e964cf0d0ea5e5991ba4d58ef7075fd6e157457921eac SHA512 dc6d7b28af227b1ac365a3402a171a393ab7adb5e68b6fa764dfb61876b9d27717df3575fcf47f7febadbbb2c09b2094c24a5e52799ab618318ce06735bd1f15
+MISC metadata.xml 325 BLAKE2B 3d1e56e84a1ee9bfb3ab37bdce7fe7d4d2d74eca05ad6beee2f3d90da661f5bf59aa45dff767a72f210dcbdcff7818e41494a58e8c14183a6f11a9f59c0b073f SHA512 bc84447080d9969bb04b15981db6ef6cc35d7a38a796085a7397f5bf2f629ea97785828f895aeb8296e87977d40991a4dd5ffec9cf4ae2393f267afa8d3768c8
diff --git a/app-admin/chrpath/chrpath-0.13-r2.ebuild b/app-admin/chrpath/chrpath-0.13-r2.ebuild
new file mode 100644
index 000000000000..ae32d8001b8c
--- /dev/null
+++ b/app-admin/chrpath/chrpath-0.13-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="chrpath can modify the rpath and runpath of ELF executables"
+HOMEPAGE="http://directory.fsf.org/project/chrpath/"
+# original upstream no longer exists (ftp://ftp.hungry.com/pub/hungry)
+SRC_URI="http://ftp.tux.org/pub/X-Windows/ftp.hungry.com/chrpath/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ~mips ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multilib.patch
+ "${FILESDIR}"/${PN}-keepgoing.patch
+ "${FILESDIR}"/${P}-testsuite-1.patch
+)
+
+src_prepare() {
+ default
+ # disable installing redundant docs in the wrong dir
+ sed -i -e '/doc_DATA/d' Makefile.am || die
+ # fix for automake-1.13, #467538
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static) || die
+}
+
+src_install() {
+ default
+ if ! use static-libs; then
+ find "${D}" -name "*.la" -delete || die
+ fi
+}
diff --git a/app-admin/chrpath/files/chrpath-0.13-multilib.patch b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
new file mode 100644
index 000000000000..e7db0a124053
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-0.13-multilib.patch
@@ -0,0 +1,160 @@
+Index: chrpath-0.13/Makefile.am
+===================================================================
+--- chrpath-0.13.orig/Makefile.am
++++ chrpath-0.13/Makefile.am
+@@ -12,12 +12,19 @@ debs:
+ fakeroot debian/rules binary
+
+ chrpath_SOURCES = \
+- chrpath.c \
+- killrpath.c \
+ main.c \
+- elf.c \
+ protos.h
+
++chrpath_LDADD = $(LDLIBS)
++
++lib_LTLIBRARIES = libchrpath32.la libchrpath64.la
++libchrpath32_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
++libchrpath32_la_CFLAGS = -DSIZEOF_VOID_P=4
++libchrpath32_la_LDFLAGS = -avoid-version
++libchrpath64_la_SOURCES = chrpath.c killrpath.c elf.c protos.h
++libchrpath64_la_CFLAGS = -DSIZEOF_VOID_P=8
++libchrpath64_la_LDFLAGS = -avoid-version
++
+ EXTRA_DIST = ChangeLog.usermap $(man_MANS)
+
+ CLEANFILES = *.bb *.bbg *.da *.gcov testsuite/*.bb testsuite/*.bbg
+Index: chrpath-0.13/configure.ac
+===================================================================
+--- chrpath-0.13.orig/configure.ac
++++ chrpath-0.13/configure.ac
+@@ -16,6 +16,7 @@ CHRPATH_LDRPATH_OPTION
+ dnl Checks for programs.
+ AC_PROG_CC
+ AC_PROG_INSTALL
++AC_PROG_LIBTOOL
+
+ dnl Checks for libraries.
+
+@@ -26,11 +27,19 @@ AC_CHECK_HEADERS([getopt.h elf.h fcntl.h
+ dnl Checks for typedefs, structures, and compiler characteristics.
+ AC_C_CONST
+ AC_C_BIGENDIAN
+-AC_CHECK_SIZEOF(void *)
+
+ dnl Checks for library functions.
+ AC_CHECK_FUNCS(getopt_long)
+
++dnl See if we need -ldl on this platform for dlopen
++LDLIBS=
++save_LIBS="$LIBS"
++LIBS=
++AC_SEARCH_LIBS([dlopen], [dl])
++LDLIBS=${LIBS}
++LIBS="${save_LIBS}"
++AC_SUBST([LDLIBS])
++
+ if eval "test x$GCC = xyes"; then
+ for flag in \
+ -ansi \
+Index: chrpath-0.13/main.c
+===================================================================
+--- chrpath-0.13.orig/main.c
++++ chrpath-0.13/main.c
+@@ -12,13 +12,19 @@
+ # include "config.h"
+ #endif
+
++#include <dlfcn.h>
++#include <elf.h>
++#include <fcntl.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <unistd.h>
+ #ifdef HAVE_GETOPT_H
+ #include <getopt.h>
+ #endif
+-#include "protos.h"
++
++typedef int (*killrpath_t)(const char *filename);
++typedef int (*chrpath_t)(const char *filename, const char *newpath, int convert);
+
+ #ifdef HAVE_GETOPT_LONG
+ # define GETOPT_LONG getopt_long
+@@ -61,6 +67,30 @@ usage(char *progname)
+ printf("\n");
+ }
+
++static unsigned
++elf_class(const char *filename)
++{
++ Elf32_Ehdr ehdr;
++ int fd;
++
++ fd = open(filename, O_RDONLY);
++ if (fd == -1)
++ return 0;
++ if (read(fd, &ehdr, sizeof(ehdr)) != sizeof(ehdr))
++ {
++ close(fd);
++ return 0;
++ }
++ close(fd);
++ if ((memcmp(ehdr.e_ident, ELFMAG, SELFMAG) != 0)
++ || (ehdr.e_ident[EI_VERSION] != EV_CURRENT))
++ {
++ fprintf(stderr, "`%s' probably isn't an ELF file.\n", filename);
++ return 0;
++ }
++ return ehdr.e_ident[EI_CLASS];
++}
++
+ int
+ main(int argc, char * const argv[])
+ {
+@@ -73,6 +103,9 @@ main(int argc, char * const argv[])
+ #ifdef HAVE_GETOPT_LONG
+ int option_index = 0;
+ #endif /* HAVE_GETOPT_LONG */
++ void* dll[2];
++ killrpath_t killrpath[2];
++ chrpath_t chrpath[2];
+
+ if (argc < 2)
+ {
+@@ -116,14 +149,31 @@ main(int argc, char * const argv[])
+ }
+ } while (-1 != opt);
+
++ dll[0] = dlopen("libchrpath32.so", RTLD_LAZY);
++ killrpath[0] = (killrpath_t)dlsym(dll[0], "killrpath");
++ chrpath[0] = (chrpath_t)dlsym(dll[0], "chrpath");
++
++ dll[1] = dlopen("libchrpath64.so", RTLD_LAZY);
++ killrpath[1] = (killrpath_t)dlsym(dll[1], "killrpath");
++ chrpath[1] = (chrpath_t)dlsym(dll[1], "chrpath");
++
+ while (optind < argc && (!retval || keep_going))
+ {
++ const char* program = argv[optind++];
++ unsigned eclass = elf_class(program);
++ if (!eclass)
++ {
++ retval = 1;
++ continue;
++ }
+ if (remove)
+- retval |= killrpath(argv[optind++]);
++ retval |= killrpath[eclass - ELFCLASS32](program);
+ else
+ /* list by default, replace if path is set */
+- retval |= chrpath(argv[optind++], newpath, convert);
++ retval |= chrpath[eclass - ELFCLASS32](program, newpath, convert);
+ }
+
++ dlclose(dll[0]);
++ dlclose(dll[1]);
+ return retval;
+ }
diff --git a/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch b/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
new file mode 100644
index 000000000000..1a30ce1eb94a
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-0.13-testsuite-1.patch
@@ -0,0 +1,19 @@
+Submitted By: Mario Fetka (geos_one) (mario dot fetka at gmail dot com)
+Date: 2010-04-04
+Initial Package Version: 0.13
+Origin: me
+Upstream Status: unknown
+Description: make the testsuite run with the new mltilib design
+
+diff -Naur chrpath-0.13.orig/testsuite/runtest.sh chrpath-0.13/testsuite/runtest.sh
+--- chrpath-0.13.orig/testsuite/runtest.sh 2010-04-04 09:02:21.859114159 +0000
++++ chrpath-0.13/testsuite/runtest.sh 2010-04-04 09:42:08.762112560 +0000
+@@ -2,6 +2,8 @@
+
+ set -x
+
++export LD_LIBRARY_PATH=$PWD/../.libs:$LD_LIBRARY_PATH
++
+ CHRPATH=../chrpath
+
+ retval=0
diff --git a/app-admin/chrpath/files/chrpath-keepgoing.patch b/app-admin/chrpath/files/chrpath-keepgoing.patch
new file mode 100644
index 000000000000..d8f6965729ff
--- /dev/null
+++ b/app-admin/chrpath/files/chrpath-keepgoing.patch
@@ -0,0 +1,20 @@
+--- chrpath-0.13/main.c.orig 2006-02-27 20:21:06.000000000 +0100
++++ chrpath-0.13/main.c 2006-02-27 21:07:16.027641500 +0100
+@@ -57,6 +57,7 @@
+ printf(" -r <path>|--replace <path> Replace current rpath/runpath setting\n");
+ printf(" with the path given\n");
+ printf(" -l|--list List the current rpath/runpath (default)\n");
++ printf(" -k|--keepgoing Continue as much as possible after an error.\n");
+ printf(" -h|--help Show this usage information.\n");
+ #ifndef HAVE_GETOPT_LONG
+ printf("\n *** The long options are not available on this platform");
+--- chrpath-0.13/chrpath.1.orig 2004-09-19 10:35:44.000000000 +0200
++++ chrpath-0.13/chrpath.1 2006-02-28 10:06:28.187060500 +0100
+@@ -22,6 +22,7 @@
+ [ \fB-r\fP \fI<path>\fP |\ \fB--replace\fP \fI<path>\fP ]
+ [ \fB-c\fP | \fB--convert\fP ]
+ [ \fB-l\fP | \fB--list\fP ]
++[ \fB-k\fP | \fB--keepgoing\fP ]
+ [ \fB-h\fP | \fB--help\fP ]
+ \fI<program>\fP [ \fI<program>\fP ... ]
+ .SH DESCRIPTION
diff --git a/app-admin/chrpath/metadata.xml b/app-admin/chrpath/metadata.xml
new file mode 100644
index 000000000000..ec89a074cbfa
--- /dev/null
+++ b/app-admin/chrpath/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>grobian@gentoo.org</email>
+ </maintainer>
+<maintainer type="project">
+ <email>prefix@gentoo.org</email>
+ <name>Gentoo Prefix</name>
+ </maintainer>
+</pkgmetadata>