summaryrefslogtreecommitdiff
path: root/app-admin/chroot_safe
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/chroot_safe
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/chroot_safe')
-rw-r--r--app-admin/chroot_safe/Manifest4
-rw-r--r--app-admin/chroot_safe/chroot_safe-1.4.ebuild35
-rw-r--r--app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch13
-rw-r--r--app-admin/chroot_safe/metadata.xml8
4 files changed, 60 insertions, 0 deletions
diff --git a/app-admin/chroot_safe/Manifest b/app-admin/chroot_safe/Manifest
new file mode 100644
index 000000000000..1bc4dd55817b
--- /dev/null
+++ b/app-admin/chroot_safe/Manifest
@@ -0,0 +1,4 @@
+AUX chroot_safe-1.4-ldflags.patch 399 BLAKE2B 3acacf5d552da06fd1907d988f113d96058efbd357cd4e6bbe514d8e8ed750b7931f3ea61a065cf605c42e3d7a21986da5d27e5b242cc0d594adcd6537b9893a SHA512 f5e3114b5d553f95d1b885d1ff43aee4d3cfb2d15a5d519818ff2f4c36fe099cdd27e6bd578dbf7ce957c38d8b329fd786f0efb22d0785197706e19892da2753
+DIST chroot_safe-1.4.tgz 25886 BLAKE2B 62247d568240a93914e5c42c3bfefd2e8793a9b6bd27c13668ff3cc48ec396b622553764e934045c0c570eeff7b15c5ae9fb7b3623c5661be537e79ce9d93287 SHA512 7eee0d8e2c75ccf4bd918f610c21511498a6499b638d09634993a4d6874882a0dbc8c27eea95e9776f1722593e3445399a893557bfa6398a11b85447564dfe61
+EBUILD chroot_safe-1.4.ebuild 783 BLAKE2B acdc573b676ce35d9cf686f15f33231099361986209e15a28ac05c17a1b487dfa7d689ecd0ae2e474a23f089f50c63972aa4673c2e2e406a652f4ce4f2dca909 SHA512 f5977571dfaf1f7e63cdd6d75bd7ba01986856e75bb73dcc49f0da6d08f9a127cfe56cb286026f3f504956994e238fa53cf571400f4fdcba2116b9935c455364
+MISC metadata.xml 247 BLAKE2B 306b96b46dafe605c41d3111cf9bd2fc3ef659f9f66692d05f952f8c9606d5bf1b1dd8051cdf1cd2d4e41f01934e57ae3e55ae46d23ba5acc2314d2fef325a4f SHA512 c46fc3160d29be2ce0948b1503ce44ead81dc76a264e183dc667be4e4f9bce0e235c94c2ebd06934b63cc7575aa8d5f27a528bb79185d35a138c7e0ec6dd1e3c
diff --git a/app-admin/chroot_safe/chroot_safe-1.4.ebuild b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
new file mode 100644
index 000000000000..210b10565d66
--- /dev/null
+++ b/app-admin/chroot_safe/chroot_safe-1.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils multilib
+
+DESCRIPTION="a tool to chroot any dynamically linked application in a safe and sane manner"
+HOMEPAGE="http://chrootsafe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN//_}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ldflags.patch
+}
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}/usr/$(get_libdir)"
+}
+
+src_compile() {
+ emake CPPFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dolib.so chroot_safe.so
+ dosbin chroot_safe
+ sed -i -e "s:/chroot_safe::" "${ED}"/usr/sbin/chroot_safe \
+ || die "sed chroot_safe failed"
+ doman chroot_safe.1
+ dodoc CHANGES.txt
+}
diff --git a/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch b/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch
new file mode 100644
index 000000000000..e9e94580ac42
--- /dev/null
+++ b/app-admin/chroot_safe/files/chroot_safe-1.4-ldflags.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile.in b/Makefile.in
+index ce69ab7..e8542b5 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -12,7 +12,7 @@ install=@INSTALL@
+ all: chroot_safe.so
+
+ chroot_safe.so: chroot_safe.cpp Makefile
+- $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(DEFINES) $(SOFLAGS) -o chroot_safe.so $<
++ $(CXX) $(CPPFLAGS) $(CXXFLAGS) $(LDFLAGS) $(DEFINES) $(SOFLAGS) -o chroot_safe.so $<
+
+ clean:
+ rm -f *.o *.so *~
diff --git a/app-admin/chroot_safe/metadata.xml b/app-admin/chroot_safe/metadata.xml
new file mode 100644
index 000000000000..7c5fd5d3ecad
--- /dev/null
+++ b/app-admin/chroot_safe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="sourceforge">chrootsafe</remote-id>
+ </upstream>
+</pkgmetadata>