summaryrefslogtreecommitdiff
path: root/app-admin/certmgr/certmgr-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-13 17:49:31 +0100
commit36ac65103bf5503e5bad1ecc7e8cb9e7643f6840 (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /app-admin/certmgr/certmgr-1.6.0.ebuild
parenta1392efe64137262023d92492396ca9156d22396 (diff)
Revert "gentoo resync : 13.09.2019"
This reverts commit a1392efe64137262023d92492396ca9156d22396.
Diffstat (limited to 'app-admin/certmgr/certmgr-1.6.0.ebuild')
-rw-r--r--app-admin/certmgr/certmgr-1.6.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/certmgr/certmgr-1.6.0.ebuild b/app-admin/certmgr/certmgr-1.6.0.ebuild
new file mode 100644
index 000000000000..6951be522070
--- /dev/null
+++ b/app-admin/certmgr/certmgr-1.6.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+EGO_PN="github.com/cloudflare/${PN}"
+inherit golang-build golang-vcs-snapshot
+
+SRC_URI="https://${EGO_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Automated certificate management using a CFSSL CA"
+HOMEPAGE="https://github.com/cloudflare/certmgr"
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RESTRICT="test"
+
+src_compile() {
+ pushd src || die
+ GOPATH="${S}" go install -v ${EGO_PN}/cmd/... || die
+ popd || die
+}
+
+src_install() {
+ dobin bin/*
+ pushd src/${EGO_PN} || die
+ dodoc README.md
+ popd || die
+}