summaryrefslogtreecommitdiff
path: root/app-admin/calamares
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/calamares
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/calamares')
-rw-r--r--app-admin/calamares/Manifest6
-rw-r--r--app-admin/calamares/calamares-3.1.13.ebuild79
-rw-r--r--app-admin/calamares/calamares-3.2.0.ebuild84
-rw-r--r--app-admin/calamares/files/calamares-pkexec2
-rw-r--r--app-admin/calamares/metadata.xml27
5 files changed, 198 insertions, 0 deletions
diff --git a/app-admin/calamares/Manifest b/app-admin/calamares/Manifest
new file mode 100644
index 000000000000..10cbcfd59ddb
--- /dev/null
+++ b/app-admin/calamares/Manifest
@@ -0,0 +1,6 @@
+AUX calamares-pkexec 43 BLAKE2B 432999808da0fdde0e5d9c88887a5f112ac00c90af51f3d907d02ab4f9eb4fae7348856028bcfff98ced8698d0d039bd9506f50baa90f5b12b43c1b72885f230 SHA512 768148cd58cdfb5c6791b76ec60c21a4ca852120f53ed31a83bc7a2e0a26aa77b10bd3756182d3dff03208e820def4b83c45edba0484fa2f5a33c93880c3f4bb
+DIST calamares-3.1.13.tar.gz 2279516 BLAKE2B ff2c81e81086d53c205c25dbdb7e8b1b60f5f10c979e9afd85c02426cd38037c6fbbf76e21fa5fb152ea9bf1c47658563ba5b2fb7e84b4e2734d6269584315df SHA512 451e04fe41448976e612b2a682cf38ed2683b490bb195ba82ad97d47dfd3eb808f8c25251be00104e3f3b4086ab37be462034bbd2866e64536e90f7ebcfb0d7a
+DIST calamares-3.2.0.tar.gz 2488863 BLAKE2B 6941cdd7eb381a6ee4f7bc2628605ee5a670de0d839b5797cec930737ec5fc09e214c484c2e8398ab2f12669bbc64768d5ee20b2aa1adae799fb96373a0b07df SHA512 0b502749ace48ce56f2bb364d265c5b9197cca2b27115663f928cb58d02ba43e93b80b5022053bca5899ce6ee35146992157408fc5af017da6d61abdcdbc4e1d
+EBUILD calamares-3.1.13.ebuild 1983 BLAKE2B ee4739b47d4224b681e5909fcc872eb59f8d414ecfd316338ae948b45fdcca51bcf7a82608b74b25e79db6a77fbe538f1ba4850edbc848a07bb4bf10aa9e471a SHA512 6c1630a7e30912297bc8238b46f40eb2935bd36ec862a421d46281881f167bd31b116c9bb19f082f9f584c01bc4102a241b8a668eae1cbcd6803e4b7404a969b
+EBUILD calamares-3.2.0.ebuild 2134 BLAKE2B 48d01855b913950b9e3fe68ed4e4ca7d2879e62bbf4f10ffa2d364704a1b806709b2afd0d48a1daa2ed8a50aab4154bc2135be949817bff8fd2c25b603ef610f SHA512 021c49d45c83ee2491f3eb14ac4d7c601139dfe40a1950fcae45381048760081c14120283a5988286f6e2487851a5629cfb1143279170e7d28924d6b38e7798c
+MISC metadata.xml 1055 BLAKE2B a6c7974103baa5a646cb1d594e3f224903df9ce5c618ad4ed46c0b3d4df5d3437be570eda0d55e3b0ca8f6df4af9627b088ace2a3f0efc802528aeb49fc7bce6 SHA512 0269dad0b0a05e7c729ad5b9f1f7d6790c117b0d76b904dc909b868b1c298ff3352faafe91104b39cfc3c2e4f5e1a20244d3f5321c937d2334bd15bd910dc89f
diff --git a/app-admin/calamares/calamares-3.1.13.ebuild b/app-admin/calamares/calamares-3.1.13.ebuild
new file mode 100644
index 000000000000..261aa9e0169b
--- /dev/null
+++ b/app-admin/calamares/calamares-3.1.13.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="https://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager pythonqt +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ dev-cpp/yaml-cpp:=
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5(+)]
+ >=sys-libs/kpmcore-3.0.3:5=
+ pythonqt? ( >=dev-python/PythonQt-3.1:=[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/systemd-boot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ virtual/udev
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWEBVIEW_FORCE_WEBKIT=OFF
+ -DWITH_PYTHONQT=$(usex pythonqt)
+ )
+
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}
diff --git a/app-admin/calamares/calamares-3.2.0.ebuild b/app-admin/calamares/calamares-3.2.0.ebuild
new file mode 100644
index 000000000000..a0864c5ac076
--- /dev/null
+++ b/app-admin/calamares/calamares-3.2.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_5,3_6} )
+inherit kde5 python-r1
+
+DESCRIPTION="Distribution-independent installer framework"
+HOMEPAGE="https://calamares.io"
+if [[ ${KDE_BUILD_TYPE} == live ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/${PN}"
+else
+ SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+IUSE="+networkmanager pythonqt +upower"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtsvg)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-cpp/yaml-cpp:=
+ >=dev-libs/boost-1.55:=[${PYTHON_USEDEP}]
+ dev-libs/libpwquality[${PYTHON_USEDEP}]
+ sys-apps/dbus
+ sys-apps/dmidecode
+ sys-auth/polkit-qt[qt5(+)]
+ >=sys-libs/kpmcore-3.0.3:5=
+ pythonqt? ( >=dev-python/PythonQt-3.1:=[${PYTHON_USEDEP}] )
+"
+
+RDEPEND="${DEPEND}
+ app-admin/sudo
+ dev-libs/libatasmart
+ net-misc/rsync
+ >=sys-block/parted-3.0
+ || ( sys-boot/grub:2 sys-boot/systemd-boot )
+ sys-boot/os-prober
+ sys-fs/squashfs-tools
+ virtual/udev
+ networkmanager? ( net-misc/networkmanager )
+ upower? ( sys-power/upower )
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+ python_setup
+ export PYTHON_INCLUDE_DIRS="$(python_get_includedir)" \
+ PYTHON_INCLUDE_PATH="$(python_get_library_path)"\
+ PYTHON_CFLAGS="$(python_get_CFLAGS)"\
+ PYTHON_LIBS="$(python_get_LIBS)"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DWEBVIEW_FORCE_WEBKIT=OFF
+ -DWITH_PYTHONQT=$(usex pythonqt)
+ )
+
+ kde5_src_configure
+ sed -i -e 's:pkexec /usr/bin/calamares:calamares-pkexec:' "${S}"/calamares.desktop
+ sed -i -e 's:Icon=calamares:Icon=drive-harddisk:' "${S}"/calamares.desktop
+}
+
+src_install() {
+ kde5_src_install
+ dobin "${FILESDIR}"/calamares-pkexec
+}
diff --git a/app-admin/calamares/files/calamares-pkexec b/app-admin/calamares/files/calamares-pkexec
new file mode 100644
index 000000000000..3300d3b70c61
--- /dev/null
+++ b/app-admin/calamares/files/calamares-pkexec
@@ -0,0 +1,2 @@
+#!/bin/sh
+pkexec "/usr/bin/calamares" "$@"
diff --git a/app-admin/calamares/metadata.xml b/app-admin/calamares/metadata.xml
new file mode 100644
index 000000000000..bc9aeb32994b
--- /dev/null
+++ b/app-admin/calamares/metadata.xml
@@ -0,0 +1,27 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>johu@gentoo.org</email>
+ <name>Johannes Huber</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mudler@gentoo.org</email>
+ <name>Ettore Di Giacinto</name>
+ </maintainer>
+ <longdescription>
+ Calamares is a distribution-independent system installer, with an
+ advanced partitioning feature for both manual and automated
+ partitioning operations. It is the first installer with an automated
+ “Replace Partition” option, which makes it easy to reuse a partition
+ over and over for distribution testing. Calamares is designed to be
+ customizable by distribution maintainers without need for cumbersome
+ patching, thanks to third party branding and external modules support.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">calamares/calamares</remote-id>
+ </upstream>
+ <use>
+ <flag name="pythonqt">Enable PythonQt-based module interface</flag>
+ </use>
+</pkgmetadata>