summaryrefslogtreecommitdiff
path: root/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild')
-rw-r--r--app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild
index beda5758dffd..d8293f57fe67 100644
--- a/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild
+++ b/app-admin/bitwarden-desktop-bin/bitwarden-desktop-bin-1.28.3.ebuild
@@ -1,19 +1,20 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit unpacker xdg-utils
+inherit desktop unpacker xdg-utils
MY_PN="Bitwarden"
+
DESCRIPTION="Bitwarden password manager desktop client"
HOMEPAGE="https://bitwarden.com/"
SRC_URI="https://github.com/bitwarden/desktop/releases/download/v${PV}/Bitwarden-${PV}-amd64.deb"
+S="${WORKDIR}"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
RDEPEND="
app-accessibility/at-spi2-atk:2
@@ -53,8 +54,6 @@ IDEPEND="
dev-util/gtk-update-icon-cache
"
-S="${WORKDIR}"
-
QA_PREBUILT="
opt/Bitwarden/*.so
opt/Bitwarden/bitwarden
@@ -67,11 +66,12 @@ src_install() {
fperms 755 /opt/Bitwarden/bitwarden
fperms 4755 /opt/Bitwarden/chrome-sandbox
- insinto /usr/share/applications
- doins usr/share/applications/bitwarden.desktop
+ domenu usr/share/applications/bitwarden.desktop
- insinto /usr/share/icons
- doins -r usr/share/icons/hicolor
+ local x
+ for x in 16 32 48 64 256 512; do
+ doicon -s ${x} data/icons/hicolor/${x}*/*
+ done
}
pkg_postinst() {