summaryrefslogtreecommitdiff
path: root/app-admin/awscli
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-26 11:27:54 +0100
commit25e2c97a4a6f12a367115508fc86d34fe76a6f5e (patch)
tree68acc191d796190f572dc374002717fec321e616 /app-admin/awscli
parent1aa38370b2506ce90ad64cd4e18968d6612ebea5 (diff)
gentoo auto-resync : 26:09:2023 - 11:27:54
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest2
-rw-r--r--app-admin/awscli/awscli-1.29.54.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index d7124d4f08f3..7559af9d3de8 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,5 +1,7 @@
DIST aws-cli-1.29.49.gh.tar.gz 2533689 BLAKE2B 0ead02f739adc66eed988bedf41b9b508c553a6dfcea07af022a5b3098e8a3f65e4fc59e512b3374b3f1fcf89ba30f0dcca20e2cd6638c2d2b37b09646f1f4ca SHA512 336e012105d295dc69734fbd9f47a9cb6f2a54fc4dfac388e52e24519967e0aab5e3d98920f8ad05ea242e39673b6a8f98bb9af551507ee0560ee7598c9f86ec
DIST aws-cli-1.29.53.gh.tar.gz 2549518 BLAKE2B 4c9932ddbfb5f8619006589c0ed8f00b5d0230bc9d7fa811875cc4b16e9b5583a3abe4ccbb290524565dde2f78ae5696162863ea6e5224517c98414d7cb74344 SHA512 1150c20f5cc3da3a0ba2e25741441a7db8b6e399a927366902b30fd30a394634d015cc6b53bbfe7bcb759ce0aec6e0f9432a23e5b8d00cd9c2bb71afd5744627
+DIST aws-cli-1.29.54.gh.tar.gz 2550145 BLAKE2B 75c11a59218e4b0def9313f342c076c0cf414744f0f68e7b4a3e80800dabb95ce184207a6bb7167a85fba829510da72875beeee97506911987b9efff0b58d5d7 SHA512 2dfe1a41cb2235c67fba78e1f83d406ccc9db9b3965b88d7ca4fd31c584fa82b373e818c93b81c4fdb56583ec7a500e6122dc4b9db70bb26cf703fe1827bd663
EBUILD awscli-1.29.49.ebuild 2804 BLAKE2B f5472cbd2dedb555c4968eff148a3e63d0395304b3d02dbc59b56bb593b7fccd64022b69a94c5e4bc5e2b0965fdc75f32beb5151ef379f98ef65d94e109fd340 SHA512 1d1359b9f28290a17fc18b2b36ded73b09edf0f80c1a6757b4f87c7b7229700decf2adf660747303820fb4ef3978ed9ca9e34427bd67ceed6312c3c0ec07ef75
EBUILD awscli-1.29.53.ebuild 2811 BLAKE2B 9023a2e9d234cff26111cf9302a312e369631fead3f1f064904d693e08e2c3aba14e70740cc9b41c3ebcc70671af79cd548788c8f945e758a5ac98263163c8cf SHA512 a1abe2aa8947aa77d6386114a1ba347bcf3d473c8cb2afef7ab815e7308beada9e6c38935801695a3d8fda58c0a1ecc71727dc5b1822ae3cde33bdd2d872f5e4
+EBUILD awscli-1.29.54.ebuild 2811 BLAKE2B 9023a2e9d234cff26111cf9302a312e369631fead3f1f064904d693e08e2c3aba14e70740cc9b41c3ebcc70671af79cd548788c8f945e758a5ac98263163c8cf SHA512 a1abe2aa8947aa77d6386114a1ba347bcf3d473c8cb2afef7ab815e7308beada9e6c38935801695a3d8fda58c0a1ecc71727dc5b1822ae3cde33bdd2d872f5e4
MISC metadata.xml 385 BLAKE2B 5accfb180a91179cc6df539d42d1de06be3ebfec73f3edb719f5d59576103b9a8cb0c7c524c1042630e0cf99f068939a19f04c7b1b4a2acf9e072369df80d913 SHA512 ccb3d516326c5dbdf53068372ce25baecc137d21a04516374362212b969cc928dacbf743b4953da33f28482905798f069d09d19c88d9913f2b32648db25115ab
diff --git a/app-admin/awscli/awscli-1.29.54.ebuild b/app-admin/awscli/awscli-1.29.54.ebuild
new file mode 100644
index 000000000000..040a8d7bd9f3
--- /dev/null
+++ b/app-admin/awscli/awscli-1.29.54.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit bash-completion-r1 distutils-r1 multiprocessing
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # broken xdist (signal() works only in main thread)
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/test_help.py::TestHelpPager::test_can_handle_ctrl_c
+ tests/unit/test_help.py::TestHelpPager::test_can_render_contents
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}