summaryrefslogtreecommitdiff
path: root/app-admin/aws-rds-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/aws-rds-tools
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/aws-rds-tools')
-rw-r--r--app-admin/aws-rds-tools/Manifest2
-rw-r--r--app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild38
2 files changed, 20 insertions, 20 deletions
diff --git a/app-admin/aws-rds-tools/Manifest b/app-admin/aws-rds-tools/Manifest
index dbb90a6876f7..3d620f122677 100644
--- a/app-admin/aws-rds-tools/Manifest
+++ b/app-admin/aws-rds-tools/Manifest
@@ -1,3 +1,3 @@
DIST RDSCli-1.6.001.zip 6291974 BLAKE2B bdb7f9bce07e920b144cce15e6b05f9d98aeab4cbb33c181914d8584c5e24f70ef486e3d2b677e166ad9f936a2d15758ba55cc26f7fc129ed907989c2d3424a8 SHA512 29eb31064cc9b067bdc625e9777dd1cc77bdbd01a167c91c396d52f89fd9617496e2383fe343a17abb0d8029e47eb87f8ae7e60c0dd5a89cee485dbe45a05963
-EBUILD aws-rds-tools-1.6.001.ebuild 1567 BLAKE2B 3288bfa20d244192bcf1db5fc244be2329dbcd8852a5a1ae2feb1a829a016b9c19fbd91f855eece4410278634e2b5b3bdfb6bb0e1bf29f6ac125c7c3be2cede9 SHA512 f42e7bdb03c95d5833a3181369bc97dfca1ef2458bcd0faa124b8a33609852b8d52985361620dbe9bc3c20aa3441e652416799014cbe78cdbfe35506372449ad
+EBUILD aws-rds-tools-1.6.001.ebuild 1518 BLAKE2B e6d08e03f73f1e262b5adb5e43b6a8ac23c317c01b3aaa757dc6fd57fcc5d4d39d40bef4e9f4794708d3751f44ba22ab36aa864375ddf7b3a63890263a4e86cc SHA512 01ce630b9ca713f6b7495c3e12dfc03c97ec6ece0c9c6f216c1463bf0ce8ec3360032cf84ee5f04cce2d621297d14af8de88a808acf5f3073fb16b340306bddf
MISC metadata.xml 456 BLAKE2B 7c623b757f291e6ff28618f87a39f47dcbaa1b7dec75d642a98fc4930b3b75089af8d0ae14b14e9e422ed0ff12716ba337606a58fc1d678547ad16991669f103 SHA512 aa4a57f4b0181ace33cad1698cdadd8cf41eb6f8fa8184ef415d09e0b0fbc81eaf579800c36040a9e01fb4fd2715e646a45d906d55e07617185ffe3f7b8538e8
diff --git a/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild b/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild
index 4d0cfb2e1d01..1cd6d1b4857c 100644
--- a/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild
+++ b/app-admin/aws-rds-tools/aws-rds-tools-1.6.001.ebuild
@@ -1,50 +1,50 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The Command Line Toolkit for the Amazon Relational Database Service"
HOMEPAGE="http://aws.amazon.com/developertools/2928"
SRC_URI="mirror://sabayon/${CATEGORY}/RDSCli-${PV}.zip"
-S="${WORKDIR}/RDSCli-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "$S"
+S="${WORKDIR}/RDSCli-${PV}"
+
+src_prepare() {
+ default
find . -name '*.cmd' -delete || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_RDS_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_RDS_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
- dodoc "THIRDPARTYLICENSE.TXT"
+ dodoc THIRDPARTYLICENSE.TXT
}
pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."