summaryrefslogtreecommitdiff
path: root/app-admin/aws-as-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-admin/aws-as-tools
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-admin/aws-as-tools')
-rw-r--r--app-admin/aws-as-tools/Manifest2
-rw-r--r--app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild40
2 files changed, 21 insertions, 21 deletions
diff --git a/app-admin/aws-as-tools/Manifest b/app-admin/aws-as-tools/Manifest
index 5a6ab3e81904..a64037e8f4c5 100644
--- a/app-admin/aws-as-tools/Manifest
+++ b/app-admin/aws-as-tools/Manifest
@@ -1,3 +1,3 @@
DIST AutoScaling-1.0.49.1.zip 12387808 BLAKE2B 7f43b3544b05f1adc196c28b7c2fc5c26ea84cb3d3bd7cf098d8413b98aac5d2908177ee5567aad6dbea96d1abbf60794c4450423de768c280a33cb4efdbbd1e SHA512 aefc4dfc970757062ca972c5d532485c9e28ceb771b6fa0a4fb2fe25460bd67e3023bcefde57f9852340b6015e7ab2771c49beb0826e1394710ea7eea94948ed
-EBUILD aws-as-tools-1.0.49.1.ebuild 1727 BLAKE2B 7cd5d58140ffc98728cf7f537cffd9c60fb2ef99d474ee19fa3bf624f04760c00d96464c70e22cb7f7d8cdc2f70d6004f2e611cd91dfd60ded9710845d85168e SHA512 62d8cc6ecab9d676e563642c2acbc6d3a89758d45c0aec9014d5a5c710ea9616405096ece2ab8c6f96df7ec4ee8122795e6916a07eca13790f9667aa6492b7c0
+EBUILD aws-as-tools-1.0.49.1.ebuild 1669 BLAKE2B 008f80572c8302b3fdce9385f7edd2c80c6bd8c7336a06eb13046f508dd4b0bb8bb01c9f882360c284e0b5036105dd86544a395b48d178d844969d1e21f68659 SHA512 5cf1ea6b4e08754b89b87e2ba1c672e61f4e1c9791abfaf3ecbee9e41ef4889164880aa957e48dc931e5a0dc3970cf96d08b1e322440f7be79efefaa9fc2f512
MISC metadata.xml 456 BLAKE2B 7c623b757f291e6ff28618f87a39f47dcbaa1b7dec75d642a98fc4930b3b75089af8d0ae14b14e9e422ed0ff12716ba337606a58fc1d678547ad16991669f103 SHA512 aa4a57f4b0181ace33cad1698cdadd8cf41eb6f8fa8184ef415d09e0b0fbc81eaf579800c36040a9e01fb4fd2715e646a45d906d55e07617185ffe3f7b8538e8
diff --git a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
index 38450b0e2f07..a9b3692c2a2a 100644
--- a/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
+++ b/app-admin/aws-as-tools/aws-as-tools-1.0.49.1.ebuild
@@ -1,44 +1,43 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
DESCRIPTION="The API tools serve as the client interface to the Auto Scaling web service"
HOMEPAGE="http://aws.amazon.com/developertools/2535"
# SRC_URI="http://ec2-downloads.s3.amazonaws.com/AutoScaling-2011-01-01.zip"
SRC_URI="mirror://sabayon/app-admin/AutoScaling-1.0.49.1.zip"
-S="${WORKDIR}/AutoScaling-${PV}"
-
LICENSE="Amazon"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
+RESTRICT="mirror"
+
DEPEND="app-arch/unzip"
RDEPEND="virtual/jre"
-RESTRICT="mirror"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+S="${WORKDIR}/AutoScaling-${PV}"
+
+src_prepare() {
+ default
+
find . -name '*.cmd' -delete || die
- rm bin/as-cmd-2009-05-15
- rm bin/service-2009-05-15
+ rm bin/{as-cmd,service}-2009-05-15 || die
}
src_install() {
- dodir /opt/${PN}
insinto /opt/${PN}/lib
- doins -r "${S}"/lib/*
+ doins -r lib/.
+
exeinto /opt/${PN}/bin
- doexe "${S}"/bin/*
-
- dodir /etc/env.d
- cat - > "${T}"/99${PN} <<EOF
-AWS_AUTO_SCALING_HOME=/opt/${PN}
-PATH=/opt/${PN}/bin
-ROOTPATH=/opt/${PN}/bin
-EOF
+ doexe bin/*
+
+ cat > "${T}"/99${PN} <<- EOF || die
+ AWS_AUTO_SCALING_HOME=/opt/${PN}
+ PATH=/opt/${PN}/bin
+ ROOTPATH=/opt/${PN}/bin
+ EOF
doenvd "${T}"/99${PN}
dodoc "THIRDPARTYLICENSE.TXT"
@@ -48,6 +47,7 @@ pkg_postinst() {
ewarn "Remember to run: env-update && source /etc/profile if you plan"
ewarn "to use these tools in a shell before logging out (or restarting"
ewarn "your login manager)"
+
elog
elog "You need to put the following in your ~/.bashrc replacing the"
elog "values with the full path to your AWS credentials file."