summaryrefslogtreecommitdiff
path: root/app-admin/authbind
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/authbind
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/authbind')
-rw-r--r--app-admin/authbind/Manifest4
-rw-r--r--app-admin/authbind/authbind-2.1.1.ebuild51
-rw-r--r--app-admin/authbind/files/authbind-2.1.1-respect-flags.patch26
-rw-r--r--app-admin/authbind/metadata.xml8
4 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/authbind/Manifest b/app-admin/authbind/Manifest
new file mode 100644
index 000000000000..eb4103eaf6b3
--- /dev/null
+++ b/app-admin/authbind/Manifest
@@ -0,0 +1,4 @@
+AUX authbind-2.1.1-respect-flags.patch 808 BLAKE2B 3a74723e5bfe38b2ba31959850b7ea475afe76a73165b267936249809c46632883988f5ae8d56f89af41f682c9afcd3bc4eb3f9e3d5467ad1ce5c53cc5f809d9 SHA512 5c22805ee442cfa76e59e11a7614acaddfc6c38a316c290e147a159a221baf3ca44b44135bf4862031faacbc1c913c97a8a95f000ffcd33688021ece7df19750
+DIST authbind_2.1.1.tar.gz 14407 BLAKE2B 624cb647b138006324611d00943ad78f9166e4c47821ef5b395c58eb75c1034591cb4a0549f6870fa4294f4f4ca628f03390b4539a4543a64111d33ac9cb3261 SHA512 f3a45fcf1d8d6e6762bc1cef7a1b89f211e4af56c68b4c6c5e508a2f7ee039499b8b2f11ce8aeb94822d20377d309035760fa7b58aabaa4e87417ca25811c812
+EBUILD authbind-2.1.1.ebuild 1179 BLAKE2B 3da9b5f5f1cd5bfbe95c1caae16b0d0106439dd5154fba54d3d10941f547b9b450f975f525e0a1674b9bcc13851c2e6e79cdeef33b384009f911fb2e33590f19 SHA512 777f23b0e2d3999a73f8262659d92a45c9f99d51e439650bdf50a124288afccdd153de74f97c4b1253cea9029a785f3342ba2c495f6d67a52ebe727504293fce
+MISC metadata.xml 250 BLAKE2B 50c4b89c67107f8c4eba77c3b35992d381dfc6a30f5e8fb7c696f6b2cde6b7b1f90566a99ceba3df17485a88283059ef51010414e8df6c72d9e7b8c7f9ff0e27 SHA512 a57d332a86b16f67fe2896c47c6cc9ba57f602b65943080289c816a9d0f70b779f61cde882034cc1c2adda79208865dae0bf43d95deea4556e840b785e062343
diff --git a/app-admin/authbind/authbind-2.1.1.ebuild b/app-admin/authbind/authbind-2.1.1.ebuild
new file mode 100644
index 000000000000..c7a9890aa7ce
--- /dev/null
+++ b/app-admin/authbind/authbind-2.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib flag-o-matic
+
+DESCRIPTION="Bind sockets to privileged ports without root"
+HOMEPAGE="http://www.chiark.greenend.org.uk/ucgi/~ian/git/authbind.git/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-respect-flags.patch"
+}
+
+src_configure() {
+ sed -i \
+ -e "s|^prefix=.*|prefix=/usr|" \
+ -e "s|^lib_dir=.*|lib_dir=\$(prefix)/$(get_libdir)|" \
+ -e "s|^libexec_dir=.*|libexec_dir=\$(prefix)/libexec/authbind|" \
+ -e "s|^SHARED_LDFLAGS=.*|SHARED_LDFLAGS=$(raw-ldflags)|" \
+ Makefile || die "sed failed"
+
+ sed -i \
+ -e 's|/usr/lib|/usr/libexec|' \
+ authbind-helper.8 || die "sed failed"
+}
+
+src_install() {
+ dobin authbind
+ doman authbind.1 authbind-helper.8
+
+ ln -s libauthbind.so.* libauthbind.so.$(awk -F= '/MAJOR=/ { print $2 }' < Makefile)
+ dolib.so libauthbind.so*
+
+ exeinto /usr/libexec/authbind
+ exeopts -m4755
+ doexe helper
+
+ keepdir /etc/authbind/by{addr,port,uid}
+
+ dodoc debian/changelog
+}
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
new file mode 100644
index 000000000000..2a9eb5f6b84c
--- /dev/null
+++ b/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
@@ -0,0 +1,26 @@
+diff --git a/Makefile b/Makefile
+index c1eed73..932ea60 100644
+--- a/Makefile
++++ b/Makefile
+@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
+ INSTALL_DIR ?= install -o root -g root -m 755 -d
+ STRIP ?= strip
+
+-OPTIMISE= -O2
+-LDFLAGS= -g
+ LIBS= -ldl -lc
+-CFLAGS= -g $(OPTIMISE) \
++SHARED_LDFLAGS=
++CFLAGS+= \
+ -Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
+ -Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
+ CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
+@@ -82,7 +81,7 @@ helper: helper.o
+ helper.o authbind.o: authbind.h
+
+ $(LIBTARGET): libauthbind.o
+- ld -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
++ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+
+ clean distclean:
+ rm -f $(TARGETS) *.o *~ ./#*# *.bak *.new core
diff --git a/app-admin/authbind/metadata.xml b/app-admin/authbind/metadata.xml
new file mode 100644
index 000000000000..5c23291b5215
--- /dev/null
+++ b/app-admin/authbind/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>