summaryrefslogtreecommitdiff
path: root/app-admin/augeas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-05 19:20:12 +0100
commita4e37a9aeeef82eba5858dbc609f65b838b0f836 (patch)
treee4348e571adc5713a413fbaf411d45c511a7da31 /app-admin/augeas
parentd03ec6c0e9c1683a824ce77667440dcb4a13974e (diff)
gentoo auto-resync : 05:10:2022 - 19:20:12
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/Manifest5
-rw-r--r--app-admin/augeas/augeas-1.13.0.ebuild53
-rw-r--r--app-admin/augeas/files/augeas-1.13.0-selinux.patch19
-rw-r--r--app-admin/augeas/metadata.xml21
4 files changed, 88 insertions, 10 deletions
diff --git a/app-admin/augeas/Manifest b/app-admin/augeas/Manifest
index 41a3b3d9b3cf..f6384ebc66b2 100644
--- a/app-admin/augeas/Manifest
+++ b/app-admin/augeas/Manifest
@@ -1,3 +1,6 @@
+AUX augeas-1.13.0-selinux.patch 661 BLAKE2B abd8430f4bf5a0c0d8033d1f265026b9cff64baf2898cbb522613b41ccde7314342c052ee7cf0d0f3b2d7295af96158c137aef57a7833cda08d435ed17c91e96 SHA512 4059e71ce3f4061fe658dab665e917a807e9f207e0d42b61687434d2368d748da536ae532c9451b9c360fedfc0e6f7fa67ed8926282fec1dbecaecc28f6b0790
DIST augeas-1.12.0.tar.gz 2429279 BLAKE2B cd90203fec1a81b114d95bb50e168b852923136f34c83974d3427cbedd4eb0d335d3952057507b38ded5c7011be2b56725565ea106cb32a0ca43b7c81250b29e SHA512 4f61d4abbf338e915dfae212560d39792674bc757f05f500afa80c6170abc214ffb99cab2cf5bbd1c2338d11a6909e5fc3ff7112a2246fca69f7b39ac283da40
+DIST augeas-1.13.0.tar.gz 2562588 BLAKE2B 0a8e62c999a425b89bfa2b1b2cdf7c7894ca39b59d577ca2f7ce9bf33e51f2fffe2510518a8666d59fcf7f8479cae3b2a41efe4478830f89fa20d1fbeb6c9716 SHA512 a6a9ee76f3e48780df1928f2fdfa5cc826695fe6233ff90d069d05806cb020aed3c6b2ce6b9047925a203973eefcd7c254fc3ddd1db7473821c8ade4fda58d5f
EBUILD augeas-1.12.0.ebuild 957 BLAKE2B 8997535b7b70e25300dc2bb017be15fd724e6731590151ac9617bb7ec8e03901b3dedaa07dc5b54c3475a5fd86646bd38bfd2ca7a6d07dbc5b66aae8cfe7fd8e SHA512 f6402c7b79ff126af421b82598817edf2894542ac73b3ab32601a4d8e18c8e3b7f273cb55be83470123a7ebbea14a53cba93a3d6652075c22740791ab6ed23c4
-MISC metadata.xml 694 BLAKE2B 8bcf71a6c32d0cb72cfd0caeaa70eab180f574393cc75e2ea532d4ad46efbf18c24328b7570eeb4edfb5d215b65a5940d142586cdf11f35fb1cafecc7dfc8dad SHA512 70d88400794e8559ca3319e88700bdfa07c13b175205bd080bf731b0cf140b9858330c23e136fb10493bfe0f65ef5478f1373a4f0ad4c2da80b67d8320c8b93e
+EBUILD augeas-1.13.0.ebuild 987 BLAKE2B b84c2712b7066be10e5e341d455059954cb986800a3b71a69364164055616efebc2fb589784653a35406a55f6279e9a1697f365dc3f9c004fdee10d75f2fe61c SHA512 3a4755ab42c3f20f17f61fd438e302b7af173228463b935a2eb53b2e6697d9041a83f2d6c90a1b7f5467ce25545ce9b2143f87b1f2b2eb78a647b963aa2438ea
+MISC metadata.xml 788 BLAKE2B d8484727eaeaecc48fde1039c9081d9e1c9572487f9a327a8464dbe448f407efc649499c06d7eca01fdd5eefc51cf7a33ef1bcfbf7df683276904a3f7367e4cf SHA512 1f9528e412f4621928b9da5970bfb244193b763bd27e235e40ae62efd7981be831ca2beebb060e335e432cad1f52ab2bbef2536eca19095e9115db0efa3c4ca2
diff --git a/app-admin/augeas/augeas-1.13.0.ebuild b/app-admin/augeas/augeas-1.13.0.ebuild
new file mode 100644
index 000000000000..b471ac9f4b88
--- /dev/null
+++ b/app-admin/augeas/augeas-1.13.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="https://github.com/hercules-team/augeas/releases/download/release-${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ >=app-doc/NaturalDocs-1.40
+ virtual/pkgconfig
+ test? ( dev-lang/ruby )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-selinux.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # selinux needs to be implemented
+ econf --without-selinux
+}
+
+src_compile() {
+ addpredict /usr/share/NaturalDocs/Config/Languages.txt
+ addpredict /usr/share/NaturalDocs/Config/Topics.txt
+
+ default
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/app-admin/augeas/files/augeas-1.13.0-selinux.patch b/app-admin/augeas/files/augeas-1.13.0-selinux.patch
new file mode 100644
index 000000000000..e1af18805a22
--- /dev/null
+++ b/app-admin/augeas/files/augeas-1.13.0-selinux.patch
@@ -0,0 +1,19 @@
+https://github.com/hercules-team/augeas/commit/f38398a2d07028b892eac59449a35e1a3d645fac
+
+From f38398a2d07028b892eac59449a35e1a3d645fac Mon Sep 17 00:00:00 2001
+From: Leo-Schmit <63145459+Leo-Schmit@users.noreply.github.com>
+Date: Tue, 20 Sep 2022 13:41:31 +0200
+Subject: [PATCH] Replace deprecated 'security_context_t' with 'char *' (#747)
+
+--- a/src/transform.c
++++ b/src/transform.c
+@@ -918,7 +918,7 @@ static int transfer_file_attrs(FILE *from, FILE *to,
+ struct stat st;
+ int ret = 0;
+ int selinux_enabled = (is_selinux_enabled() > 0);
+- security_context_t con = NULL;
++ char *con = NULL;
+
+ int from_fd;
+ int to_fd = fileno(to);
+
diff --git a/app-admin/augeas/metadata.xml b/app-admin/augeas/metadata.xml
index b374ce3fe233..900379c4291c 100644
--- a/app-admin/augeas/metadata.xml
+++ b/app-admin/augeas/metadata.xml
@@ -2,16 +2,19 @@
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
+ <email>prometheanfire@gentoo.org</email>
</maintainer>
<longdescription lang="en">
-A library for programmatically editing configuration files. Augeas parses
-configuration files into a tree structure, which it exposes through its
-public API. Changes made through the API are written back to the initially
-read files.
+ A library for programmatically editing configuration files. Augeas parses
+ configuration files into a tree structure, which it exposes through its
+ public API. Changes made through the API are written back to the initially
+ read files.
-The transformation works very hard to preserve comments and formatting
-details. It is controlled by ``lens'' definitions that describe the file
-format and the transformation into a tree.
-</longdescription>
+ The transformation works very hard to preserve comments and formatting
+ details. It is controlled by ``lens'' definitions that describe the file
+ format and the transformation into a tree.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">hercules-team/augeas</remote-id>
+ </upstream>
</pkgmetadata>