summaryrefslogtreecommitdiff
path: root/app-admin/augeas
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/augeas
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/augeas')
-rw-r--r--app-admin/augeas/Manifest5
-rw-r--r--app-admin/augeas/augeas-1.10.1.ebuild46
-rw-r--r--app-admin/augeas/augeas-1.8.1.ebuild46
-rw-r--r--app-admin/augeas/metadata.xml17
4 files changed, 114 insertions, 0 deletions
diff --git a/app-admin/augeas/Manifest b/app-admin/augeas/Manifest
new file mode 100644
index 000000000000..d65f3e2722a2
--- /dev/null
+++ b/app-admin/augeas/Manifest
@@ -0,0 +1,5 @@
+DIST augeas-1.10.1.tar.gz 2289207 BLAKE2B 6e3cf750c4d3faf7dc472ec7bfe3c46f5babca294d2bd5169cca419c2f93e21bdd656bbc44b30ab66c00fb793df1aa045f60c1260963901773c334b9019eff0b SHA512 382e8ef6a5bd3d12d7d2e0d2987f39c04ff7df3f07cd68aa732bf266b89d5d59a85be63921a7ff70f9219dbc6bb8547f80528242caa9417e08a008d1721cb1d2
+DIST augeas-1.8.1.tar.gz 2165325 BLAKE2B aa309984b5b11441fd2b10f3dc0b4a5f79a39038c1a71af6f7ef68b4fc24074db0bbcfd97341828211cc63d60d4b814515b119d0305367e9594cd5aa5159b822 SHA512 80be6dc75e86e2a00c56cb668824ffbe54105b64fad64a2737d980c8ee5ba347a97ddd190a1c712bd07a768ed23a8d07b0eb676033b367632036a8e7f98c976b
+EBUILD augeas-1.10.1.ebuild 1000 BLAKE2B c6d0e200c970a67013c4495d5018f622a947c96de0f3f6435b9b8ae193335a5c7181e33debab36db20fe96fcdd87ce1e4e4b00ea2a22c3ebb37aa6e46e906608 SHA512 85322cb00d04bf5b8c9b7534126ed6c966b73f094b63afc211345d80ee83a836d90bec866168107d390072c2f0d90ea113b4fa1b525c54d4c3d820bafa704b9a
+EBUILD augeas-1.8.1.ebuild 1000 BLAKE2B 601f1da391549d104db635310c3fbc7ce590c0b14428b4059e6f32c4f5265a3821eb28f7581766cc773572646e67434d3114ba8d2959cf15a4418884f18e482b SHA512 47871941fbcb08efce33560c5e8d857fef6e2dff1cdde7c31af6b205517af837840b83664fde9b6943b5ee3c3a367a7709c603b9409397cb79d7f879fedde1a0
+MISC metadata.xml 693 BLAKE2B c47bd36818c81a0fcb3d8f2e18e7a48797038c8a4a93302d592140faaed41d093523b6ad407b58dc7ae8c5f81c999c04e8514511b685e2a9b7d556dea177bde8 SHA512 1fcdcea259ed6cb652d08e763ccc67bee7bd5da9a7d3600dd492beaec7300868a47a7afdd71950ca8631886042428fce36cc17602a0776a9fa489f0fa2d27436
diff --git a/app-admin/augeas/augeas-1.10.1.ebuild b/app-admin/augeas/augeas-1.10.1.ebuild
new file mode 100644
index 000000000000..da590fa69145
--- /dev/null
+++ b/app-admin/augeas/augeas-1.10.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ default
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs="--without-selinux
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)"
+ eautoreconf
+ econf ${myeconfargs}
+ default
+}
diff --git a/app-admin/augeas/augeas-1.8.1.ebuild b/app-admin/augeas/augeas-1.8.1.ebuild
new file mode 100644
index 000000000000..bd87d5c497e5
--- /dev/null
+++ b/app-admin/augeas/augeas-1.8.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ~ppc64 sparc x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ default
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs="--without-selinux
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)"
+ eautoreconf
+ econf ${myeconfargs}
+ default
+}
diff --git a/app-admin/augeas/metadata.xml b/app-admin/augeas/metadata.xml
new file mode 100644
index 000000000000..2b1c8d903c2b
--- /dev/null
+++ b/app-admin/augeas/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+A library for programmatically editing configuration files. Augeas parses
+configuration files into a tree structure, which it exposes through its
+public API. Changes made through the API are written back to the initially
+read files.
+
+The transformation works very hard to preserve comments and formatting
+details. It is controlled by ``lens'' definitions that describe the file
+format and the transformation into a tree.
+</longdescription>
+</pkgmetadata>