summaryrefslogtreecommitdiff
path: root/app-admin/augeas/augeas-1.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-admin/augeas/augeas-1.9.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-admin/augeas/augeas-1.9.0.ebuild')
-rw-r--r--app-admin/augeas/augeas-1.9.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-admin/augeas/augeas-1.9.0.ebuild b/app-admin/augeas/augeas-1.9.0.ebuild
new file mode 100644
index 000000000000..1caae80ecb1a
--- /dev/null
+++ b/app-admin/augeas/augeas-1.9.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A library for changing configuration files"
+HOMEPAGE="http://augeas.net/"
+SRC_URI="http://download.augeas.net/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static-libs test"
+
+RDEPEND="
+ dev-libs/libxml2
+ sys-libs/readline:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=app-doc/NaturalDocs-1.40
+ test? ( dev-lang/ruby )"
+
+PATCHES=(
+)
+
+src_prepare() {
+ if [ -f /usr/share/NaturalDocs/Config/Languages.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Languages.txt
+ fi
+ if [ -f /usr/share/NaturalDocs/Config/Topics.txt ] ; then
+ addwrite /usr/share/NaturalDocs/Config/Topics.txt
+ fi
+ default
+}
+
+src_configure() {
+ # Needs to implemented
+ local myeconfargs="--without-selinux
+ $(use_enable !static-libs shared)
+ $(use_enable static-libs static)"
+ eautoreconf
+ econf ${myeconfargs}
+ default
+}