summaryrefslogtreecommitdiff
path: root/app-admin/apg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/apg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/apg')
-rw-r--r--app-admin/apg/Manifest6
-rw-r--r--app-admin/apg/apg-2.3.0b-r5.ebuild51
-rw-r--r--app-admin/apg/files/apg-2.3.0b-cracklib.patch17
-rw-r--r--app-admin/apg/files/apg-2.3.0b-crypt_password.patch31
-rw-r--r--app-admin/apg/files/apg-glibc-2.4.patch11
-rw-r--r--app-admin/apg/metadata.xml13
6 files changed, 129 insertions, 0 deletions
diff --git a/app-admin/apg/Manifest b/app-admin/apg/Manifest
new file mode 100644
index 000000000000..3914e77cd8d7
--- /dev/null
+++ b/app-admin/apg/Manifest
@@ -0,0 +1,6 @@
+AUX apg-2.3.0b-cracklib.patch 925 BLAKE2B bcc3579d24a69d6936fd14d78cd2d1a1b3f467eb892faa0e7e1ba170dce41e14e3f8c4ebddf44a28d27cb9825d789e54cfc2332ce48bdb582b8536317566d03f SHA512 19477c54c22d2fff712a8a5822bfa11fbf42a55a27a18eb9d6bdbe38e3c388342bc36f596d4c2e03cfbdb9c4a4c6a35b519b48e909602332e063e41c906889eb
+AUX apg-2.3.0b-crypt_password.patch 836 BLAKE2B 974a8a4d5936cc7b30535746011f34f659f46a7f168ca4b60927ac51d88e16dd7b56a3696f2242a53c871e5d0ecaa47135673b2f6a61d2315e44e2f68ec871fb SHA512 3696ea5cf3ebadd22daf589ee708e1472e6f0d7e569cc479b1ea4e59743a31aa484a254e4c02d908996faab624999db76e443f74dccd2117fdab44e1e7fb8580
+AUX apg-glibc-2.4.patch 261 BLAKE2B 10de29e4200591ab800f3c33a2d2936beb0c3c8812b37c9446ac178277d6a54128b675f61d96d607ff4ddc7f23598d61de69d9a6adc3ed20900cd9d944106989 SHA512 c7a3f388b5132d21caf6d45ad0c987bb9511a9fc4edd9e7f75739c270438d436159603b4eeb554bbc8cafce3329d01b66d11ab6e75f43b8bd2de57a31bd73bf5
+DIST apg-2.3.0b.tar.gz 109995 BLAKE2B 9b4a6141fb7f6e649fe06ed91bda636879a03d6e5e6071267bbb6cd27e63b4588c23ea7902c5b1a74dde8520843566a4f2857a34f4d66020142425e5faf53daf SHA512 3112d2267f2311f960a52fa268b55a5faf0250a4a8c5e7444f0c1326afa2844a476a54befcf79e5b8532d74c53f6f58ffc420591c8c36798dd82b43c14869e1a
+EBUILD apg-2.3.0b-r5.ebuild 1344 BLAKE2B cbdb7df15da6c6b6e08804bc5b9a94124a62c2d10c6873a697047d1ab1bbfd0c94bbfe1c992b3a958b141705c8c3749bd9c13a1b1a7646c8e8e28bf9ce56dbb0 SHA512 69f23df5f60996446721ec5ad11b201fa97cf4a1c2c12e28da17ff855debcb349e293fbba174066aa91fac5f773fe69c1b45b46530bc853dcc4c474699c60cd3
+MISC metadata.xml 490 BLAKE2B 6daed6930e317bb6b39f21dccd9cc4f08ddc549528076d6948212c7f62fe5d1e981f57c52278ea0fbcfd3fa36b3ce79192d52bc6e91c64940c1285933166735c SHA512 b1c2173415979d73b36b5e1650f27eebb89698f65a75af8351f8f77e762b9e54798a7b2398d6146ec54e975e4dd8ce59efc3b3c803eec863784107b1ce588e9c
diff --git a/app-admin/apg/apg-2.3.0b-r5.ebuild b/app-admin/apg/apg-2.3.0b-r5.ebuild
new file mode 100644
index 000000000000..818202c48ce4
--- /dev/null
+++ b/app-admin/apg/apg-2.3.0b-r5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Another Password Generator"
+HOMEPAGE="http://www.adel.nursat.kz/apg/"
+SRC_URI="http://www.adel.nursat.kz/apg/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 hppa ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cracklib"
+
+DEPEND="cracklib? ( sys-libs/cracklib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ chmod -R 0700 "${S}"
+ if use cracklib; then
+ epatch "${FILESDIR}"/${P}-cracklib.patch
+ epatch "${FILESDIR}"/${PN}-glibc-2.4.patch
+ fi
+ epatch "${FILESDIR}"/${P}-crypt_password.patch
+}
+
+src_compile() {
+ sed -i 's,^#\(APG_CS_CLIBS += -lnsl\)$,\1,' Makefile \
+ || die "Sed failed"
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i 's,^APG_CLIBS += -lcrypt,APG_CLIBS += ,' Makefile \
+ || die "Sed failed"
+ fi
+
+ emake \
+ FLAGS="${CFLAGS} ${LDFLAGS}" CFLAGS="${CFLAGS} ${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ standalone || die "compile problem"
+ emake FLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" \
+ -C bfconvert || die "compile problem"
+}
+
+src_install() {
+ dobin apg apgbfm bfconvert/bfconvert || die
+ dodoc CHANGES INSTALL README THANKS TODO || die
+ cd doc
+ doman man/apg.1 man/apgbfm.1 || die
+ dodoc APG_TIPS pronun.txt rfc0972.txt rfc1750.txt || die
+}
diff --git a/app-admin/apg/files/apg-2.3.0b-cracklib.patch b/app-admin/apg/files/apg-2.3.0b-cracklib.patch
new file mode 100644
index 000000000000..a1c34a14f5a0
--- /dev/null
+++ b/app-admin/apg/files/apg-2.3.0b-cracklib.patch
@@ -0,0 +1,17 @@
+--- Makefile 2003-08-07 09:40:39.000000000 -0600
++++ Makefile.cracklib 2004-10-14 07:16:17.288530686 -0600
+@@ -44,10 +44,10 @@
+ # If you want to use cracklib for password quality check then you
+ # must uncomment the folowing 4 lines (you must not do this for WIN32)
+ #
+-#CRACKLIB_DICTPATH = "/usr/local/lib/pw_dict"
+-#STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}' -I/usr/local/include -L/usr/local/lib
+-#APG_CLIBS += -lcrack
++CRACKLIB_DICTPATH = "/usr/lib/cracklib_dict"
++STANDALONE_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}'
++CLISERV_OPTIONS += -DAPG_USE_CRACKLIB '-DCRACKLIB_DICTPATH=${CRACKLIB_DICTPATH}'
++APG_CLIBS += -lcrack
+
+ ##################################################################
+ # Support for ANSI X9.17/SHA1 PRNG
diff --git a/app-admin/apg/files/apg-2.3.0b-crypt_password.patch b/app-admin/apg/files/apg-2.3.0b-crypt_password.patch
new file mode 100644
index 000000000000..93f3f152a2b4
--- /dev/null
+++ b/app-admin/apg/files/apg-2.3.0b-crypt_password.patch
@@ -0,0 +1,31 @@
+--- restrict.c 2007-03-09 13:48:27.000000000 +0300
++++ restrict.c 2007-03-09 13:49:31.000000000 +0300
+@@ -33,6 +33,9 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++#if defined(APG_USE_CRACKLIB)
++#include <crack.h>
++#endif /* APG_USE_CRACKLIB */
+ #include "restrict.h"
+ extern struct sym smbl[94];
+ /*
+--- apg.c 2007-03-08 17:32:40.000000000 +0300
++++ apg.c 2007-03-08 17:34:07.000000000 +0300
+@@ -100,6 +100,7 @@
+ #else /* CLISERV */
+ #if defined(APG_USE_CRACKLIB)
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vkt"
++#include <crack.h>
+ #else /* CRACKLIB */
+ #define APG_PROGRAMM_OPTIONS "M:E:a:r:b:p:n:m:x:vt"
+ #endif /* CRACKLIB */
+@@ -709,7 +710,7 @@
+ */
+ char * crypt_passstring (const char *p)
+ {
+- char salt[10];
++ char salt[11];
+ gen_rand_pass (salt, 10, 10, S_SL|S_CL|S_NB);
+ return (crypt(p, salt));
+ }
diff --git a/app-admin/apg/files/apg-glibc-2.4.patch b/app-admin/apg/files/apg-glibc-2.4.patch
new file mode 100644
index 000000000000..be90c6355e66
--- /dev/null
+++ b/app-admin/apg/files/apg-glibc-2.4.patch
@@ -0,0 +1,11 @@
+--- restrict.h.orig 2006-03-26 03:33:50.168661936 +0400
++++ restrict.h 2006-03-26 03:34:10.427582112 +0400
+@@ -33,6 +33,8 @@
+ #ifndef APG_RESTRICT_H
+ #define APG_RESTRICT_H 1
+
++#define uint32_t int
++
+ #if defined(APG_USE_CRACKLIB)
+ #include <packer.h>
+ #endif
diff --git a/app-admin/apg/metadata.xml b/app-admin/apg/metadata.xml
new file mode 100644
index 000000000000..971e516f3bf3
--- /dev/null
+++ b/app-admin/apg/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>DuPol@gmx.de</email>
+ <name>Dustin Polke</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+<longdescription>Another Password Generator. Generates random, pronouncable passwords with a variety of algorithms</longdescription>
+</pkgmetadata>