summaryrefslogtreecommitdiff
path: root/app-admin/ansible
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-admin/ansible
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-admin/ansible')
-rw-r--r--app-admin/ansible/Manifest2
-rw-r--r--app-admin/ansible/ansible-2.9.7.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/app-admin/ansible/Manifest b/app-admin/ansible/Manifest
index 7e71b6599eb9..1c0ab11fb428 100644
--- a/app-admin/ansible/Manifest
+++ b/app-admin/ansible/Manifest
@@ -1,4 +1,6 @@
DIST ansible-2.9.6.tar.gz 14201258 BLAKE2B 29da78035291a252f215a49945e82d9f3598a91c9c8993c69623668e9f8a667882330d51c75e1ae27ee5242f4a6320ee947af338c4c38e23f4f9d04cf19364ca SHA512 7111fd72b4e029b2f661bfb849b4323b69ea796f8a069ad3120e8de390effa670180c69ca0fd5e0a1c2e444db6d574a52d530a2b0343c76cd81ba963b3c3a7cb
+DIST ansible-2.9.7.tar.gz 14215538 BLAKE2B b3882c359d0e71446c81b4f4592a08447656c22ed70358d7eddf36f4a84811d97f047afcdfd57f67664a130cee5c1231a106fc5b77b52cfab8b1be868ee03f81 SHA512 ce029441bcafdc5b44c9fda69f183d4defea84ead5628164caf87306cb97efec68c11b2cce728e90f28290640c320549486a6b4e823710f638d1d2e7c35675a4
EBUILD ansible-2.9.6.ebuild 1711 BLAKE2B 1697739493cf880bc2b0374ca2afc1e4fae28d0740afd9f237ad2507a3f69e7c837ccabdaf9cae2f66ba99536da0bcc83f6b5b364a63d41e89395c2e43d6add7 SHA512 719e35eba96cc4ef0d4558a508f553b63efe60151bed4e69671247b21f789090e34e75380a7267ac40639b75920cf3054ba6aeeee891adac98bec1d0c2243538
+EBUILD ansible-2.9.7.ebuild 1713 BLAKE2B a888274e71e059297c58d463de427aa3cc2c04ebf1bc272f98830cefe96c2a2dfeca7e3d5bf26b9724f1840631c586fab0753caf2d799e18dc94f23cdb63acdc SHA512 4582bd23813d31dee689dabd84f020e20249582dd8c51e7aa4221bbe21237e92ae5c48305e6bb0380dfafa754ff3cd56ff243a1e1ce93ffd9f89786e8fa42ce4
EBUILD ansible-9999.ebuild 1697 BLAKE2B da48c9b97787143e815cc768b5aebbf7bf005ac8a8562a3420f4d4594214e601e90cab78a447017de45b7217952c5c2b0922e37c2e7770b2e786632089230b22 SHA512 0276bdacbfef27725a2714d8cc56d05c2c64d2b37fcbe77d7cbeebaf30828364a7ecf86ea960327d01ae1e3202387777b32d5903152b405036c2541bc38c7f9f
MISC metadata.xml 952 BLAKE2B 53640d081ebb558274f8c10095aa6e477820e28a7fdf62c169f5fb3b82153223a7f8ecd1807d14646eae2ec2262b50341919bbb13255293d379ba017b30b20bd SHA512 03b75d65cd0a4b32021b34d9f7ba21b6c4c6893cf185a36dbe6fc10728e0f18c65fc5b6a4c197be8c2b1dadb7243ddce02dbe2f504034a2df1c621f8ba6e26a7
diff --git a/app-admin/ansible/ansible-2.9.7.ebuild b/app-admin/ansible/ansible-2.9.7.ebuild
new file mode 100644
index 000000000000..8c8b3a948043
--- /dev/null
+++ b/app-admin/ansible/ansible-2.9.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://ansible.com/"
+SRC_URI="https://releases.ansible.com/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x64-macos"
+IUSE="doc test"
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ net-misc/sshpass
+ virtual/ssh
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx-notfound-page[${PYTHON_USEDEP}]
+ >=dev-python/pygments-2.4.0[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/passlib[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
+python_test() {
+ nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
+ distutils-r1_python_install_all
+
+ dodoc -r examples
+}