summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-25 15:22:17 +0100
commit22910f5d14da606bd7f06e19a2f61c5d1a8fc94b (patch)
tree808b5701901fb54b53ec3ecf6f33272e933f3ea6 /app-admin/ansible/ansible-9999.ebuild
parent91c0ec2d7067f6ab1ef578bd9967b32ca07eb502 (diff)
gentoo resync : 25.05.2018
Diffstat (limited to 'app-admin/ansible/ansible-9999.ebuild')
-rw-r--r--app-admin/ansible/ansible-9999.ebuild16
1 files changed, 11 insertions, 5 deletions
diff --git a/app-admin/ansible/ansible-9999.ebuild b/app-admin/ansible/ansible-9999.ebuild
index cbb8b3767281..0ca97a267cc6 100644
--- a/app-admin/ansible/ansible-9999.ebuild
+++ b/app-admin/ansible/ansible-9999.ebuild
@@ -15,7 +15,7 @@ EGIT_BRANCH="devel"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE="doc test"
RDEPEND="
dev-python/paramiko[${PYTHON_USEDEP}]
@@ -32,6 +32,7 @@ RDEPEND="
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/packaging-16.6[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
test? (
${RDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
@@ -42,6 +43,14 @@ DEPEND="
dev-vcs/git
)"
+python_compile_all() {
+ if use doc; then
+ cd docs/docsite || die
+ export CPUS=4
+ emake -f Makefile.sphinx html
+ fi
+}
+
python_prepare_all() {
rm -fv MANIFEST.in || die
distutils-r1_python_prepare_all
@@ -51,11 +60,8 @@ python_test() {
nosetests -d -w test/units -v --with-coverage --cover-package=ansible --cover-branches || die
}
-python_compile_all() {
- emake -j1 docs
-}
-
python_install_all() {
+ use doc && local HTML_DOCS=( docs/docsite/_build/html/. )
distutils-r1_python_install_all
doman docs/man/man1/*.1