summaryrefslogtreecommitdiff
path: root/app-admin/ansible/ansible-9.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-21 12:05:28 +0100
commit490ef2c2dc8b4e808f37add1adee21a754efd9a9 (patch)
treee235cdf15550b3d2f644b6fc4a8aa726971416f5 /app-admin/ansible/ansible-9.4.0.ebuild
parentda7ae1dd1fccb6b3c0e4763ab983ad96d57bf463 (diff)
gentoo auto-resync : 21:04:2024 - 12:05:28
Diffstat (limited to 'app-admin/ansible/ansible-9.4.0.ebuild')
-rw-r--r--app-admin/ansible/ansible-9.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/ansible/ansible-9.4.0.ebuild b/app-admin/ansible/ansible-9.4.0.ebuild
new file mode 100644
index 000000000000..51baea072b8f
--- /dev/null
+++ b/app-admin/ansible/ansible-9.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+DISTUTILS_USE_PEP517=setuptools
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Model-driven deployment, config management, and command execution framework"
+HOMEPAGE="https://www.ansible.com/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~ppc64 ~riscv x86 ~x64-macos"
+RESTRICT="test"
+
+RDEPEND=">=app-admin/ansible-core-2.16.0
+ <app-admin/ansible-core-2.17"
+
+python_compile() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_compile
+}
+python_install() {
+ local -x ANSIBLE_SKIP_CONFLICT_CHECK=1
+ distutils-r1_python_install
+}