summaryrefslogtreecommitdiff
path: root/app-admin/abrt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-admin/abrt
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-admin/abrt')
-rw-r--r--app-admin/abrt/Manifest2
-rw-r--r--app-admin/abrt/abrt-2.15.0.ebuild127
2 files changed, 129 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index fe03a21add45..ce0b48b8954e 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -3,5 +3,7 @@ AUX abrt-2.0.12-r1-init 1921 BLAKE2B dc8bbe3d4902ac65165f1e71eb6400810980f6b9001
AUX abrt-2.14.6-glib270.patch 1498 BLAKE2B c6d15a5d32bc1aa939d2b024d452fffada34b2cb1eb6e828f882242858eef64be8810f775726f837c7cc095943997fc310a2643957c47c274a88cabf73ed518f SHA512 91c42149f2689be2f2865c5f2972afd62ae7111673a0ebf8451a3a122cd290cddf3720c62f8ee5c28af9dd1b7805552f533bafd0aec936a3142699ef8d4c1fe5
AUX abrt-2.14.6-lazy-imports.patch 1727 BLAKE2B dfb918555e02ba320aa9c785fe5c9a12826870d4bd0fd4dfb6cc9ceded057dccb81e501d208858f3bb7c0fd63248b910df12e54cd760b720a74f39e7f71a7daf SHA512 c8141624883227548ac34600d9e6604d103a7b0f91ee9c2190744b7c88209eba73d81f06135d1422c53f9cf12a5edf26e5f659d56c70b1d77aa9c75e273bfab4
DIST abrt-2.14.6.tar.gz 6057661 BLAKE2B 2ef74203181c89818f283a801c4a1a0f22a01c92ca2415d245dc180ee721b3e29cb75c95e45d738f88b6bbf339fe8bef4e499ab6fecad33399dc8a5af8f98d4c SHA512 eb1ba2f624d51eeccd203bb23060493347f5a9142fad7d0570d46134071d870a9c66b4fbfb8210e7d6f87c0c039f31eb486d18a36b10fba318e2180aa09df9fe
+DIST abrt-2.15.0.tar.gz 6122114 BLAKE2B ac075a15d4621596bbe3009bf2e4725040139d78077f85bd4daebbe86504f9aa0a12dcedcf3b5b65404bc2851e93e6b1113dcc37923832c826d572ab9810ef94 SHA512 2d6c1287c1f01990aeb30f956f465c7a6399a6e53dc667602e263c136f94bc4090b58876acba678b29671c0db89ae8e7dd6994cf8d0d2d9fbc375f54ae6cd935
EBUILD abrt-2.14.6-r1.ebuild 3405 BLAKE2B ec5bf02b52d1d2bf0ce773ca1ffc83145848296110551cac2678b10c8c45bfe20f1f30d91184a728afc4cbf8056f1c1f2b74e7168372190e9d7fd14e03ab1005 SHA512 88e33f8d777cd05b50b0a6fce28cc4b0685e0985f45249cadd236f8c5507b9019ffd47592e013ba625096ea3d1a365958a51b174af821f919145f2160e614c55
+EBUILD abrt-2.15.0.ebuild 3217 BLAKE2B f8ef650d66cd1f3103ed2063553dba6022568e03ec2c7d0056d98dbc025005fb1df0d8f595aef0355e0c12ffc0c39a71bb4fa5e137c126b993b1cb45777f27e5 SHA512 4f1551dbb6afbe2e6b5c56c5ae32206b7a77d815d3c91b73c6405be957e4c4fb4db4820354ca3fbe53c5c35d1d59237a30234b1582749319f83c5c512cfe9ad7
MISC metadata.xml 318 BLAKE2B 09afc80150b955861543909cf2b31829ee72a6cf2ccb265fadf855d36f0d7666b9a4fc53c68ca47c3e72002ea70ec338186bee5808f65e2a8586ce5965711c46 SHA512 033123dd526fad2b3f7affc739255d15e806de3e7fe9fa1da56197288b5da997bbdc8025b0354a655ab6d4e5b77e2e72865955dffe5b7ebb8c037182d6ce4deb
diff --git a/app-admin/abrt/abrt-2.15.0.ebuild b/app-admin/abrt/abrt-2.15.0.ebuild
new file mode 100644
index 000000000000..6a77875e2603
--- /dev/null
+++ b/app-admin/abrt/abrt-2.15.0.ebuild
@@ -0,0 +1,127 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit autotools python-single-r1 tmpfiles xdg
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project https://github.com/abrt/abrt"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="selinux test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RESTRICT="!test? ( test )"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libreport-2.13.0:=[gtk,python]
+ dev-libs/libxml2:2
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ net-libs/libsoup:2.4
+ sys-apps/dbus
+ sys-apps/systemd:0=
+ sys-auth/polkit
+ sys-libs/libcap
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+ x11-libs/libnotify
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+ app-arch/cpio
+ app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/elfutils
+ dev-libs/json-c:0=
+ sys-apps/util-linux
+ >=sys-devel/gdb-7
+ $(python_gen_cond_dep '
+ dev-libs/satyr[${PYTHON_USEDEP}]
+ dev-python/argcomplete[${PYTHON_USEDEP}]
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/humanize[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ $(python_gen_cond_dep 'dev-python/python-systemd[${PYTHON_USEDEP}]')
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+
+ # Install under proper directory
+ sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
+
+ # Ensure this works for systems with and without /usr merge
+ sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
+
+ # Fix hardcoded "pytest-3"
+ sed -i -e "s:pytest-3:pytest:" \
+ configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --with-python3
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ $(use_with test pythontests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # /var/spool/abrt is created by dev-libs/libreport
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+
+ # Drop empy dirs, handled by tmpfiles
+ rm -r "${ED}"/var/run/ || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ tmpfiles_process abrt.conf
+}