summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /app-accessibility
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4725 -> 4724 bytes
-rw-r--r--app-accessibility/brltty/Manifest1
-rw-r--r--app-accessibility/brltty/brltty-6.1-r1.ebuild218
3 files changed, 219 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 4d0d55c0e5b7..18c4a5993dd0 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
index 902a2aa15566..aab868e2996c 100644
--- a/app-accessibility/brltty/Manifest
+++ b/app-accessibility/brltty/Manifest
@@ -3,5 +3,6 @@ AUX brltty-6.0-udev.patch 1033 BLAKE2B d5220b3351af4191ab78f122265296ed802209d03
AUX brltty.rc 241 BLAKE2B 873b1344cc6dee3aa6272d9c8857b58a751200e77d7fa0d96f9ff992f2825267503db5fc11ea07d7064a0fa4fe78af637c41ced04212d063efb92183bb936c9f SHA512 d3b91fddbfa61e212537c58444585262d2781fa97ff7f8f4e9ab3c3ad937c680b230d805f7541e2701050e2b001d7d11f7e5937476568a3459d73bb36026f847
AUX brltty.tmpfiles.conf 31 BLAKE2B e51c4c6e98da2d68ebd2aca39d3015ca28b40dbee5528155f9efb87ef8ec5264b382c78acf748514bd1f3902dbedcd471f4e18b0361c6a924108a950c75aceb9 SHA512 3d52a11e0d266ac508ab5447b6515f006f610e3bcb2ec396c3fe4c58a68874c9568f7fd6a143829f69c1b87680f1157953eae9fe326f5db3723c7e4b46390bf7
DIST brltty-6.1.tar.xz 3394852 BLAKE2B 03e6358721dcd5c3bdee3301a1ed827a690128ec339669543279c7e9a115bef6c5d8630e4af2d0b214b9c7c3eaa9001ab4c54ae7fb899cb3bc675985f51d6933 SHA512 030ef60ef7a9a60dc2fba2a64ea0a0868395eee6f2f86876b4e4111e804a05b44f798a154a69a8f5e0f6358130993c360a550f7decac0535450f9cf939231eaf
+EBUILD brltty-6.1-r1.ebuild 5610 BLAKE2B 26895fc3e3e42bccb0a769a9cbca0d0c2608681f8592f4f6d61854504b50119c70b4ef5a9fe6ce69c748488561ea7d6b18910b1d600ba361267b325720bb232e SHA512 924edbad232cb247b7a03f03a9051478ebe26b91dc3100b76839ad2a437681e5f4950997f28d271150ce3df1447de5eb733a2d5be2a71b1b3a5db0af999ac284
EBUILD brltty-6.1.ebuild 5601 BLAKE2B e26efd68d25484109eac679fe9ee28a86da220089f5a642ac412096476727d967f594465c31e2001e5119b5b35e0ac2a092c428844c4e79bec3a923a385a5019 SHA512 a1e938b5e8648286c03ad10164cbae3b3f07ff9faebc6c09f38f4ebc0c4ce6ac8890d6e9ee222af854a603003773de73583b1fdde96b1d54256ced864cdb71b2
MISC metadata.xml 1662 BLAKE2B 46ba8439b31b6d391c93bdf34188c57179bcb3af882065b559ea41473937627802cf49a32300b47c590a0c13470fb72ed46ea272d4598e1cb8fdb2cc7b715653 SHA512 4849dc267e88460878b084ebf551dc3cabd3808aaba4e8779cd13528a7db665707e8291ed4965da6ef995a99cacb18f8b68fa54d3bd81ffcd1efe13e77aa4b8c
diff --git a/app-accessibility/brltty/brltty-6.1-r1.ebuild b/app-accessibility/brltty/brltty-6.1-r1.ebuild
new file mode 100644
index 000000000000..14ae62a8ce07
--- /dev/null
+++ b/app-accessibility/brltty/brltty-6.1-r1.ebuild
@@ -0,0 +1,218 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+FINDLIB_USE="ocaml"
+JAVA_PKG_WANT_SOURCE="1.8"
+JAVA_PKG_WANT_TARGET="1.8"
+
+inherit findlib multilib toolchain-funcs java-pkg-opt-2 flag-o-matic usr-ldscript \
+ autotools udev systemd python-r1 tmpfiles
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="https://brltty.app/"
+SRC_URI="https://brltty.app/archive/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="+api +beeper bluetooth +contracted-braille doc +fm gpm iconv icu
+ java louis +midi ncurses nls ocaml +pcm policykit python
+ usb systemd +speech tcl xml X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api ${PYTHON_REQUIRED_USE} )
+ tcl? ( api )"
+
+DEPEND="
+ app-accessibility/at-spi2-core:2
+ dev-libs/libpcre2[pcre32]
+ sys-apps/dbus
+ bluetooth? ( net-wireless/bluez )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu:= )
+ louis? ( dev-libs/liblouis:= )
+ midi? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses:0= )
+ pcm? ( media-libs/alsa-lib )
+ policykit? ( sys-auth/polkit )
+ python? ( ${PYTHON_DEPS} )
+ speech? (
+ app-accessibility/espeak
+ app-accessibility/flite
+ app-accessibility/speech-dispatcher
+ )
+ systemd? ( sys-apps/systemd )
+ tcl? ( >=dev-lang/tcl-8.4.15:0= )
+ usb? ( virtual/libusb:0 )
+ xml? ( dev-libs/expat )
+ X? (
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXfixes
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+RDEPEND="${DEPEND}
+ java? ( >=virtual/jre-1.8:* )
+"
+BDEPEND="
+ virtual/pkgconfig
+ java? ( >=virtual/jdk-1.8:* )
+ nls? ( virtual/libintl )
+ python? ( >=dev-python/cython-0.16[${PYTHON_USEDEP}] )
+"
+
+HTML_DOCS=( "${S}"/Documents/Manual-BrlAPI/. )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.0-udev.patch
+ "${FILESDIR}"/${PN}-5.2-respect-AR.patch
+)
+
+src_prepare() {
+ default
+
+ java-pkg-opt-2_src_prepare
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ tc-export AR LD PKG_CONFIG
+
+ export JAVAC=""
+ export JAVA_JNI_FLAGS=""
+ if use java; then
+ export JAVA_HOME="$(java-config -g JAVA_HOME)"
+ export JAVAC_HOME="${JAVA_HOME}/bin"
+ export JAVA_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ export JAVAC="$(java-pkg_get-javac) -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ # override prefix in order to install into /
+ # braille terminal needs to be available as soon in the boot process as
+ # possible
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ local myconf=(
+ --prefix="${EPREFIX}"/
+ --localedir="${EPREFIX}"/usr/share/locale
+ --includedir="${EPREFIX}"/usr/include
+ --localstatedir="${EPREFIX}"/var
+ --disable-stripping
+ --with-writable-directory="${EPREFIX}"/run/brltty
+ $(use_enable api)
+ $(use_with beeper beep-package)
+ $(use_enable contracted-braille)
+ $(use_with fm fm-package)
+ $(use_enable gpm)
+ $(use_enable iconv)
+ $(use_enable icu)
+ $(use_enable java java-bindings)
+ $(use_enable louis liblouis)
+ $(use_with midi midi-package)
+ $(use_enable nls i18n)
+ $(use_enable ocaml ocaml-bindings)
+ $(use_with pcm pcm-package)
+ $(use_enable policykit polkit)
+ $(use_enable python python-bindings)
+ $(use_enable speech speech-support)
+ $(use_with systemd service-package)
+ $(use_enable tcl tcl-bindings)
+ $(use_enable xml expat)
+ $(use_enable X x)
+ $(use_with bluetooth bluetooth-package)
+ $(use_with ncurses curses)
+ $(use_with usb usb-package) )
+
+ econf "${myconf[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myconf[@]}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ emake JAVA_JNI_FLAGS="${JAVA_JNI_FLAGS}" JAVAC="${JAVAC}"
+
+ if use python; then
+ python_build() {
+ cd "Bindings/Python" || die
+ emake
+ }
+ python_foreach_impl run_in_build_dir python_build
+ fi
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake INSTALL_ROOT="${D}" OCAML_LDCONF= install
+
+ if use python; then
+ python_install() {
+ cd "Bindings/Python" || die
+ emake INSTALL_ROOT="${D}" install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ if use java; then
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ udev_newrules Autostart/Udev/rules 70-brltty.rules
+ newinitd "${FILESDIR}"/brltty.rc brltty
+ systemd_dounit Autostart/Systemd/brltty@.service
+ dotmpfiles "${FILESDIR}/${PN}.tmpfiles.conf"
+
+ if use api ; then
+ local libdir="$(get_libdir)"
+ mkdir -p "${ED}"/usr/${libdir}/ || die
+ mv "${ED}"/${libdir}/*.a "${ED}"/usr/${libdir}/ || die
+ gen_usr_ldscript libbrlapi.so
+ fi
+
+ cd Documents || die
+ mv Manual-BRLTTY/English/BRLTTY.txt BRLTTY-en.txt || die
+ mv Manual-BRLTTY/French/BRLTTY.txt BRLTTY-fr.txt || die
+ mv Manual-BrlAPI/English/BrlAPI.txt BrlAPI-en.txt || die
+ dodoc CONTRIBUTORS ChangeLog HISTORY README* TODO BRLTTY-*.txt
+ if use doc; then
+ dodoc BrlAPI-*.txt
+ HTML_DOCS="Manual-BRLTTY" einstalldocs
+ fi
+
+ keepdir /var/lib/BrlAPI
+ rmdir "${ED}/run/brltty" || die
+ rmdir "${ED}/run" || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.tmpfiles.conf
+
+ elog
+ elog "please be sure ${EROOT}/etc/brltty.conf is correct for your system."
+ elog
+ elog "To make brltty start on boot, type this command as root:"
+ elog
+ elog "rc-update add brltty boot"
+}