summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-11 04:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-11 04:37:21 +0100
commitf8d2edf76d3901ebc1ace32c33a4d547fd5eee63 (patch)
tree742aed438164cbd07e8b218247c5519dd17d8749 /app-accessibility
parent783da4542a9c3e0e1ec703644212707cde610679 (diff)
gentoo auto-resync : 11:09:2023 - 04:37:21
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4709 -> 4553 bytes
-rw-r--r--app-accessibility/espeak/Manifest4
-rw-r--r--app-accessibility/espeak/espeak-1.48.04-r1.ebuild103
-rw-r--r--app-accessibility/espeak/files/espeak-1.48.04-gcc-6-fix.patch13
-rw-r--r--app-accessibility/espeak/metadata.xml14
5 files changed, 0 insertions, 134 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index d545448ccba6..ed8c60c0d7bb 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/espeak/Manifest b/app-accessibility/espeak/Manifest
deleted file mode 100644
index 8787b8bd64c4..000000000000
--- a/app-accessibility/espeak/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX espeak-1.48.04-gcc-6-fix.patch 531 BLAKE2B e17d5304b52ab2e805f63d685f05bf5343a9fd1b64876091b64469ec652296a5de2d04e40b639bd1acb455e133330bfbc270e0d3293b4c487ca174e97d2d4837 SHA512 92966a8f3ef3a4cca2b208216ae9ecd65efdb67001b4ed8c0868bc95bc87fec88826f7554a5239c97269dc673cec8ac70f36c9f3fe186f0a5e6eca924e0bb681
-DIST espeak-1.48.04-source.zip 3019245 BLAKE2B a29da5eab832fa76b180049765f7fa671ebf47c0a68ee2cdfb0f4466846d97b2bf7b8f07dba747e236a27c9b077000bfd471e35b9744ffac7c9014679f5c04fd SHA512 f0759e6ace2604c8cbb19e8c3fd4b106edf4dcece247a6677f6b734af7746c35a367126edfbe585396c98f6c54f07e25d64bfab35e258e64f09bd2c0833247fa
-EBUILD espeak-1.48.04-r1.ebuild 2335 BLAKE2B ab6ff949f6602dd63f7b8870cd921cd890da96f308e02305a9ba9f002b4787075febd2957b7e72b3ab99bf12fd194dbe99826f6a041af3e3f411c0bf3dd89664 SHA512 71be8d8d0c892069c9ca15f44919883a95a68e75fe6944391b21c232643050eb73436272831ff910fcfa4fd74efab116f6f0e888327c1da395680d5ecc358c67
-MISC metadata.xml 426 BLAKE2B fa3afca193cba0b2979f177f7fd2a1fd984754590c01cb678e36de7e7434bff13fbcae9978d68f54235a52029f3e10b01ae6b0fb68c4913772c20cacfdde4bb2 SHA512 7192bf4f9808d3780bd4d690c7ea3adf96648e49ded906f67a60a3425e479dcfcdfcbe8b613ca50c165784962f046e574cfe642627d466c82696034fa0f43aaf
diff --git a/app-accessibility/espeak/espeak-1.48.04-r1.ebuild b/app-accessibility/espeak/espeak-1.48.04-r1.ebuild
deleted file mode 100644
index eebc2c473640..000000000000
--- a/app-accessibility/espeak/espeak-1.48.04-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P="${P}-source"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
-DESCRIPTION="Speech synthesizer for English and other languages"
-HOMEPAGE="http://espeak.sourceforge.net/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
-IUSE="portaudio pulseaudio"
-
-COMMON_DEPEND="portaudio? ( >=media-libs/portaudio-19_pre20071207 )
- pulseaudio? ( media-sound/pulseaudio )"
-
-DEPEND="${COMMON_DEPEND}
- app-arch/unzip"
-
-RDEPEND="${COMMON_DEPEND}
- media-sound/sox"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc-6-fix.patch )
-
-S="${WORKDIR}/${MY_P}/src"
-
-get_audio() {
- if use portaudio && use pulseaudio; then
- echo runtime
- elif use portaudio; then
- echo portaudio
- elif use pulseaudio; then
- echo pulseaudio
- else
- echo none
- fi
-}
-
-src_prepare() {
- default
- # gentoo uses portaudio 19.
- mv -f portaudio19.h portaudio.h
-}
-
-src_compile() {
- # Uses removed 'register' keyword, bug #894180
- append-cxxflags -std=c++14
-
- emake \
- PREFIX="${EPREFIX}/usr" \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}" \
- CXX="$(tc-getCXX)" \
- CXXFLAGS="${CXXFLAGS}" \
- AR="$(tc-getAR)" \
- AUDIO="$(get_audio)" \
- all
-
- einfo "Fixing byte order of phoneme data files"
- pushd ../platforms/big_endian > /dev/null
- emake \
- CC="$(tc-getCC)" \
- CFLAGS="${CFLAGS}"
- ./espeak-phoneme-data \
- ../../espeak-data \
- . \
- ../../espeak-data/phondata-manifest
- cp -f phondata phonindex phontab "../../espeak-data"
-}
-
-src_install() {
- emake \
- PREFIX="${EPREFIX}/usr" \
- LIBDIR="\$(PREFIX)/$(get_libdir)" \
- DESTDIR="${D}" \
- AUDIO="$(get_audio)" \
- install
-
- cd ..
- insinto /usr/share/espeak-data
- doins -r dictsource
- dodoc ChangeLog.txt ReadMe
- HTML_DOCS="docs/*" einstalldocs
-}
-
-pkg_preinst() {
- local voicedir="${ROOT}/usr/share/${PN}-data/voices/en"
- if [ -d "${voicedir}" ]; then
- rm -rf "${voicedir}"
- fi
-}
-
-pkg_postinst() {
- if ! use portaudio && ! use pulseaudio; then
- ewarn "Since portaudio and pulseaudio are not in your use flags,"
- ewarn "espeak will only be able to create wav files."
- ewarn "If this is not what you want, please reemerge ${CATEGORY}/${PN}"
- ewarn "with either portaudio or pulseaudio USE flag enabled."
- fi
-}
diff --git a/app-accessibility/espeak/files/espeak-1.48.04-gcc-6-fix.patch b/app-accessibility/espeak/files/espeak-1.48.04-gcc-6-fix.patch
deleted file mode 100644
index f28de7338b37..000000000000
--- a/app-accessibility/espeak/files/espeak-1.48.04-gcc-6-fix.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-https://src.fedoraproject.org/cgit/rpms/espeak.git/tree/espeak-1.48-gcc-6-fix.patch
-diff --git a/src/tr_languages.cpp b/src/tr_languages.cpp
---- a/tr_languages.cpp
-+++ b/tr_languages.cpp
-@@ -198,7 +198,7 @@ static const unsigned short chars_ignore_zwnj_hyphen[] = {
- 0x200d, 1, // zero width joiner
- 0, 0 };
-
--const char string_ordinal[] = {0xc2,0xba,0}; // masculine ordinal character, UTF-8
-+const char string_ordinal[] = {'\xc2','\xba',0}; // masculine ordinal character, UTF-8
-
-
- static Translator* NewTranslator(void)
diff --git a/app-accessibility/espeak/metadata.xml b/app-accessibility/espeak/metadata.xml
deleted file mode 100644
index 7a1669bb69a0..000000000000
--- a/app-accessibility/espeak/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>williamh@gentoo.org</email>
- </maintainer>
- <maintainer type="project">
- <email>accessibility@gentoo.org</email>
- <name>Gentoo Accessibility Project</name>
- </maintainer>
- <upstream>
- <remote-id type="sourceforge">espeak</remote-id>
- </upstream>
-</pkgmetadata>