summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-06 04:25:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-06 04:25:10 +0100
commitededf7351b15c0df4d166af8fc7928bd1a0b2c8e (patch)
tree1125adc62f8977a4cd0fd1c07ecdb6c4389f7557 /app-accessibility
parent0234a4013e6d1821ab7db449aa7867d7141324a8 (diff)
gentoo auto-resync : 06:09:2023 - 04:25:10
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4711 -> 4709 bytes
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-45_rc.ebuild59
3 files changed, 61 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 654336bb26b3..d545448ccba6 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index d04817f25915..7fbf33934e62 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-44.1.tar.xz 3760772 BLAKE2B 1e2825e9183b86563d85f106f80b7fa84d7d0cc06c818cb72c2a307c9c85a421cbbfc581df7829afde558ddf468bc048382d059ae995661a5163d390585961b4 SHA512 951a60b7efd9b61762404c20b62d476c1ebc3fc2662c0be1feef307fa1761feb5195c89ce725db1585dde4c39d96e1aa74c2b5c934115a3c2669880c3c7ac200
+DIST orca-45.rc.tar.xz 3923500 BLAKE2B e7f919e0badf804612d2c778abab598437dca812507b2d5e5ba6b7fc34897ed8baaa739d3f72a1e56db13badf725675d468a525ab663db6e1eaa08191abd3654 SHA512 897e667b7c9fd98d01eafb79f1fcd02da078fa5d023a22301ba7ea2a84cd18c05684c4c297a1edd22232c5f72d64fa5fb78b35037ea4d8cfd3fdfa350c3500a7
EBUILD orca-44.1.ebuild 1451 BLAKE2B 0c926436900096c9c07475c261432a9f48edf20e592f775a25e8bad00f8bfc35733c01b4a58baf72174319cf2129dfb3aa32486141befd97cbd70056726f7904 SHA512 415993a87a11b8d8da8dd0cfe4fdcd5187c2b19533b60d3db077582b5d4f01f63f36b883aa1c1ddc10eee7918f7edf14c3bb99f116518fdd48d66c73e14ecfe6
+EBUILD orca-45_rc.ebuild 1455 BLAKE2B f9b6c14731b1bcd009ae627f0a75c87487eaca5992ed12c17bdbb1ec8b14e669b25bad7401c0a1ecd967c8229c5a4cd87915639c121192a04f6ba253139160ce SHA512 32b5a284d664739d80dcfcc968727bef2e2e4568d00e752fba707003c55dff117f1164f33940d7d560f44ff97933915e05e1301058a1a116a4b9f14635b9c4ed
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-45_rc.ebuild b/app-accessibility/orca/orca-45_rc.ebuild
new file mode 100644
index 000000000000..d9924573dce0
--- /dev/null
+++ b/app-accessibility/orca/orca-45_rc.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.48:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.46[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}