summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /app-accessibility
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4531 -> 4529 bytes
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-3.36.6.ebuild64
-rw-r--r--app-accessibility/speechd-el/Manifest2
-rw-r--r--app-accessibility/speechd-el/speechd-el-2.8.ebuild2
5 files changed, 68 insertions, 2 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 02a3377a900f..bf250216bb11 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index fc742bbd6dc4..bfe70c719184 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-3.36.5.tar.xz 3578288 BLAKE2B d9711720b7a104bc86c97f1821566dd710f0bd318a5409fc5bd5624e7f35a81e9cd0a3d9fd1337c58b09d1ed8fe1c9eeb5b0822e45f7a711a44405bcb8f54db6 SHA512 87756ab5ea962c715f1a00ba80a30cf2e812bab87cf6f13b437b45b39bb763b684fe69b8847a3ed543c398f79a4d2d3ed33b61f88414f432b473c0892453a4f0
+DIST orca-3.36.6.tar.xz 3465112 BLAKE2B 227610b5a01027c292cf9a99ecc54f76ad6053d6923325825ed5f81183b39e1e38e70e7a7d88561f0b0c4d212f16465542d57bf4aeed2fa893b8893fa1d3dd49 SHA512 be2752267d46077310eccc4d76dc5e87ce8e1715cc33ff6f8f15b83c9891a2ba98a2d681f893c88df5b0c5ffd8a1ebadc3a4286debf0ff14ba17803d20f902db
EBUILD orca-3.36.5.ebuild 1648 BLAKE2B 9f80152aa72444dcfe6343e75c77ef7ab9563123adcb336c340577e6948f862fca703b242d0998088ce517c1c57bea3e3886ecc119443d6e17d54b721124d838 SHA512 5b5964138479936516dd8d9f46a0972fb341c1e956c5483a5aa6f8a110f75995ce90aa05e50e3ed9f0a77851dfcb3c3deb2d6de5115730487a49e4c77f591efd
+EBUILD orca-3.36.6.ebuild 1650 BLAKE2B d61b4eaaa388fc1a6a6b915db0983773899354e387bf193d34b905a974a67217d37b2ee261d1e94c57edcfa8cd78e332e1f348ae15ff39de637a0de05a4df5bf SHA512 a614dad534582560dc6b44f370e63d6a439e0ee863d88edbcd925c5d0e815ea5db4b3de66ee744e9750857752f3d09de9d2c29e9cd20f6c3a7a8bc12c2fb5edc
MISC metadata.xml 640 BLAKE2B 490290dba5378d6599afa55e56780f99333b32ce71d0ca17f241c9e87c9d7ae19f3e0656c059bb841dd707df66b330da7ff860f3c0b1eb221de552227ba4ca06 SHA512 6fd5af9a57c21a72a37740f458947dce9a54e378ce5b602c9443d954ed536792cfa74299a69d02a2b0d81905a892d5b2d43f93678367ce7e039aa350c882cbb8
diff --git a/app-accessibility/orca/orca-3.36.6.ebuild b/app-accessibility/orca/orca-3.36.6.ebuild
new file mode 100644
index 000000000000..7e5ba2f05844
--- /dev/null
+++ b/app-accessibility/orca/orca-3.36.6.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_MULTI_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_MULTI_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_MULTI_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_MULTI_USEDEP}]
+ dev-python/setproctitle[${PYTHON_MULTI_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}
diff --git a/app-accessibility/speechd-el/Manifest b/app-accessibility/speechd-el/Manifest
index 4ae042ce3f75..363edd928ba5 100644
--- a/app-accessibility/speechd-el/Manifest
+++ b/app-accessibility/speechd-el/Manifest
@@ -1,3 +1,3 @@
DIST speechd-el-2.8.tar.gz 474614 BLAKE2B 36ac862c2f14b3f9b5be25bf666c466093f8e5bf3d456058d73a4eef0cc766d9b36ce990d8a3ee8161edb4190637a199853ac77eaedc28afd101ebd95842c47f SHA512 1a34e433d5ae61c83dfb7d3a9f26e25210613355f3a71e7601f15865cd9693db81dd9f559aef41bd3142d25702db88006bb9fd2053b597799f1b68c48911a3d2
-EBUILD speechd-el-2.8.ebuild 997 BLAKE2B 9b71cd85168ca1cea2b5fb1aff7348e5a72114c21c056ff3a9e290f950b7dc4158906d6a51112b2d70cafa0e94a9a5a20e2510fc25afb697eda1de9a14deba75 SHA512 8afe0e3582dce9bbbcd3506cc89eb95e664da1f0b939762d6b1f9008989cca6eadda5a8d33f1ce2e5904e3d7f1c13c22a8ff4d222dbc628b467dd7cb493fa86d
+EBUILD speechd-el-2.8.ebuild 994 BLAKE2B e912bf5b2d44d7f9db9de06607627c0a8f3a404923de6eccc58807d23c20b0ea0950684a8a09c8bd951b0e02719d1b3fb68c40f4618fb3b6adc5fd055430e061 SHA512 94d620eeb4ccfa108ef31a36480a360f84e0fff64e37bc1fb8290ce2d46a769b795a1b9f3b9417fcb5875186e3fc93768d45ef7dce92ceb78ac3f30d3d01f27a
MISC metadata.xml 463 BLAKE2B a97c4ff69a8a6db27cee2d6f5af14521e021dadb47c3eee89a71781c8c241698cfbb5c524375a6c86444c345b6ec4c65103e0e47afab6d57f157b75722aa931f SHA512 7d5ad40f8bda917fac4f3b178621e9403c7c5bc1814224cfc98ba17cf827da349cfed0c2accb80724c316363e2dce925c5f8385507a924a9a1963344592a0726
diff --git a/app-accessibility/speechd-el/speechd-el-2.8.ebuild b/app-accessibility/speechd-el/speechd-el-2.8.ebuild
index 2193ed224eda..827b384d6a98 100644
--- a/app-accessibility/speechd-el/speechd-el-2.8.ebuild
+++ b/app-accessibility/speechd-el/speechd-el-2.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7