summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /app-accessibility/orca
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-43.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index a12ee451fac7..f8688f55c08a 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-43.0.tar.xz 3758480 BLAKE2B 05c31777c1c88452e165bd7fb6fe75fe727149f5337828b5f4e7679430ed5065a03de7074536c4433bedd81c3090c72e02a775db46f4673d6e3264a57732ad7a SHA512 20248e6065c1daa9c3d6ba37515bab60a3ceb14065b862d6d0610a7659bddc04f49a1cda7850646b45bb0afb5c2a89f1894de96f505831b11b77d332adb747d3
+DIST orca-43.1.tar.xz 3761604 BLAKE2B 924fce7c03abe51b46c406f9627f78a18700ad980adc52d9b522cecf73d07a978f4546fd3aec77ab92217627642928ba2ffb2ee73bb7a25163fb3610fa57cb9b SHA512 5d3ade5ae3c4f9b7ed8dfcabddbf7bcf5e2e15e731e0d9c1c69da692e9ce70d270aedcbfc8557a56ca0f2935b2c0c84e21fa4c6db64ec1c01c78dda7a429623f
EBUILD orca-43.0.ebuild 1541 BLAKE2B 1b03704f5c12bac9ab5e00aa5b87bccef11f6276ddc8f57a3bab0729a1d671ea3bea65bc420758b79fba4321e675a098c719eb249675a61a67aa6a1dc8d6a031 SHA512 f0efb369bf19c8b12b7b663f6d4959e1b8213d64bd4bc1a3d5757f25e7119566bbd0a0e16eee558b55b8681483995a35a2e5e86624e64641b90b22ef7cdf888e
+EBUILD orca-43.1.ebuild 1454 BLAKE2B af065ee3cd13e617c6849af0984a632799ee1c31c72fcbfc0c0c50ec6fb1bab717f9a1de80f555c7ba4bbecc39a54ff37ce169b6c674640bc3565bed3ce42eaf SHA512 c6d43d374354c7ebb04e41884d9ce8300c2df97a04606405b15b4f26e81e102bac93adbf63261a54e89004add1a7578b1db1d135809bf8e4d0d53a4fe1311f12
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-43.1.ebuild b/app-accessibility/orca/orca-43.1.ebuild
new file mode 100644
index 000000000000..cde3d66e714d
--- /dev/null
+++ b/app-accessibility/orca/orca-43.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.46:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}