summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /app-accessibility/orca
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-42.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index e8764673fc71..262cb7b3e932 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-41.2.tar.xz 3637836 BLAKE2B bebe1d6e37b88f8e1c97c2ee2a599185c2c14d88fc7d12805bb5a7623b1323ad8688cb846b6e733ef02d58390eb390d1dcd2150a0ed50c8109a7468d62f525c2 SHA512 a2d208193aaac48bf12ca22732b338cdcb5299edc7e7b5c75c88f8dee6ad69762287dbb36c25661c08f904b3848a2ca0e60f2d7153e41594944fab509ff3ef07
+DIST orca-42.0.tar.xz 3658384 BLAKE2B 7b8b83205e9b8c16021cb3582ca8ada195384b5dee4c93ea9707e5f6133f006d21e2b94c6c65131b73ac5d1072eea423d66d5c4b4e5cd6d2be7cc4fdf3c9ad0f SHA512 dee0f65cd1055293d65eabb360b515763501812264440410332d7c0bf58eff63035f8fee07d61e5caed7c860cdce44ca30b187c6fc1c0417102fb577ff02e340
EBUILD orca-41.2.ebuild 1562 BLAKE2B 23c0907b11da9aca993aed45ea94f9bed04553d421fcf76bd241d582f3189943edb8d7e9dd7d09ce158573b06bd71a231126e854cab047a31a2323a52da7d484 SHA512 9ce417d9e0175bf2dd5790a85bfdc6feec6a00b919b18c6dc9ea28d4b899860cc41e8e949f1a2d441dd3d9cf0ff79442bf62b8afc6b12dbe933ff5b6ead149ce
+EBUILD orca-42.0.ebuild 1565 BLAKE2B 63b5a2cb9baeae99b1aaba4157e7d1f8413252f645792884803a1cea218d9c383b3c2f3e07374be94bee34853591ef308b0f6daa6deebfec6f320bcd273e6fe4 SHA512 2e6213329641e0529f81008bf151b662708f186b00f813d009ca99344cbcee35876dcfd827d3390d1d8e57561ab59c4705384e4560bff3e2cea1d6e5025ec666
MISC metadata.xml 641 BLAKE2B 2a9a0582cf597e46cf71f11034a17ed3146f5d2709855be3f64530c94be53bdbb7ac8e8be859969706c67e6b32e1f8a33fe97b3e54d41b27a4f6ee3807f19fd6 SHA512 4119f9cc00c1978ada19d63f559ba35bec6299732bf50e3fb724c531dae3c3052e26fb1e7ec7830c55c98ef800ff0a6ecbb01df98e3b64781ff42eb7ef9ce7fb
diff --git a/app-accessibility/orca/orca-42.0.ebuild b/app-accessibility/orca/orca-42.0.ebuild
new file mode 100644
index 000000000000..b5714207dce1
--- /dev/null
+++ b/app-accessibility/orca/orca-42.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}