summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-accessibility/orca
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest4
-rw-r--r--app-accessibility/orca/orca-42.2.ebuild63
-rw-r--r--app-accessibility/orca/orca-42.3.ebuild63
3 files changed, 130 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index 0b89ef5e0999..c4f53df3cf99 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,7 @@
DIST orca-42.1.tar.xz 3700132 BLAKE2B 1310a1b43da709e9b273ce21374fff9fa30fbf08d1d0e171eb7eff4511ad5e2bcee12a2d6549a4c0c8e21526fb6f4b3b311d0e09fd6bfa863e29168809df9c10 SHA512 98f016087317666c4dcc7543d16ffb93214075d49d3708a1aa3dc8b6dd5d9d85c52dd31e650f4511371061c58d53e73455a09d6d7b4405b8a972b58ff1d7db91
+DIST orca-42.2.tar.xz 3707612 BLAKE2B a181c994ee8c35561d493dd00949807c09ccb3dd406ed0c61083c746c29fe7ef9db010484c34ca4416170cf51555b1f595f78816ca5f66ccf29970a0ff447088 SHA512 78c4e6d588d4929869100b761c85aa1d37a503e0960953c6ef7488ac7ed3c6d4ec400b9fd034b5178d64a69aca7daeaac2f25e292c32dfa814f7428b1c159fd5
+DIST orca-42.3.tar.xz 3707048 BLAKE2B b1a03cee97ba2ad17e32b863effba46974f86e5cbdcea72235085e369189e8e92cba8b83931fd83a7b859edfc8da9236f462e250c468ad1533768479eb25aad0 SHA512 59d9d61af2e385d8e356f825fc1733d73d136f89a3a06c352eaf1e7b05cd6ebf5bd13282afb478adb4ea7981398db0138324c3e275eb372b99ba648d9fafeab6
EBUILD orca-42.1.ebuild 1562 BLAKE2B 23c0907b11da9aca993aed45ea94f9bed04553d421fcf76bd241d582f3189943edb8d7e9dd7d09ce158573b06bd71a231126e854cab047a31a2323a52da7d484 SHA512 9ce417d9e0175bf2dd5790a85bfdc6feec6a00b919b18c6dc9ea28d4b899860cc41e8e949f1a2d441dd3d9cf0ff79442bf62b8afc6b12dbe933ff5b6ead149ce
+EBUILD orca-42.2.ebuild 1565 BLAKE2B 63b5a2cb9baeae99b1aaba4157e7d1f8413252f645792884803a1cea218d9c383b3c2f3e07374be94bee34853591ef308b0f6daa6deebfec6f320bcd273e6fe4 SHA512 2e6213329641e0529f81008bf151b662708f186b00f813d009ca99344cbcee35876dcfd827d3390d1d8e57561ab59c4705384e4560bff3e2cea1d6e5025ec666
+EBUILD orca-42.3.ebuild 1565 BLAKE2B 63b5a2cb9baeae99b1aaba4157e7d1f8413252f645792884803a1cea218d9c383b3c2f3e07374be94bee34853591ef308b0f6daa6deebfec6f320bcd273e6fe4 SHA512 2e6213329641e0529f81008bf151b662708f186b00f813d009ca99344cbcee35876dcfd827d3390d1d8e57561ab59c4705384e4560bff3e2cea1d6e5025ec666
MISC metadata.xml 641 BLAKE2B 2a9a0582cf597e46cf71f11034a17ed3146f5d2709855be3f64530c94be53bdbb7ac8e8be859969706c67e6b32e1f8a33fe97b3e54d41b27a4f6ee3807f19fd6 SHA512 4119f9cc00c1978ada19d63f559ba35bec6299732bf50e3fb724c531dae3c3052e26fb1e7ec7830c55c98ef800ff0a6ecbb01df98e3b64781ff42eb7ef9ce7fb
diff --git a/app-accessibility/orca/orca-42.2.ebuild b/app-accessibility/orca/orca-42.2.ebuild
new file mode 100644
index 000000000000..b5714207dce1
--- /dev/null
+++ b/app-accessibility/orca/orca-42.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}
diff --git a/app-accessibility/orca/orca-42.3.ebuild b/app-accessibility/orca/orca-42.3.ebuild
new file mode 100644
index 000000000000..b5714207dce1
--- /dev/null
+++ b/app-accessibility/orca/orca-42.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-atk-2.34:2
+ >=app-accessibility/at-spi2-core-2.36:2[introspection]
+ >=dev-libs/atk-2.36
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ dev-libs/atk[introspection]
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}