summaryrefslogtreecommitdiff
path: root/app-accessibility/orca
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-25 06:49:35 +0000
commit0b82ae29b3034efe3e7b7f533dbcb76168544c5e (patch)
treeea954d341afdcf53b3b79c78c9a54ff2c9693096 /app-accessibility/orca
parentb0b85e141f6a9a74d9d6bdce989a626ff5e92523 (diff)
gentoo auto-resync : 25:03:2023 - 06:49:35
Diffstat (limited to 'app-accessibility/orca')
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-44.0.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index de4db29110b1..25541ade4c0b 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-43.1.tar.xz 3761604 BLAKE2B 924fce7c03abe51b46c406f9627f78a18700ad980adc52d9b522cecf73d07a978f4546fd3aec77ab92217627642928ba2ffb2ee73bb7a25163fb3610fa57cb9b SHA512 5d3ade5ae3c4f9b7ed8dfcabddbf7bcf5e2e15e731e0d9c1c69da692e9ce70d270aedcbfc8557a56ca0f2935b2c0c84e21fa4c6db64ec1c01c78dda7a429623f
+DIST orca-44.0.tar.xz 3764020 BLAKE2B 0ac7f837cf38cf15b63400d7ca7d631b4e3710680ea50c311ea60b81e57797e81411f6d2f82cde8434fab065e07a14a7e5d9192e73bf29bb79ac6fa9644d985f SHA512 7b1d4a8417283fc7586bd1a308529d8cc3bdc53f080b5bcd6f9dffc686b9eeeb6992df9d970996b44a3339492fb31bdc26c107cc5233521c655e46d4bea7efb2
EBUILD orca-43.1.ebuild 1451 BLAKE2B 6acffef03ade31e8ad05ec8e64e20854f2691ad658711bb9e1f92ceef4689a1a320b808abc803399b9a98ec0990acdda5bcc2fb77233c15767a2fcc0162d990e SHA512 d4fa4b79fe791ef525c2b49db758370f991456df760f790ebc977db8caffb61ae277302f587a4e66c14552ab4e13d98cefe69a9ff8d314b9d9e0ca32d4d170e0
+EBUILD orca-44.0.ebuild 1454 BLAKE2B 7b803b9033ed7829b154ed39fd9f9e30db703bfe36800ca73e892e30e3507fd289657ee8d4b27d25bab7d51e5f14436da7e929f93c647fecca31ab816defd130 SHA512 f3fe7c0e022533d15e0bb94a4c9455981bf2c0f1a78878951a951ca77178567b09e127c8e15073b06833fce4bf75c5f67fcd49198cd776393a79d0264233b02f
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-44.0.ebuild b/app-accessibility/orca/orca-44.0.ebuild
new file mode 100644
index 000000000000..6b60291784d7
--- /dev/null
+++ b/app-accessibility/orca/orca-44.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.47:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}