summaryrefslogtreecommitdiff
path: root/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild')
-rw-r--r--app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
index c458fcee9dcd..8509d2d383e6 100644
--- a/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
+++ b/app-accessibility/nfbtrans/nfbtrans-7.74-r2.ebuild
@@ -1,41 +1,43 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
-DESCRIPTION="braille translator from the National Federation of the Blind"
+DESCRIPTION="Braille translator from the National Federation of the Blind"
HOMEPAGE="http://www.nfb.org/nfbtrans"
SRC_URI="http://www.nfb.org/Images/nfb/Products_Technology/nfbtr774.zip"
+S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
-DEPEND=" >=app-arch/unzip-5.50-r2"
-RDEPEND=""
-
-S=${WORKDIR}
+BDEPEND=" >=app-arch/unzip-5.50-r2"
PATCHES=(
-"${FILESDIR}"/${P}-gentoo-fix.patch
-"${FILESDIR}"/${P}-getline-fix.patch
-"${FILESDIR}"/${P}-respect-ldflags.patch
+ "${FILESDIR}"/${P}-gentoo-fix.patch
+ "${FILESDIR}"/${P}-getline-fix.patch
+ "${FILESDIR}"/${P}-respect-ldflags.patch
)
src_prepare() {
mv MAKEFILE Makefile || die
mv SPANISH.ZIP spanish.zip || die
- emake lowercase
+
default
+
+ emake lowercase
}
src_compile() {
- emake CC=$(tc-getCC) \
+ emake \
+ CC="$(tc-getCC)" \
LIBS= \
- CFLAGS="${CFLAGS} -DLINUX" LDFLAGS="${LDFLAGS}" all
+ CFLAGS="${CFLAGS} -DLINUX" \
+ LDFLAGS="${LDFLAGS}" \
+ all
}
src_install() {