summaryrefslogtreecommitdiff
path: root/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/eflite/files/eflite-0.4.1-flite14.patch')
-rw-r--r--app-accessibility/eflite/files/eflite-0.4.1-flite14.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
new file mode 100644
index 000000000000..cb3096d88a43
--- /dev/null
+++ b/app-accessibility/eflite/files/eflite-0.4.1-flite14.patch
@@ -0,0 +1,24 @@
+diff -Naur eflite-0.4.1/Makefile.in eflite-0.4.1-new/Makefile.in
+--- eflite-0.4.1/Makefile.in 2007-01-18 18:01:09.000000000 -0600
++++ eflite-0.4.1-new/Makefile.in 2010-07-23 20:06:45.000000000 -0500
+@@ -34,7 +34,7 @@
+ $(CC) $(LDFLAGS) -o $@ $^ -lm $(LIBS) $(FLITE_LIBS) $(AUDIOLIBS)
+
+ fs.o: fs.c
+- $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(subst cmu_us_kal16,cmu_us_kal,$(FL_VOX)) -DSTANDALONE -DEFLITE -c -o $@ $<
++ $(CC) $(CFLAGS) @AUDIODEFS@ -I. -I$(flite_include_dir) -DREGISTER_VOX=register_$(FL_VOX) -DSTANDALONE -DEFLITE -c -o $@ $<
+
+ tone.o: tone.c
+ $(CC) $(CFLAGS) -I$(flite_include_dir) -DEFLITE -c -o $@ $<
+diff -Naur eflite-0.4.1/fs.c eflite-0.4.1.new/fs.c
+--- eflite-0.4.1/fs.c 2007-01-18 16:01:09.000000000 -0800
++++ eflite-0.4.1.new/fs.c 2013-09-08 09:31:57.417262688 -0700
+@@ -523,7 +523,7 @@
+ int playlen, skip;
+ if (type == SPEECH)
+ {
+- skip = (187 * wptr->sample_rate) / speed;
++ skip = 0;
+ playlen = wptr->num_samples - (skip * 2);
+ if (playlen > 0 && playlen < 500) playlen += (skip * 2) / 3;
+ }