summaryrefslogtreecommitdiff
path: root/app-accessibility/caribou
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-03 11:25:07 +0100
commitf6a034d922bf54efeaa781fcb5388b325b90d945 (patch)
treeb9fafda6cf44bf7b09de2c3d74090de10f9cde04 /app-accessibility/caribou
parent007b0aae027279095b8605c214b535e59df8f6eb (diff)
gentoo auto-resync : 03:05:2023 - 11:25:06
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest1
-rw-r--r--app-accessibility/caribou/caribou-0.4.21-r6.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
index 156259a3cea5..c100bfb42530 100644
--- a/app-accessibility/caribou/Manifest
+++ b/app-accessibility/caribou/Manifest
@@ -7,4 +7,5 @@ AUX caribou-fix-subkey-popmenu.patch 916 BLAKE2B 5f833fded2a5d1dedf613aecd1e473f
AUX caribou-fix-xadapter-xkb-calls.patch 1840 BLAKE2B c752a1e7f9cee33ed8ecdb5c9d72267e11b3881c6c1e4e7576b070088ecbe7893c9d5ef1dce8483b062ef31083441072a3b88309db523832a8b06e2254e65a82 SHA512 122b1004e601f3c669d8f8d33d4fd167d662086f54e0376f4cc6147e470b07a1345af99581313facb286c4392a2ae17b39565d36cca32fd5eeb7a44a49807999
DIST caribou-0.4.21.tar.xz 426516 BLAKE2B bd5e27bbbdb08fc31edce3b65124177e30b6d51e0071601bcd84c325b5794ce936b3f782ac8639dca332c246e329773f462dcecc0f236f52aeb0dcc7c5607a24 SHA512 5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da
EBUILD caribou-0.4.21-r5.ebuild 2251 BLAKE2B 34b7348ff42ef8d26be697d98753d560c702c757f8202e75e2a10a5dd6290f7d6009e844ff8592f96303674d1c350a7771792df40f0ea4a915d4f4f892577b1d SHA512 b9b70e296827197e44b634c79106f4303e94e8927b5840167a1c8613dc9548bb1adc22347a1a8e4a90601799f98b61dc8d67c73187d1c702556fee6c19e05aa1
+EBUILD caribou-0.4.21-r6.ebuild 2253 BLAKE2B ff92cb80da2724f395d5f12d5c5791c9870e2d0835eea9738e8884af10cc575205ffde6475c700cb4a69dbfd168ca5ebd88ba99ea79063291ad83f632ac6648c SHA512 353cac2eecc67c23b578ee15b6de34f94cde9dd9ac2ec19d07ee8ff87ee7f31c01be6663bbb4e928c02de1604864de14652151649454298f948a20c90c7d8fd4
MISC metadata.xml 840 BLAKE2B 671f825fbc4ae6d54e4f954841e64ac34affbec420b2bf7bf07ec8dcf9f94bf68bd614566c06018476bd5a6f6c29ed86072d1f3b6b2e84281744052c9ddc1b3b SHA512 1db29ec2266887839c007307a66e10fae1bd119e3a2eef9b3223382e2dbd0413defb864c2b4917ddf24eeaa36929100cb092e0d065dff26853e54532d88bfd30
diff --git a/app-accessibility/caribou/caribou-0.4.21-r6.ebuild b/app-accessibility/caribou/caribou-0.4.21-r6.ebuild
new file mode 100644
index 000000000000..e09fa2392501
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.21-r6.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit autotools gnome.org gnome2-utils python-single-r1 vala
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ app-accessibility/at-spi2-core
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ ')
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ $(python_gen_cond_dep '
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+ !<x11-base/xorg-server-1.20.10
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/libxslt
+"
+BDEPEND="
+ $(vala_depend)
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-compilation-error.patch"
+ "${FILESDIR}/${PN}-fix-subkey-popmenu.patch"
+ "${FILESDIR}/${PN}-fix-xadapter-xkb-calls.patch"
+ "${FILESDIR}/${PN}-fix-antler-style-css.patch"
+ "${FILESDIR}/${PN}-fix-python-env.patch"
+ "${FILESDIR}/${PN}-change_autostart_cinnamon.patch"
+ "${FILESDIR}/${PN}-drop_gir_patch.patch"
+)
+
+src_prepare() {
+ default
+ vala_src_prepare
+ gnome2_disable_deprecation_warning
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-docs \
+ --disable-static \
+ --disable-gtk2-module \
+ --enable-gtk3-module
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS README"
+ default
+ find "${D}" -name '*.la' -delete || die
+ python_optimize
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}