summaryrefslogtreecommitdiff
path: root/app-accessibility/caribou
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /app-accessibility/caribou
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest1
-rw-r--r--app-accessibility/caribou/caribou-0.4.21-r1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
index 21349b650891..6c8cfb33f740 100644
--- a/app-accessibility/caribou/Manifest
+++ b/app-accessibility/caribou/Manifest
@@ -1,3 +1,4 @@
DIST caribou-0.4.21.tar.xz 426516 BLAKE2B bd5e27bbbdb08fc31edce3b65124177e30b6d51e0071601bcd84c325b5794ce936b3f782ac8639dca332c246e329773f462dcecc0f236f52aeb0dcc7c5607a24 SHA512 5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da
+EBUILD caribou-0.4.21-r1.ebuild 2396 BLAKE2B d791626e6b290c47acacdc3538107e081359eb02767b52d0a669742874802412cd241bfaf9ee8a75a6c47c9265c41077bfcf0b01e1b355125f14a0b92a4f71fb SHA512 3ab2ba6f2ffa90153b6bce388f6761e05746d6bb4284bf7c249d3a5322bb54d2cba02463f736da3580a80a3dd5a17207366b3bb8ae713d8dfa05b4bf9d46acca
EBUILD caribou-0.4.21.ebuild 2390 BLAKE2B 8c45fca89ee00bd730bf14d06d3360e3cfeef63ba639ef559f741e7b0c981b16348e1c44832f83a525ddbbc5c00bb849a8828015a96f84e9ec6b749a950d9b50 SHA512 5a3a0d68a3323b2e96395f5a20b697e52eaf312469a30d66ff7e06e8226a314a68db344b387782e17d0dc2790d12ec3d889290620937996e3a5dd1103e9fa3ac
MISC metadata.xml 682 BLAKE2B 4ff796697db62d8c6a21ff62794c5fef391691685cece76ee7b8c38178f775a145b9a457df9bf959ab6af03559ceb4d9ad97a2ab835d63b70e58b4894f71fa5d SHA512 bec00e1cbb64bfec610e3f4e724e8afb8539a4b676b1e443a17b7eaf2263bef1fbf5787d77de253d84ebb0a54b3ca4bd386ba421826c0bb903164bb7ecf5223d
diff --git a/app-accessibility/caribou/caribou-0.4.21-r1.ebuild b/app-accessibility/caribou/caribou-0.4.21-r1.ebuild
new file mode 100644
index 000000000000..a6ab60c8d630
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.21-r1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+ ${PYTHON_DEPS}
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # FIXME: Now this supports python3 too...
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+# sed -e '/export PYTHONPATH=.*python/ d' \
+# -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+# -i bin/{antler-keyboard,caribou-preferences}.in ||
+# die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=769323
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}