summaryrefslogtreecommitdiff
path: root/app-accessibility/caribou
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/caribou
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest3
-rw-r--r--app-accessibility/caribou/caribou-0.4.21.ebuild92
-rw-r--r--app-accessibility/caribou/metadata.xml15
3 files changed, 110 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
new file mode 100644
index 000000000000..272fa00c39b2
--- /dev/null
+++ b/app-accessibility/caribou/Manifest
@@ -0,0 +1,3 @@
+DIST caribou-0.4.21.tar.xz 426516 BLAKE2B bd5e27bbbdb08fc31edce3b65124177e30b6d51e0071601bcd84c325b5794ce936b3f782ac8639dca332c246e329773f462dcecc0f236f52aeb0dcc7c5607a24 SHA512 5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da
+EBUILD caribou-0.4.21.ebuild 2407 BLAKE2B 1e311e8f3e5e3204f05eb67f73081a97dc1b26a6caeede59b964b312b58d6be27a85ea15d94c1e167393f226d488a357fe13e61b2f5cde91ebb5afc5f83da0c1 SHA512 45416b8cf24b6060227f2d9861e22b9f934e5d1baabf82a22c5223be6a6363fe267f7e8afc462d1da607ee1acbba1b855c91a6ca78d77644139972cee100869c
+MISC metadata.xml 682 BLAKE2B 4ff796697db62d8c6a21ff62794c5fef391691685cece76ee7b8c38178f775a145b9a457df9bf959ab6af03559ceb4d9ad97a2ab835d63b70e58b4894f71fa5d SHA512 bec00e1cbb64bfec610e3f4e724e8afb8539a4b676b1e443a17b7eaf2263bef1fbf5787d77de253d84ebb0a54b3ca4bd386ba421826c0bb903164bb7ecf5223d
diff --git a/app-accessibility/caribou/caribou-0.4.21.ebuild b/app-accessibility/caribou/caribou-0.4.21.ebuild
new file mode 100644
index 000000000000..e97c8589f1e6
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.21.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+ ${PYTHON_DEPS}
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # FIXME: Now this supports python3 too...
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+# sed -e '/export PYTHONPATH=.*python/ d' \
+# -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+# -i bin/{antler-keyboard,caribou-preferences}.in ||
+# die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=769323
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}
diff --git a/app-accessibility/caribou/metadata.xml b/app-accessibility/caribou/metadata.xml
new file mode 100644
index 000000000000..3a82b0ba211a
--- /dev/null
+++ b/app-accessibility/caribou/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<longdescription lang="en">
+Caribou is a text entry and UI navigation application being developed as an
+alternative to the Gnome On-screen Keyboard. The overarching goal for Caribou
+is to create a usable solution for people whose primary way of accessing a
+computer is a switch device. The initial goal is to make an in-place on-screen
+keyboard suitable for people who can use a mouse but not a hardware keyboard.
+</longdescription>
+</pkgmetadata>