summaryrefslogtreecommitdiff
path: root/app-accessibility/caribou
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-accessibility/caribou
reinit the tree, so we can have metadata
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest5
-rw-r--r--app-accessibility/caribou/caribou-0.4.21.ebuild92
-rw-r--r--app-accessibility/caribou/metadata.xml15
3 files changed, 112 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
new file mode 100644
index 000000000000..80b61ea613e3
--- /dev/null
+++ b/app-accessibility/caribou/Manifest
@@ -0,0 +1,5 @@
+DIST caribou-0.4.21.tar.xz 426516 SHA256 9c43d9f4bd30f4fea7f780d4e8b14f7589107c52e9cb6bd202bd0d1c2064de55 SHA512 5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da WHIRLPOOL 530a1b061cdadb12c31ad2e7b5686ca21db3da8066579fc6ba25a2b26418febeb58224eda61f27977507ed46db1cdbfd6afe4b555a970acdf9a580b30ac2174e
+EBUILD caribou-0.4.21.ebuild 2407 SHA256 d333dde7093b7a1937bfc8a629e2202a6541b1077b8dc393014c86c890ac68c1 SHA512 45416b8cf24b6060227f2d9861e22b9f934e5d1baabf82a22c5223be6a6363fe267f7e8afc462d1da607ee1acbba1b855c91a6ca78d77644139972cee100869c WHIRLPOOL d8dabd201fb44929f2b213dd2aeea67a220db12b7562a08ac77748922346afea0b5acc0d8cb154f5ee9bdc1a077af2a8c7a5be5ae7a678affbea48992f3b32d2
+MISC ChangeLog 4496 SHA256 8f9a45b47b2a2dd149d856f93851ac73b15c20f09f1941c62eb5e84460fee7f0 SHA512 c312229a74d615905e3992f18ccfeacc16e159aba7d07610f0039c5dd73dab7b03aabbd1c74839ac16bf9aca69ffff0cccc353872987abf66967f4e66e8b6909 WHIRLPOOL 694cc5ce31a1abfda5c485ab5d5060b25628d78200bfb2ec04a850f98b4b630db3f158030f278b2974b56f43dbb6a93ac26130b2f11fb0b30d64fabdb4197eb9
+MISC ChangeLog-2015 6305 SHA256 25259c1811656815efdb79a34551898ab8b2b34f57b63150690eb67424ddf355 SHA512 11c562ad09ff85fcf2d1a4745fdeebbb3e7a5a829cfd2e7e16df800fa94cadb9ab3eaec8320bbf0ab2bb10d0971a994d1fb1145b79b78a55c8f76a81eca7cccc WHIRLPOOL 9c5dd38ca001e8de51d951ce8bd09971c30c8c60640d67d7db5a9348209e28487b86409a513719db46bf5cc12aa691422226112547d9579d8090a162b6dd256e
+MISC metadata.xml 682 SHA256 9e0f2e7b7909762b582a65b8b05841c29fbcb0fa6981eba9b1c5f129269e38ec SHA512 bec00e1cbb64bfec610e3f4e724e8afb8539a4b676b1e443a17b7eaf2263bef1fbf5787d77de253d84ebb0a54b3ca4bd386ba421826c0bb903164bb7ecf5223d WHIRLPOOL 5e392728f301f38beacb0d3edf5513649419986a36430ead3eeac4d351c04889c1ca5b698f5aa9e60f6c8ca5ddb2f9698ae1107bfb684b0c4e3f0ef2b4aae096
diff --git a/app-accessibility/caribou/caribou-0.4.21.ebuild b/app-accessibility/caribou/caribou-0.4.21.ebuild
new file mode 100644
index 000000000000..e97c8589f1e6
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.21.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86"
+
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="
+ app-accessibility/at-spi2-core
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/gtk+:2
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+ ${PYTHON_DEPS}
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+"
+DEPEND="${COMMON_DEPEND}
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # FIXME: Now this supports python3 too...
+ # delete custom PYTHONPATH, useless on Gentoo and potential bug source
+ # + caribou is python2 only so fix the shell scripts
+# sed -e '/export PYTHONPATH=.*python/ d' \
+# -e "s:@PYTHON@:${EPREFIX}/usr/bin/python2:" \
+# -i bin/{antler-keyboard,caribou-preferences}.in ||
+# die "sed failed"
+
+ gnome2_src_prepare
+
+ prepare_caribou() {
+ mkdir -p "${BUILD_DIR}" || die
+ }
+ python_foreach_impl prepare_caribou
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" python_foreach_impl run_in_build_dir \
+ gnome2_src_configure \
+ --disable-docs \
+ --disable-static \
+ --enable-gtk3-module \
+ --enable-gtk2-module \
+ VALAC=$(type -P true)
+ # vala is not needed for tarball builds, but configure checks for it...
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ python_foreach_impl run_in_build_dir gnome2_src_install
+
+ # https://bugzilla.gnome.org/show_bug.cgi?id=769323
+ dodoc AUTHORS NEWS README # ChangeLog simply points to git log
+}
diff --git a/app-accessibility/caribou/metadata.xml b/app-accessibility/caribou/metadata.xml
new file mode 100644
index 000000000000..3a82b0ba211a
--- /dev/null
+++ b/app-accessibility/caribou/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+</maintainer>
+<longdescription lang="en">
+Caribou is a text entry and UI navigation application being developed as an
+alternative to the Gnome On-screen Keyboard. The overarching goal for Caribou
+is to create a usable solution for people whose primary way of accessing a
+computer is a switch device. The initial goal is to make an in-place on-screen
+keyboard suitable for people who can use a mouse but not a hardware keyboard.
+</longdescription>
+</pkgmetadata>