summaryrefslogtreecommitdiff
path: root/app-accessibility/caribou
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-accessibility/caribou
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-accessibility/caribou')
-rw-r--r--app-accessibility/caribou/Manifest1
-rw-r--r--app-accessibility/caribou/caribou-0.4.21-r5.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/app-accessibility/caribou/Manifest b/app-accessibility/caribou/Manifest
index 5b8c4dfccbd6..3f584d9f4b6f 100644
--- a/app-accessibility/caribou/Manifest
+++ b/app-accessibility/caribou/Manifest
@@ -7,4 +7,5 @@ AUX caribou-fix-subkey-popmenu.patch 916 BLAKE2B 5f833fded2a5d1dedf613aecd1e473f
AUX caribou-fix-xadapter-xkb-calls.patch 1840 BLAKE2B c752a1e7f9cee33ed8ecdb5c9d72267e11b3881c6c1e4e7576b070088ecbe7893c9d5ef1dce8483b062ef31083441072a3b88309db523832a8b06e2254e65a82 SHA512 122b1004e601f3c669d8f8d33d4fd167d662086f54e0376f4cc6147e470b07a1345af99581313facb286c4392a2ae17b39565d36cca32fd5eeb7a44a49807999
DIST caribou-0.4.21.tar.xz 426516 BLAKE2B bd5e27bbbdb08fc31edce3b65124177e30b6d51e0071601bcd84c325b5794ce936b3f782ac8639dca332c246e329773f462dcecc0f236f52aeb0dcc7c5607a24 SHA512 5fc0cf54a1cad50d41e659adbbb932b51d69d18951562f87497e99aaae17ac72b453b759dd7289ff8f68a79574dfce510b9de6bedc61408c14cb48b83eaf08da
EBUILD caribou-0.4.21-r4.ebuild 2247 BLAKE2B 04bdcc1d001a8f358b6a2c88a69052e8d0c647ace8926a3b774254f424a26f251e2b91baddb50ae621bdadc2182768e0beac82c65c4ff2f02147ea8e7a0acd42 SHA512 008c12ad32dc8f2783e0499f66c7ea0f9c6ada18c88361adb56c760da44cf95726a3fedc5726d62c37ace36ad27b7271366595f52656505dec172910236e1bbd
+EBUILD caribou-0.4.21-r5.ebuild 2250 BLAKE2B 677924d4281b2415b352d5c0e47853e4f2bbdf50354801d534b164b49ef8c5dc154114272cb7cfca501bacd7df44506e161ef5190d3ba9d38af2718c9d12a6f0 SHA512 c1fbc99ff00a00d9f00e8609bf9be37cb806dd180051a7e36662d4caf01932a5f74a9d63c118c3482acd33b63da8faaa678c882cd372e6613804ef91225fd998
MISC metadata.xml 840 BLAKE2B 671f825fbc4ae6d54e4f954841e64ac34affbec420b2bf7bf07ec8dcf9f94bf68bd614566c06018476bd5a6f6c29ed86072d1f3b6b2e84281744052c9ddc1b3b SHA512 1db29ec2266887839c007307a66e10fae1bd119e3a2eef9b3223382e2dbd0413defb864c2b4917ddf24eeaa36929100cb092e0d065dff26853e54532d88bfd30
diff --git a/app-accessibility/caribou/caribou-0.4.21-r5.ebuild b/app-accessibility/caribou/caribou-0.4.21-r5.ebuild
new file mode 100644
index 000000000000..8b7c2df3dd7e
--- /dev/null
+++ b/app-accessibility/caribou/caribou-0.4.21-r5.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="xml"
+
+inherit autotools gnome.org gnome2-utils python-single-r1 vala
+
+DESCRIPTION="Input assistive technology intended for switch and pointer users"
+HOMEPAGE="https://wiki.gnome.org/Projects/Caribou"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ app-accessibility/at-spi2-core
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ ')
+ >=dev-libs/gobject-introspection-0.10.7:=
+ dev-libs/libgee:0.8
+ dev-libs/libxml2
+ >=media-libs/clutter-1.5.11:1.0[introspection]
+ >=x11-libs/gtk+-3:3[introspection]
+ x11-libs/libX11
+ x11-libs/libxklavier
+ x11-libs/libXtst
+"
+# gsettings-desktop-schemas is needed for the 'toolkit-accessibility' key
+# pyatspi-2.1.90 needed to run caribou if pygobject:3 is installed
+# librsvg needed to load svg images in css styles
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/glib[dbus]
+ $(python_gen_cond_dep '
+ >=dev-python/pyatspi-2.1.90[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/gsettings-desktop-schemas-3
+ gnome-base/librsvg:2
+ sys-apps/dbus
+ !<x11-base/xorg-server-1.20.10
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ dev-libs/libxslt
+"
+BDEPEND="
+ $(vala_depend)
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-fix-compilation-error.patch"
+ "${FILESDIR}/${PN}-fix-subkey-popmenu.patch"
+ "${FILESDIR}/${PN}-fix-xadapter-xkb-calls.patch"
+ "${FILESDIR}/${PN}-fix-antler-style-css.patch"
+ "${FILESDIR}/${PN}-fix-python-env.patch"
+ "${FILESDIR}/${PN}-change_autostart_cinnamon.patch"
+ "${FILESDIR}/${PN}-drop_gir_patch.patch"
+)
+
+src_prepare() {
+ default
+ vala_src_prepare
+ gnome2_disable_deprecation_warning
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-maintainer-mode \
+ --disable-schemas-compile \
+ --disable-docs \
+ --disable-static \
+ --disable-gtk2-module \
+ --enable-gtk3-module
+}
+
+src_install() {
+ DOCS="AUTHORS NEWS README"
+ default
+ find "${D}" -name '*.la' -delete || die
+ python_optimize
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}