summaryrefslogtreecommitdiff
path: root/app-accessibility/brltty/brltty-6.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-accessibility/brltty/brltty-6.1.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-accessibility/brltty/brltty-6.1.ebuild')
-rw-r--r--app-accessibility/brltty/brltty-6.1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-accessibility/brltty/brltty-6.1.ebuild b/app-accessibility/brltty/brltty-6.1.ebuild
index 518a31f5e70f..cff7d7f3322c 100644
--- a/app-accessibility/brltty/brltty-6.1.ebuild
+++ b/app-accessibility/brltty/brltty-6.1.ebuild
@@ -3,12 +3,12 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
FINDLIB_USE="ocaml"
JAVA_PKG_WANT_SOURCE="1.8"
JAVA_PKG_WANT_TARGET="1.8"
-inherit findlib eutils multilib toolchain-funcs java-pkg-opt-2 flag-o-matic usr-ldscript \
+inherit findlib multilib toolchain-funcs java-pkg-opt-2 flag-o-matic usr-ldscript \
autotools udev systemd python-r1 tmpfiles
DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
@@ -110,7 +110,6 @@ src_configure() {
--includedir="${EPREFIX}"/usr/include
--localstatedir="${EPREFIX}"/var
--disable-stripping
- --with-install-root="${D}"
--with-writable-directory="${EPREFIX}"/run/brltty
$(use_enable api)
$(use_with beeper beep-package)
@@ -163,12 +162,12 @@ src_install() {
findlib_src_preinst
fi
- emake OCAML_LDCONF= install
+ emake INSTALL_ROOT="${D}" OCAML_LDCONF= install
if use python; then
python_install() {
cd "Bindings/Python" || die
- emake install
+ emake INSTALL_ROOT="${D}" install
}
python_foreach_impl run_in_build_dir python_install
fi