summaryrefslogtreecommitdiff
path: root/app-accessibility/accerciser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-accessibility/accerciser
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-accessibility/accerciser')
-rw-r--r--app-accessibility/accerciser/Manifest3
-rw-r--r--app-accessibility/accerciser/accerciser-3.22.0.ebuild65
-rw-r--r--app-accessibility/accerciser/metadata.xml13
3 files changed, 81 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
new file mode 100644
index 000000000000..46f8b4ae75a8
--- /dev/null
+++ b/app-accessibility/accerciser/Manifest
@@ -0,0 +1,3 @@
+DIST accerciser-3.22.0.tar.xz 3060756 BLAKE2B a648c764c5f101f323458c692cb4171704b7b710558f4103b57d87ca58c2d0d9c03cad72de1d3be9483d317ad94c95e43bb2437515093d6ffd93089a58e5fab1 SHA512 980db5dcd0bdc78314ab87cce95cfcfa018bf302acc66ea2dd1bddfb61de5bfe2e64344cff63740c38be33124ff49c75699aa6867d5e85b25d422b5af1b025c1
+EBUILD accerciser-3.22.0.ebuild 1444 BLAKE2B 45d8eaa83e454788c4381b3adefbe7ef993ba6fc060d8f7579b5b49b30689ef7a3827ff44de5afb56df3013bd4f87817070ce28b3442278a0fd08c4d053b4889 SHA512 573256cf8ca8e33c0b6f12d3e6693dab5a9ff32a6e0191172148a6d544db2a10c2e5e5f5af93ab61a1679bdb37638a35c5621b6bc5ea8c96551506a6b310bbcb
+MISC metadata.xml 738 BLAKE2B 916b10f5cb4aba612767ff5a617c091a36573681418c15973fbbff3328e00311306b162f504e9a12e17f04dc582f72bae21508847fec79a8d8cad4f3e18c9cb5 SHA512 78780d3254a608f95d3532de8a7438e891bd2e194ac8a255f2d224e8f4b41c2928b2efe04ae16050d0092f9e25f77800728f0be9b7cb3bcb955455532d4154e6
diff --git a/app-accessibility/accerciser/accerciser-3.22.0.ebuild b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
new file mode 100644
index 000000000000..a91ed1fc9645
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/metadata.xml b/app-accessibility/accerciser/metadata.xml
new file mode 100644
index 000000000000..b361a7a06606
--- /dev/null
+++ b/app-accessibility/accerciser/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.
+
+In essence, Accerciser is a next generation at-poke tool.
+</longdescription>
+</pkgmetadata>