summaryrefslogtreecommitdiff
path: root/app-accessibility/accerciser
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-accessibility/accerciser
reinit the tree, so we can have metadata
Diffstat (limited to 'app-accessibility/accerciser')
-rw-r--r--app-accessibility/accerciser/Manifest5
-rw-r--r--app-accessibility/accerciser/accerciser-3.22.0.ebuild65
-rw-r--r--app-accessibility/accerciser/metadata.xml13
3 files changed, 83 insertions, 0 deletions
diff --git a/app-accessibility/accerciser/Manifest b/app-accessibility/accerciser/Manifest
new file mode 100644
index 000000000000..89bb70220dbf
--- /dev/null
+++ b/app-accessibility/accerciser/Manifest
@@ -0,0 +1,5 @@
+DIST accerciser-3.22.0.tar.xz 3060756 SHA256 883306274442c7ecc076b24afca5190c835c40871ded1b9790da69347e9ca3c5 SHA512 980db5dcd0bdc78314ab87cce95cfcfa018bf302acc66ea2dd1bddfb61de5bfe2e64344cff63740c38be33124ff49c75699aa6867d5e85b25d422b5af1b025c1 WHIRLPOOL b30adca45e02d5fb684adbbbb4a3b608d8703fad0e5e5b9ed690f339419792e3bcd9ef486ca4508ceb7c870ae227243b383daf3cac0af1f6bc39323f0c28b1ef
+EBUILD accerciser-3.22.0.ebuild 1440 SHA256 79877d296ff3f6e7c8fa0326c2a3d50474ed6fbe9506f43584e7bfa1ccde1fe1 SHA512 a4b1c965682e3e152c1083edf149c0a8d772423d1ce9f4a18d0fa66d5cb489357b88cf65649f607564419a4d0bd3aa4010cbfbab3072ba58b6dce8f061aa2514 WHIRLPOOL ab118bc346681ef468cd84d7ee3512997d3094f5de62fd3b0a221c16e301c79ef9d1ec03e25bc3eb1a9afc4b1616bd9edc3aa58562e2673e1ba35cdf9dcd18f8
+MISC ChangeLog 3453 SHA256 e001b62c02cadc171bfb1ef94bd99d7cc0b1917217540e859d951e99a57e1f49 SHA512 5714cd6f2ac2b5680826a713cc7533c8d49fdc006edca87fcc47cd905749d31daf9fdc735d73e780f04742d3d7e8776da6595f276ee894dbc395d8fd8b4c015f WHIRLPOOL 95abf3c87e90194a506480be5f0f3432e04192d28edd1dd6b3900db902c704dffa3fdd5e0516a8397ac5110f2a0dad6956c7175a0cbdd80eb8f23d65450ccecf
+MISC ChangeLog-2015 6560 SHA256 7cf3f5070607b53f350494ff5921af7f999437949b02129b4cc40c8c6c21264a SHA512 26fbec15c82209c0d4fdc4ba0f295bf1db18ca3d805541e47c1a094a9e214072aefb6e120742901f5ea3bbbada9c8e53805833975dc7c4b3db72f18c963e6d2c WHIRLPOOL 2078b0b719c1c9e2ab0d411744637db8ef293b85352093866d2cb30242ed3bb292ed9f19051e174adaf835ab1f52ca946305d91358f173138e5388433befee98
+MISC metadata.xml 738 SHA256 efa00e13497196a77e7c5775b6ebdb465811f31a835280768725e953e98c583d SHA512 78780d3254a608f95d3532de8a7438e891bd2e194ac8a255f2d224e8f4b41c2928b2efe04ae16050d0092f9e25f77800728f0be9b7cb3bcb955455532d4154e6 WHIRLPOOL 2bb819201f2889353b460005c9effac56084fb499aa56f073c0319378d68c90614b976010051d79d71b059985d27ea78fc0081d7b7e79a00ed07737710b147ca
diff --git a/app-accessibility/accerciser/accerciser-3.22.0.ebuild b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
new file mode 100644
index 000000000000..202c73d492ab
--- /dev/null
+++ b/app-accessibility/accerciser/accerciser-3.22.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="xml"
+
+inherit gnome2 python-r1
+
+DESCRIPTION="Interactive Python accessibility explorer"
+HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"
+
+LICENSE="BSD CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.5.2:2
+ >=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
+ >=x11-libs/gtk+-3.1.13:3[introspection]
+
+ dev-libs/atk[introspection]
+ >=dev-libs/glib-2.28:2
+ dev-libs/gobject-introspection:=
+ >=dev-python/ipython-0.11[${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+ ${PYTHON_DEPS}
+"
+DEPEND="${RDEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Leave shebang alone
+ sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die
+
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_install() {
+ installing() {
+ gnome2_src_install
+ python_doscript src/accerciser
+ }
+ python_foreach_impl run_in_build_dir installing
+}
diff --git a/app-accessibility/accerciser/metadata.xml b/app-accessibility/accerciser/metadata.xml
new file mode 100644
index 000000000000..b361a7a06606
--- /dev/null
+++ b/app-accessibility/accerciser/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+ <longdescription lang="en">
+Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.
+
+In essence, Accerciser is a next generation at-poke tool.
+</longdescription>
+</pkgmetadata>