summaryrefslogtreecommitdiff
path: root/acct-user/syncthing
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /acct-user/syncthing
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'acct-user/syncthing')
-rw-r--r--acct-user/syncthing/Manifest2
-rw-r--r--acct-user/syncthing/metadata.xml8
-rw-r--r--acct-user/syncthing/syncthing-0.ebuild14
3 files changed, 24 insertions, 0 deletions
diff --git a/acct-user/syncthing/Manifest b/acct-user/syncthing/Manifest
new file mode 100644
index 000000000000..efa1ebdb7e11
--- /dev/null
+++ b/acct-user/syncthing/Manifest
@@ -0,0 +1,2 @@
+EBUILD syncthing-0.ebuild 319 BLAKE2B ddbb152f1fc63efcd43b07a46897ff53458cb99d24d04652a60207eb2213b25594d73c760689810210e9eb350e2fcc69487935a980c658e09ec191e0502c87cf SHA512 b6cc977a4118417f14498d0d492e7d40e995baf8faf81c9b38e27b6256b3fac324acaefce93cf4a623b9ac90c4818a7b05a360a613bf20b1e4fbb8a6fa5d8b1f
+MISC metadata.xml 245 BLAKE2B 1564b4d8e674e807191dcc857c12585eaf336e3418e110853e311b2851b382ca8931b46a96230677251bf3784004879d8498cae2dae11c9289f4a8606dfa5d7f SHA512 bd2ae86e550344a79551fe0383e4625d28ca6fad675d84c66fc5b22ed7fe3afbfc2b4d6a7b1a5d02f6efbc56950b8295270a3dba8a1e7e51fde80a370d0c868a
diff --git a/acct-user/syncthing/metadata.xml b/acct-user/syncthing/metadata.xml
new file mode 100644
index 000000000000..3e5026ee3754
--- /dev/null
+++ b/acct-user/syncthing/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/acct-user/syncthing/syncthing-0.ebuild b/acct-user/syncthing/syncthing-0.ebuild
new file mode 100644
index 000000000000..136d34e4cdb2
--- /dev/null
+++ b/acct-user/syncthing/syncthing-0.ebuild
@@ -0,0 +1,14 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit acct-user
+
+DESCRIPTION="User for the system-wide net-p2p/syncthing server"
+ACCT_USER_ID=499
+ACCT_USER_HOME=/var/lib/syncthing
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( syncthing )
+
+acct-user_add_deps