summaryrefslogtreecommitdiff
path: root/acct-user/stdiscosrv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /acct-user/stdiscosrv
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'acct-user/stdiscosrv')
-rw-r--r--acct-user/stdiscosrv/Manifest1
-rw-r--r--acct-user/stdiscosrv/stdiscosrv-1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/acct-user/stdiscosrv/Manifest b/acct-user/stdiscosrv/Manifest
index 9cb682507cdf..2ac4ea99df44 100644
--- a/acct-user/stdiscosrv/Manifest
+++ b/acct-user/stdiscosrv/Manifest
@@ -1,2 +1,3 @@
EBUILD stdiscosrv-0-r1.ebuild 316 BLAKE2B 51aa673f3f033d7ba7fbff43444d8281ad670a8e6af6d6ea3e522e5396c034c31adabe647f7d90931c192b00770a1ed30c26a6f16d07dfddf5c1f49932ed40ec SHA512 50a18cd26f7f6753d308a44ec56a089014037f0ddeab52c96bae9513aba2510d7abf35d6428b28b1337787fecaa9fa553ead771111f5864447a88ff6cdcc0d18
+EBUILD stdiscosrv-1.ebuild 682 BLAKE2B 2bd28a6db284f6ad8693703e16bfae5f7ce8183546b8e6945e0ae44cf01c32d2452eda673e39e63b42b741a449d66a09833a8337caa076603f5ec749b3630210 SHA512 c4147a460c29581da50c689107a467c9d61b559932eb56225bcc08d740d227578c2577cbf1011a2721c24aa89097644569bd4668db3dd9dc00a3560f01bd5e2f
MISC metadata.xml 246 BLAKE2B f808bbbcb9c53d005d1a1667cd6217a601a3bd3bd2267121c0043a870ae44bb91bb27bc9825d5d6eafe01b73fe58a553655aa252737c0b066f2286ff9415d65e SHA512 b620abb7732628010a8a3792d40bde878492be97ce14c99c4d2466240df2f25edf7734ad4d210bc954f27323f0e26698e660766c65be5868646a3866020373fd
diff --git a/acct-user/stdiscosrv/stdiscosrv-1.ebuild b/acct-user/stdiscosrv/stdiscosrv-1.ebuild
new file mode 100644
index 000000000000..fc1db7a4a130
--- /dev/null
+++ b/acct-user/stdiscosrv/stdiscosrv-1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit acct-user
+
+DESCRIPTION="User for the Syncthing discovery server"
+ACCT_USER_ID=497
+ACCT_USER_HOME=/var/lib/syncthing-discosrv
+ACCT_USER_HOME_PERMS=0770
+ACCT_USER_GROUPS=( syncthing )
+
+acct-user_add_deps
+
+pkg_postinst() {
+ if [[ -n "${REPLACING_VERSIONS}" ]]; then
+ local rver
+ for rver in ${REPLACING_VERSIONS} ; do
+ if ver_test "${rver}" -lt 1; then
+ ewarn "The home directory of this user has changed to /var/lib/syncthing-discosrv"
+ ewarn "If you have any files in /var/lib/${PN}, move them to the new location by hand"
+ break
+ fi
+ done
+ fi
+}